Revert "Import oneTBB 2021.5.0 as wip/onetbb"
authorCharlotte Koch <charlotte@NetBSD.org>
Thu, 11 Aug 2022 04:28:06 +0000 (21:28 -0700)
committerCharlotte Koch <charlotte@NetBSD.org>
Thu, 11 Aug 2022 04:28:06 +0000 (21:28 -0700)
This reverts commit 4ab57a7d7089a326b434660bbb5038a2c91f092b.

It already exists as parallel/threadingbuildingblocks, lol

We should probably get rid of wip/threadingbuildingblocks and wip/tbb

Makefile
onetbb/DESCR [deleted file]
onetbb/Makefile [deleted file]
onetbb/PLIST [deleted file]
onetbb/distinfo [deleted file]
onetbb/patches/patch-cmake_compilers_GNU.cmake [deleted file]

index 3ab2ef3ada610976da71cf1df877f0c8d8a99e8f..cd43ffff394c9dc62f7873c371dfc0aae10f3e27 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -2715,7 +2715,6 @@ SUBDIR+=  olsrd
 SUBDIR+=       omega
 SUBDIR+=       omnispeak
 SUBDIR+=       oneloop
-SUBDIR+=       onetbb
 SUBDIR+=       oolite
 SUBDIR+=       oops
 SUBDIR+=       oorexx
diff --git a/onetbb/DESCR b/onetbb/DESCR
deleted file mode 100644 (file)
index 2491aa9..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-oneTBB is a flexible C++ library that simplifies the work of adding parallelism
-to complex applications, even if you are not a threading expert.
-
-The library lets you easily write parallel programs that take full advantage of
-the multi-core performance. Such programs are portable, composable and have a
-future-proof scalability. oneTBB provides you with functions, interfaces, and
-classes to parallelize and scale the code. All you have to do is to use the
-templates.
-
-
diff --git a/onetbb/Makefile b/onetbb/Makefile
deleted file mode 100644 (file)
index 4608399..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-# $NetBSD$
-
-DISTNAME=      onetbb-2021.5.0
-CATEGORIES=    devel
-MASTER_SITES=  ${MASTER_SITE_GITHUB:=oneapi-src/}
-GITHUB_TAG=    v${PKGVERSION_NOREV}
-
-MAINTAINER=    charlotte@NetBSD.org
-HOMEPAGE=      https://oneapi-src.github.io/oneTBB/
-COMMENT=       oneAPI Threading Building Blocks
-LICENSE=       apache-2.0
-
-WRKSRC=                ${WRKDIR}/oneTBB-${PKGVERSION_NOREV}
-
-USE_LANGUAGES+=        c c++
-
-USE_CMAKE=     yes
-
-CMAKE_ARGS+=   -DTBB_EXAMPLES:BOOL=OFF
-CMAKE_ARGS+=   -DTBB_TEST:BOOL=OFF
-
-.include "../../mk/bsd.pkg.mk"
diff --git a/onetbb/PLIST b/onetbb/PLIST
deleted file mode 100644 (file)
index f92b975..0000000
+++ /dev/null
@@ -1,155 +0,0 @@
-@comment $NetBSD$
-include/oneapi/tbb.h
-include/oneapi/tbb/blocked_range.h
-include/oneapi/tbb/blocked_range2d.h
-include/oneapi/tbb/blocked_range3d.h
-include/oneapi/tbb/blocked_rangeNd.h
-include/oneapi/tbb/cache_aligned_allocator.h
-include/oneapi/tbb/collaborative_call_once.h
-include/oneapi/tbb/combinable.h
-include/oneapi/tbb/concurrent_hash_map.h
-include/oneapi/tbb/concurrent_lru_cache.h
-include/oneapi/tbb/concurrent_map.h
-include/oneapi/tbb/concurrent_priority_queue.h
-include/oneapi/tbb/concurrent_queue.h
-include/oneapi/tbb/concurrent_set.h
-include/oneapi/tbb/concurrent_unordered_map.h
-include/oneapi/tbb/concurrent_unordered_set.h
-include/oneapi/tbb/concurrent_vector.h
-include/oneapi/tbb/detail/_aggregator.h
-include/oneapi/tbb/detail/_aligned_space.h
-include/oneapi/tbb/detail/_allocator_traits.h
-include/oneapi/tbb/detail/_assert.h
-include/oneapi/tbb/detail/_concurrent_queue_base.h
-include/oneapi/tbb/detail/_concurrent_skip_list.h
-include/oneapi/tbb/detail/_concurrent_unordered_base.h
-include/oneapi/tbb/detail/_config.h
-include/oneapi/tbb/detail/_containers_helpers.h
-include/oneapi/tbb/detail/_exception.h
-include/oneapi/tbb/detail/_export.h
-include/oneapi/tbb/detail/_flow_graph_body_impl.h
-include/oneapi/tbb/detail/_flow_graph_cache_impl.h
-include/oneapi/tbb/detail/_flow_graph_impl.h
-include/oneapi/tbb/detail/_flow_graph_indexer_impl.h
-include/oneapi/tbb/detail/_flow_graph_item_buffer_impl.h
-include/oneapi/tbb/detail/_flow_graph_join_impl.h
-include/oneapi/tbb/detail/_flow_graph_node_impl.h
-include/oneapi/tbb/detail/_flow_graph_node_set_impl.h
-include/oneapi/tbb/detail/_flow_graph_nodes_deduction.h
-include/oneapi/tbb/detail/_flow_graph_tagged_buffer_impl.h
-include/oneapi/tbb/detail/_flow_graph_trace_impl.h
-include/oneapi/tbb/detail/_flow_graph_types_impl.h
-include/oneapi/tbb/detail/_hash_compare.h
-include/oneapi/tbb/detail/_intrusive_list_node.h
-include/oneapi/tbb/detail/_machine.h
-include/oneapi/tbb/detail/_mutex_common.h
-include/oneapi/tbb/detail/_namespace_injection.h
-include/oneapi/tbb/detail/_node_handle.h
-include/oneapi/tbb/detail/_pipeline_filters.h
-include/oneapi/tbb/detail/_pipeline_filters_deduction.h
-include/oneapi/tbb/detail/_range_common.h
-include/oneapi/tbb/detail/_rtm_mutex.h
-include/oneapi/tbb/detail/_rtm_rw_mutex.h
-include/oneapi/tbb/detail/_scoped_lock.h
-include/oneapi/tbb/detail/_segment_table.h
-include/oneapi/tbb/detail/_small_object_pool.h
-include/oneapi/tbb/detail/_string_resource.h
-include/oneapi/tbb/detail/_task.h
-include/oneapi/tbb/detail/_task_handle.h
-include/oneapi/tbb/detail/_template_helpers.h
-include/oneapi/tbb/detail/_utils.h
-include/oneapi/tbb/detail/_waitable_atomic.h
-include/oneapi/tbb/enumerable_thread_specific.h
-include/oneapi/tbb/flow_graph.h
-include/oneapi/tbb/flow_graph_abstractions.h
-include/oneapi/tbb/global_control.h
-include/oneapi/tbb/info.h
-include/oneapi/tbb/memory_pool.h
-include/oneapi/tbb/mutex.h
-include/oneapi/tbb/null_mutex.h
-include/oneapi/tbb/null_rw_mutex.h
-include/oneapi/tbb/parallel_for.h
-include/oneapi/tbb/parallel_for_each.h
-include/oneapi/tbb/parallel_invoke.h
-include/oneapi/tbb/parallel_pipeline.h
-include/oneapi/tbb/parallel_reduce.h
-include/oneapi/tbb/parallel_scan.h
-include/oneapi/tbb/parallel_sort.h
-include/oneapi/tbb/partitioner.h
-include/oneapi/tbb/profiling.h
-include/oneapi/tbb/queuing_mutex.h
-include/oneapi/tbb/queuing_rw_mutex.h
-include/oneapi/tbb/rw_mutex.h
-include/oneapi/tbb/scalable_allocator.h
-include/oneapi/tbb/spin_mutex.h
-include/oneapi/tbb/spin_rw_mutex.h
-include/oneapi/tbb/task.h
-include/oneapi/tbb/task_arena.h
-include/oneapi/tbb/task_group.h
-include/oneapi/tbb/task_scheduler_observer.h
-include/oneapi/tbb/tbb_allocator.h
-include/oneapi/tbb/tbbmalloc_proxy.h
-include/oneapi/tbb/tick_count.h
-include/oneapi/tbb/version.h
-include/tbb/blocked_range.h
-include/tbb/blocked_range2d.h
-include/tbb/blocked_range3d.h
-include/tbb/blocked_rangeNd.h
-include/tbb/cache_aligned_allocator.h
-include/tbb/collaborative_call_once.h
-include/tbb/combinable.h
-include/tbb/concurrent_hash_map.h
-include/tbb/concurrent_lru_cache.h
-include/tbb/concurrent_map.h
-include/tbb/concurrent_priority_queue.h
-include/tbb/concurrent_queue.h
-include/tbb/concurrent_set.h
-include/tbb/concurrent_unordered_map.h
-include/tbb/concurrent_unordered_set.h
-include/tbb/concurrent_vector.h
-include/tbb/enumerable_thread_specific.h
-include/tbb/flow_graph.h
-include/tbb/flow_graph_abstractions.h
-include/tbb/global_control.h
-include/tbb/info.h
-include/tbb/memory_pool.h
-include/tbb/null_mutex.h
-include/tbb/null_rw_mutex.h
-include/tbb/parallel_for.h
-include/tbb/parallel_for_each.h
-include/tbb/parallel_invoke.h
-include/tbb/parallel_pipeline.h
-include/tbb/parallel_reduce.h
-include/tbb/parallel_scan.h
-include/tbb/parallel_sort.h
-include/tbb/partitioner.h
-include/tbb/profiling.h
-include/tbb/queuing_mutex.h
-include/tbb/queuing_rw_mutex.h
-include/tbb/scalable_allocator.h
-include/tbb/spin_mutex.h
-include/tbb/spin_rw_mutex.h
-include/tbb/task.h
-include/tbb/task_arena.h
-include/tbb/task_group.h
-include/tbb/task_scheduler_observer.h
-include/tbb/tbb.h
-include/tbb/tbb_allocator.h
-include/tbb/tbbmalloc_proxy.h
-include/tbb/tick_count.h
-include/tbb/version.h
-lib/cmake/TBB/TBBConfig.cmake
-lib/cmake/TBB/TBBConfigVersion.cmake
-lib/cmake/TBB/TBBTargets-relwithdebinfo.cmake
-lib/cmake/TBB/TBBTargets.cmake
-lib/libtbb.so
-lib/libtbb.so.12
-lib/libtbb.so.12.5
-lib/libtbbmalloc.so
-lib/libtbbmalloc.so.2
-lib/libtbbmalloc.so.2.5
-lib/libtbbmalloc_proxy.so
-lib/libtbbmalloc_proxy.so.2
-lib/libtbbmalloc_proxy.so.2.5
-lib/pkgconfig/tbb.pc
-share/doc/TBB/README.md
diff --git a/onetbb/distinfo b/onetbb/distinfo
deleted file mode 100644 (file)
index 1fb024e..0000000
+++ /dev/null
@@ -1,6 +0,0 @@
-$NetBSD$
-
-BLAKE2s (onetbb-2021.5.0.tar.gz) = 570452be4c16d646d781f41449c52caa4d9e580ba7bbd777085e88b955979e26
-SHA512 (onetbb-2021.5.0.tar.gz) = 0e7b71022e397a6d7abb0cea106847935ae79a1e12a6976f8d038668c6eca8775ed971202c5bd518f7e517092b67af805cc5feb04b5c3a40e9fbf972cc703a46
-Size (onetbb-2021.5.0.tar.gz) = 2463218 bytes
-SHA1 (patch-cmake_compilers_GNU.cmake) = e17b242427860668ae265dcd4593f6aebd903a76
diff --git a/onetbb/patches/patch-cmake_compilers_GNU.cmake b/onetbb/patches/patch-cmake_compilers_GNU.cmake
deleted file mode 100644 (file)
index 52eca6e..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-$NetBSD$
-
-Don't link against libdl on NetBSD.
---- cmake/compilers/GNU.cmake.orig     2022-08-10 20:30:17.538194226 -0700
-+++ cmake/compilers/GNU.cmake  2022-08-10 20:31:26.829818970 -0700
-@@ -40,7 +40,7 @@
-     set(TBB_COMMON_COMPILE_FLAGS ${TBB_COMMON_COMPILE_FLAGS} -mrtm $<$<AND:$<NOT:$<CXX_COMPILER_ID:Intel>>,$<NOT:$<VERSION_LESS:${CMAKE_CXX_COMPILER_VERSION},11.0>>>:-mwaitpkg>)
- endif()
--if (NOT MINGW)
-+if (NOT MINGW AND NOT ${CMAKE_SYSTEM_NAME} STREQUAL "NetBSD")
-     set(TBB_COMMON_LINK_LIBS dl)
- endif()