Update fs-uae to release 2.6.1.
authorOlaf Seibert <rhialto@falu.nl>
Fri, 9 Oct 2015 10:43:25 +0000 (12:43 +0200)
committerOlaf Seibert <rhialto@falu.nl>
Fri, 9 Oct 2015 10:45:59 +0000 (12:45 +0200)
From http://fs-uae.net/2015/09/20/fs-uae-2-6-1-released:

Improvements over version 2.4.x include:

    Updated emulation code from WinUAE 3.1.0.
    Support for PPC emulation (can run AmigaOS 4.x) via QEMU-UAE plugin.
    More emulated hardware support (Toccata, A2061, Picasso IV, #).
    Better support for modern OS versions due to using SDL 2.0.
    Built-in support for multiple displays, and fixes for HiDPI displays.
    The Launcher supports modern OS versions better due to using QT 5.x.
    Much improved FS-UAE Launcher user interface.
    FS-UAE mouse integration (Workbench cursor follows host cursor).
    Updated internal kickstart replacement from AROS.
    Dual joystick/mouse mode for joystick port 0.
    Official builds for SteamOS (Linux + Steam runtime).
    OS X apps are now digitally signed (Apple Developer ID).
    Support for JIT direct memory access (much faster JIT).
    Many bug fixes.
    # and a lot of other improvements. See the changelog entries for (But for all details concerning changes since 2.4.1, you can read through the changelogs for FS-UAE and FS-UAE Launcher for all the details.

Support for IPF disk images is now provided by a plugin which you need to download separately. [[ not included in pkgsrc ]]

15 files changed:
fs-uae/DESCR
fs-uae/Makefile
fs-uae/PLIST
fs-uae/distinfo
fs-uae/patches/patch-Makefile [deleted file]
fs-uae/patches/patch-common.mk [deleted file]
fs-uae/patches/patch-libfsemu_Makefile [deleted file]
fs-uae/patches/patch-libfsemu_src_emu_input.c [deleted file]
fs-uae/patches/patch-libfsemu_src_filesys.c [deleted file]
fs-uae/patches/patch-libfsemu_src_ml_manymouse_x11__xinput2.c [deleted file]
fs-uae/patches/patch-libfsemu_src_ml_ml.c [deleted file]
fs-uae/patches/patch-libfsemu_src_ml_x11.c
fs-uae/patches/patch-manymouse_x11__xinput2.c [new file with mode: 0644]
fs-uae/patches/patch-src_od-fs_bsdsocket__posix.cpp
fs-uae/patches/patch-src_od-fs_mman.cpp [new file with mode: 0644]

index 56005d54432351659b98ae96229df97e58ed7e44..54040638f5ccad1e59ea64acd3a6962ec2a6d9dd 100644 (file)
@@ -1,20 +1,21 @@
-This is a fork of UAE, the Ubiquitous Amiga Emulator, with an emulation core
-based on WinUAE. It attempts to bring many of the great features of WinUAE
-to non-Windows platforms.
+FS-UAE is an Amiga emulator for Windows, Linux and Mac OS X
+based on UAE/WinUAE, with a focus on emulating games.
 
-FS-UAE focuses on emulating Amiga games using the accurate emulation
-code from WinUAE. It also has features to emulate a high-end Amiga with
-expansions.
+Features include emulation of Amiga 500, 1200, 4000, CD32
+and CDTV, perfectly smooth scrolling on 50Hz displays, support
+for floppy images in ADF and IPF formats, CD-ROM images in ISO
+or BIN/CUE format, mounting folders on your computer as Amiga
+hard drives, support for Picasso 96 drivers for high-color and
+high-resolution Workbench displays, and more.
 
-Unique features for FS-UAE are support for online play on all supported
-platforms and an on-screen GUI controllable with keyboard and gamepad
-controllers.
+A unique feature is support for cross-platform online play. You
+can now play Amiga games against (or with) friends over the
+Internet.
 
-To make full use of FS-UAE you will need access to an image of some version
-of the Amiga Kickstart ROM (although UAE does include a ROM emulation which
-may work with some old games). The Amiga Kickstart ROMs are copyrighted
-material and may not be freely distributed (so don't ask me for a copy). If
-you don't have an Amiga from which you can legally make a ROM image, a
-selection of ROM images are available for purchase online from Cloanto
-(publishers of the Amiga Forever distribution). See
-http://www.amigaforever.com/
+The emulator uses the latest Amiga emulation code from the
+WinUAE project and requires a moderately fast computer with
+accelerated graphics (OpenGL) to work. A game pad or joystick is
+recommended, but not required (FS-UAE can emulate a joystick
+using the cursor keys and right ctrl/alt keys).
+
+libfs-capsimage is needed for IPF floppy image support.
index 40e157930899da4901209a2dd29b0c7b74b242c5..7ac49992e363f4744838e22adaf9cf46c864ebc9 100644 (file)
@@ -1,42 +1,36 @@
-# $NetBSD: Makefile,v 1.6 2014/07/13 17:18:39 rhialto Exp $
+# $NetBSD: Makefile,v 1.10 2015/06/22 16:21:18 rhialto Exp $
 
-VERSION=       2.4.1
-DISTNAME=      fs-uae-${VERSION}
+DISTNAME=      fs-uae-2.6.1
 CATEGORIES=    emulators
-MASTER_SITES=  http://fs-uae.net/fs-uae/stable/${VERSION}/
+MASTER_SITES=  http://fs-uae.net/fs-uae/stable/${PKGVERSION_NOREV}/
 
 MAINTAINER=    rhialto@falu.nl
 HOMEPAGE=      http://fs-uae.net/
 COMMENT=       FS-UAE Amiga Emulator
 LICENSE=       gnu-gpl-v2
 
-MAKE_JOBS_SAFE=        no
+USE_LANGUAGES=         c c++
+USE_TOOLS+=            pkg-config zip
+GNU_CONFIGURE=         yes
 
-USE_TOOLS+=    gmake pkg-config
-USE_LANGUAGES+=        c c++
-NO_CONFIGURE=  yes
+#CONFIGURE_ARGS += --enable-lua
 
-PKG_CFLAGS=    -I${BUILDLINK_PREFIX.openal}/include
-PKG_LDFLAGS=   ${COMPILER_RPATH_FLAG}${BUILDLINK_PREFIX.openal}/lib
-PKG_LDFLAGS+=  -L${BUILDLINK_PREFIX.openal}/lib
-
-BUILD_ENV+=    X11_CFLAGS=-I${BUILDLINK_PREFIX.libX11}/include
-BUILD_ENV+=    X11_LDFLAGS=${X11_LDFLAGS}
-BUILD_ENV+=    PKG_CFLAGS=${PKG_CFLAGS}
-BUILD_ENV+=    PKG_LDFLAGS=${PKG_LDFLAGS}
-
-INSTALL_ENV+=  prefix=${PREFIX}
-INSTALL_ENV+=  DESTDIR=${DESTDIR}
+.include "../../mk/bsd.prefs.mk"
+.if ${OPSYS} != "Darwin"
+.include "../../graphics/MesaLib/buildlink3.mk"
+.include "../../graphics/glu/buildlink3.mk"
+.include "../../x11/libX11/buildlink3.mk"
+.include "../../x11/libXi/buildlink3.mk"
+.endif
 
 .include "../../audio/openal/buildlink3.mk"
-.include "../../devel/SDL/buildlink3.mk"
+.include "../../devel/SDL2/buildlink3.mk"
 .include "../../devel/glib2/buildlink3.mk"
 .include "../../devel/zlib/buildlink3.mk"
-.include "../../graphics/MesaLib/buildlink3.mk"
 .include "../../graphics/freetype2/buildlink3.mk"
+.include "../../graphics/glew/buildlink3.mk"
 .include "../../graphics/hicolor-icon-theme/buildlink3.mk"
 .include "../../graphics/png/buildlink3.mk"
+#.include "../../multimedia/libmpeg2/buildlink3.mk"
 .include "../../sysutils/desktop-file-utils/desktopdb.mk"
-.include "../../x11/libX11/buildlink3.mk"
-
 .include "../../mk/bsd.pkg.mk"
index 685de29885873e62b20f5cf206691a1672fb1cfe..bc69738c4679b9de4310e0a7d582633067b0cc41 100644 (file)
@@ -1,13 +1,14 @@
-@comment $NetBSD: PLIST,v 1.3 2014/07/13 17:18:39 rhialto Exp $
+@comment $NetBSD: PLIST,v 1.7 2015/06/22 16:21:18 rhialto Exp $
 bin/fs-uae
 bin/fs-uae-device-helper
 share/applications/fs-uae.desktop
 share/doc/fs-uae/COPYING
 share/doc/fs-uae/README
-share/doc/fs-uae/example.conf
 share/fs-uae/2x_1920_1080/theme.conf
 share/fs-uae/2x_1920_1080_bezel/overlay.png
 share/fs-uae/2x_1920_1080_bezel/theme.conf
+share/fs-uae/aros-amiga-m68k-ext.bin
+share/fs-uae/aros-amiga-m68k-rom.bin
 share/fs-uae/aspect.png
 share/fs-uae/close.png
 share/fs-uae/floppy_sounds/drive_click.wav
@@ -15,35 +16,92 @@ share/fs-uae/floppy_sounds/drive_snatch.wav
 share/fs-uae/floppy_sounds/drive_spin.wav
 share/fs-uae/floppy_sounds/drive_spinnd.wav
 share/fs-uae/floppy_sounds/drive_startup.wav
+share/fs-uae/fs-uae.dat
 share/fs-uae/gloss.png
 share/fs-uae/glow_left.png
 share/fs-uae/glow_top.png
 share/fs-uae/glow_top_left.png
 share/fs-uae/heading_strip.png
+share/fs-uae/input/00000000000000000000000000000000.fs-uae-controller
+share/fs-uae/input/030000000b0400003365000000010000.fs-uae-controller
+share/fs-uae/input/03000000300f00001201000010010000.fs-uae-controller
 share/fs-uae/input/03000000300f00001201000010010000/jess_tech_dual_analog_pad_12_4_1_0_linux.conf
 share/fs-uae/input/03000000300f00001201000010010000/names.txt
+share/fs-uae/input/030000004c0500006802000011010000.fs-uae-controller
 share/fs-uae/input/030000004c0500006802000011010000/names.txt
 share/fs-uae/input/030000004c0500006802000011010000/sony_playstation_r_3_controller_19_27_0_0_linux.conf
+share/fs-uae/input/030000004c050000c405000011010000.fs-uae-controller
+share/fs-uae/input/030000004f04000015b3000010010000.fs-uae-controller
+share/fs-uae/input/030000004f04000020b3000010010000.fs-uae-controller
 share/fs-uae/input/030000004f04000020b3000010010000/names.txt
 share/fs-uae/input/030000004f04000020b3000010010000/thrustmaster_2_in_1_dt_12_4_1_0_linux.conf
+share/fs-uae/input/030000005e0400001907000000010000.fs-uae-controller
 share/fs-uae/input/030000005e0400001907000000010000/names.txt
 share/fs-uae/input/030000005e0400001907000000010000/xbox_360_wireless_receiver_15_6_0_0_linux.conf
+share/fs-uae/input/030000005e0400008e02000014010000.fs-uae-controller
 share/fs-uae/input/030000005e0400008e02000014010000/microsoft_x_box_360_pad_11_6_1_0_linux.conf
 share/fs-uae/input/030000005e0400008e02000014010000/names.txt
+share/fs-uae/input/030000005e040000d102000001010000.fs-uae-controller
+share/fs-uae/input/030000006d04000019c2000011010000.fs-uae-controller
 share/fs-uae/input/030000006d04000019c2000011010000/logitech_logitech_cordless_rumblepad_2_12_4_1_0_linux.conf
 share/fs-uae/input/030000006d04000019c2000011010000/names.txt
+share/fs-uae/input/030000006d0400001dc2000014400000.fs-uae-controller
 share/fs-uae/input/030000006d0400001dc2000014400000/generic_x_box_pad_11_6_1_0_linux.conf
 share/fs-uae/input/030000006d0400001dc2000014400000/names.txt
+share/fs-uae/input/030000006d0400001ec2000020200000.fs-uae-controller
 share/fs-uae/input/030000006d0400001ec2000020200000/generic_x_box_pad_11_6_1_0_linux.conf
 share/fs-uae/input/030000006d0400001ec2000020200000/names.txt
+share/fs-uae/input/030000006d0400001fc2000005030000.fs-uae-controller
 share/fs-uae/input/030000006d0400001fc2000005030000/generic_x_box_pad_11_6_1_0_linux.conf
 share/fs-uae/input/030000006d0400001fc2000005030000/names.txt
+share/fs-uae/input/030000006d040000d2ca000011010000.fs-uae-controller
 share/fs-uae/input/030000006d040000d2ca000011010000/names.txt
 share/fs-uae/input/030000006d040000d2ca000011010000/ps3_usb_cordless_gamepad_13_4_1_0_linux.conf
+share/fs-uae/input/03000000790000001100000010010000.fs-uae-controller
+share/fs-uae/input/0300000081170000990a000001010000.fs-uae-controller
+share/fs-uae/input/03000000830500006020000010010000.fs-uae-controller
+share/fs-uae/input/03000000a30600000901000000010000.fs-uae-controller
 share/fs-uae/input/03000000a30600000901000000010000/names.txt
 share/fs-uae/input/03000000a30600000901000000010000/saitek_p880_12_4_1_0_linux.conf
+share/fs-uae/input/0b040000000000003365000000000000.fs-uae-controller
+share/fs-uae/input/0b043365000000000000504944564944.fs-uae-controller
 share/fs-uae/input/2_in_1_dt_12_4_1_0_macosx.conf
 share/fs-uae/input/2_in_1_dt_12_4_1_0_windows.conf
+share/fs-uae/input/300f0000000000001201000000000000.fs-uae-controller
+share/fs-uae/input/300f1201000000000000504944564944.fs-uae-controller
+share/fs-uae/input/4c050000000000006802000000000000.fs-uae-controller
+share/fs-uae/input/4c05000000000000c405000000000000.fs-uae-controller
+share/fs-uae/input/4c05c405000000000000504944564944.fs-uae-controller
+share/fs-uae/input/4f0400000000000015b3000000000000.fs-uae-controller
+share/fs-uae/input/4f0400000000000020b3000000000000.fs-uae-controller
+share/fs-uae/input/4f0415b3000000000000504944564944.fs-uae-controller
+share/fs-uae/input/4f0420b3000000000000504944564944.fs-uae-controller
+share/fs-uae/input/5e040000000000008e02000000000000.fs-uae-controller
+share/fs-uae/input/5e048e02000000000000504944564944.fs-uae-controller
+share/fs-uae/input/5e04a102000000000000504944564944.fs-uae-controller
+share/fs-uae/input/5e04d102000000000000504944564944.fs-uae-controller
+share/fs-uae/input/6d0400000000000016c2000000000000.fs-uae-controller
+share/fs-uae/input/6d0400000000000018c2000000000000.fs-uae-controller
+share/fs-uae/input/6d0400000000000019c2000000000000.fs-uae-controller
+share/fs-uae/input/6d040000000000001dc2000000000000.fs-uae-controller
+share/fs-uae/input/6d040000000000001ec2000000000000.fs-uae-controller
+share/fs-uae/input/6d040000000000001fc2000000000000.fs-uae-controller
+share/fs-uae/input/6d04000000000000d2ca000000000000.fs-uae-controller
+share/fs-uae/input/6d0416c2000000000000504944564944.fs-uae-controller
+share/fs-uae/input/6d0418c2000000000000504944564944.fs-uae-controller
+share/fs-uae/input/6d0419c2000000000000504944564944.fs-uae-controller
+share/fs-uae/input/6d041dc2000000000000504944564944.fs-uae-controller
+share/fs-uae/input/6d041ec2000000000000504944564944.fs-uae-controller
+share/fs-uae/input/6d041fc2000000000000504944564944.fs-uae-controller
+share/fs-uae/input/6d04d2ca000000000000504944564944.fs-uae-controller
+share/fs-uae/input/8117000000000000990a000000000000.fs-uae-controller
+share/fs-uae/input/8117990a000000000000504944564944.fs-uae-controller
+share/fs-uae/input/83050000000000006020000000000000.fs-uae-controller
+share/fs-uae/input/83056020000000000000504944564944.fs-uae-controller
+share/fs-uae/input/92125441000000000000504944564944.fs-uae-controller
+share/fs-uae/input/a3060000000000000901000000000000.fs-uae-controller
+share/fs-uae/input/a3060901000000000000504944564944.fs-uae-controller
+share/fs-uae/input/atari_controller_usb_1_2_0_0_windows.conf
 share/fs-uae/input/common/gamepad.ini
 share/fs-uae/input/common/xarcade.ini
 share/fs-uae/input/common/xinput_gamepad.ini
@@ -52,6 +110,7 @@ share/fs-uae/input/controller_rumble_gamepad_f510_10_5_1_0_windows.conf
 share/fs-uae/input/controller_wireless_gamepad_f710_10_5_1_0_windows.conf
 share/fs-uae/input/controller_xbox_360_for_windows_10_5_1_0_windows.conf
 share/fs-uae/input/controller_xbox_360_wireless_receiver_for_windows_10_5_1_0_windows.conf
+share/fs-uae/input/controller_xbox_one_for_windows_11_6_1_0_windows.conf
 share/fs-uae/input/custom/custom_x_arcade.ini
 share/fs-uae/input/custom/custom_x_arcade_right.ini
 share/fs-uae/input/dual_analog_pad_12_4_1_0_macosx.conf
@@ -59,6 +118,7 @@ share/fs-uae/input/dual_analog_pad_12_4_1_0_windows.conf
 share/fs-uae/input/gamtec_ltd/smartjoy_plus_adapter.ini
 share/fs-uae/input/generic/keyboard.ini
 share/fs-uae/input/generic/mouse.ini
+share/fs-uae/input/jess_tech_dual_analog_pad_12_4_1_0_linux.conf
 share/fs-uae/input/linux/saitek_dual_analog_pad_12_4_1_0_linux.conf
 share/fs-uae/input/logitech/controller_rumble_gamepad_f510.ini
 share/fs-uae/input/logitech/controller_wireless_gamepad_f710.ini
@@ -70,9 +130,16 @@ share/fs-uae/input/logitech/logitech_extreme_3d.ini
 share/fs-uae/input/logitech/logitech_extreme_3d_pro.ini
 share/fs-uae/input/logitech/logitech_rumblepad_2.ini
 share/fs-uae/input/logitech/ps3_usb_cordless_gamepad.ini
+share/fs-uae/input/logitech_cordless_rumblepad_2_12_4_1_0_macosx.conf
+share/fs-uae/input/logitech_cordless_rumblepad_2_12_4_1_0_windows.conf
 share/fs-uae/input/logitech_cordless_rumblepad_2_usb_12_4_1_0_windows.conf
 share/fs-uae/input/logitech_dual_action_12_4_1_0_macosx.conf
+share/fs-uae/input/logitech_dual_action_12_4_1_0_windows.conf
 share/fs-uae/input/logitech_dual_action_usb_12_4_1_0_windows.conf
+share/fs-uae/input/logitech_gamepad_f310_11_6_1_0_linux.conf
+share/fs-uae/input/logitech_gamepad_f510_11_6_1_0_linux.conf
+share/fs-uae/input/logitech_gamepad_f710_11_6_1_0_linux.conf
+share/fs-uae/input/logitech_logitech_cordless_rumblepad_2_12_4_1_0_linux.conf
 share/fs-uae/input/logitech_r_precision_tm_gamepad_10_2_0_0_windows.conf
 share/fs-uae/input/logitech_rumblepad_2_usb_12_4_1_0_macosx.conf
 share/fs-uae/input/logitech_rumblepad_2_usb_12_4_1_0_windows.conf
@@ -85,30 +152,62 @@ share/fs-uae/input/microsoft/x_box_360_pad.ini
 share/fs-uae/input/microsoft/xbox_360_for_windows_controller.ini
 share/fs-uae/input/microsoft/xbox_360_wireless_receiver.ini
 share/fs-uae/input/microsoft/xbox_360_wireless_receiver_for_windows_controller.ini
+share/fs-uae/input/microsoft_x_box_360_pad_11_6_1_0_linux.conf
+share/fs-uae/input/microsoft_x_box_one_pad_11_6_1_0_linux.conf
 share/fs-uae/input/mosic/a_speed_link_competition_pro.ini
 share/fs-uae/input/mosic/speed_link_competition_pro.ini
 share/fs-uae/input/mosic/usb_2a4k_gamepad.ini
+share/fs-uae/input/mosic_speed_link_competition_pro_4_2_0_0_linux.conf
 share/fs-uae/input/other/retro_joystick_interface_v1_2.ini
 share/fs-uae/input/other/usb_2_axis_8_button_gamepad.ini
 share/fs-uae/input/p880_12_4_1_0_macosx.conf
 share/fs-uae/input/p880_12_4_1_0_windows.conf
 share/fs-uae/input/playstation_r_3_controller_19_4_0_0_macosx.conf
+share/fs-uae/input/ps3_usb_cordless_gamepad_13_4_1_0_linux.conf
 share/fs-uae/input/ps3_usb_cordless_gamepad_13_4_1_0_macosx.conf
 share/fs-uae/input/ps3_usb_cordless_gamepad_13_4_1_0_windows.conf
+share/fs-uae/input/retro_joystick_adapter_v2_0_3_2_0_0_macosx.conf
+share/fs-uae/input/retro_joystick_adapter_v2_0_3_2_0_0_windows.conf
+share/fs-uae/input/retrolink/usb_gamepad_10_2_0_0_linux.ini
+share/fs-uae/input/retronicdesign_com_retro_joystick_adapter_v2_0_8_2_0_0_linux.conf
 share/fs-uae/input/saitek/dual_analog_gamepad.ini
 share/fs-uae/input/saitek/p880.ini
+share/fs-uae/input/saitek/x52_flight_control_system.ini
+share/fs-uae/input/saitek_p880_12_4_1_0_linux.conf
 share/fs-uae/input/sony/computer_entertainment_wireless_inputdevice.ini
 share/fs-uae/input/sony/playstation_r_3_controller.ini
 share/fs-uae/input/sony/playstation_r_3_inputdevice.ini
+share/fs-uae/input/sony_computer_entertainment_wireless_controller_14_10_1_0_linux.conf
+share/fs-uae/input/sony_playstation_r_3_controller_19_27_0_0_linux.conf
+share/fs-uae/input/speed_link_competition_pro_4_2_0_0_macosx.conf
 share/fs-uae/input/speed_link_competition_pro_4_2_0_0_windows.conf
+share/fs-uae/input/speedlink_strike_2_gamepad_12_5_1_0_windows.conf
 share/fs-uae/input/thrustmaster/2_in_1_dt.ini
 share/fs-uae/input/thrustmaster/t_mini_wireless.ini
+share/fs-uae/input/thrustmaster/top_gun_fox_2_pro.ini
+share/fs-uae/input/thrustmaster_2_in_1_dt_12_4_1_0_linux.conf
+share/fs-uae/input/thrustmaster_dual_analog_3_2_12_4_1_0_macosx.conf
+share/fs-uae/input/thrustmaster_dual_analog_3_2_12_4_1_0_windows.conf
+share/fs-uae/input/thrustmaster_thrustmaster_dual_analog_3_2_12_4_1_0_linux.conf
 share/fs-uae/input/universal_gamepad.ini
 share/fs-uae/input/unknown.ini
+share/fs-uae/input/usb_2_axis_8_button_gamepad_8_2_0_0_linux.conf
+share/fs-uae/input/usb_2_axis_8_button_gamepad_8_2_0_0_macosx.conf
+share/fs-uae/input/usb_2_axis_8_button_gamepad_8_2_0_0_windows.conf
+share/fs-uae/input/usb_gamepad_10_2_0_0_linux.conf
+share/fs-uae/input/wireless_360_controller_15_6_0_0_macosx.conf
+share/fs-uae/input/wireless_controller_14_6_1_0_macosx.conf
+share/fs-uae/input/wireless_controller_14_6_1_0_windows.conf
 share/fs-uae/input/wisegroup_ltd/mp_8866_dual_usb_joypad.ini
 share/fs-uae/input/wisegroup_ltd/tigergame_ps_ps2_game_controller_adapter.ini
+share/fs-uae/input/x360controller_16_6_0_0_macosx.conf
+share/fs-uae/input/xbox_360_wired_controller_15_6_0_0_macosx.conf
+share/fs-uae/input/xbox_360_wireless_receiver_15_6_0_0_linux.conf
+share/fs-uae/input/xbox_one_wired_controller_15_6_0_0_macosx.conf
 share/fs-uae/input/xgaming/x_arcade.ini
 share/fs-uae/input/xgaming/x_arcade_right.ini
+share/fs-uae/input/xinput_controller_15_6_0_0_windows.conf
+share/fs-uae/input/zeemote/steelseries_free.ini
 share/fs-uae/item_background.png
 share/fs-uae/led-bars-edge/audio_led_1.png
 share/fs-uae/led-bars-edge/audio_led_2.png
@@ -207,6 +306,7 @@ share/icons/hicolor/64x64/apps/fs-uae.png
 share/locale/cs/LC_MESSAGES/fs-uae.mo
 share/locale/da/LC_MESSAGES/fs-uae.mo
 share/locale/de/LC_MESSAGES/fs-uae.mo
+share/locale/el/LC_MESSAGES/fs-uae.mo
 share/locale/es/LC_MESSAGES/fs-uae.mo
 share/locale/fi/LC_MESSAGES/fs-uae.mo
 share/locale/fr/LC_MESSAGES/fs-uae.mo
@@ -214,5 +314,8 @@ share/locale/it/LC_MESSAGES/fs-uae.mo
 share/locale/nb/LC_MESSAGES/fs-uae.mo
 share/locale/pl/LC_MESSAGES/fs-uae.mo
 share/locale/pt/LC_MESSAGES/fs-uae.mo
+share/locale/pt_BR/LC_MESSAGES/fs-uae.mo
 share/locale/sr/LC_MESSAGES/fs-uae.mo
+share/locale/sv/LC_MESSAGES/fs-uae.mo
 share/locale/tr/LC_MESSAGES/fs-uae.mo
+share/mime/packages/fs-uae.xml
index bcfc41839d6aeaa253968d773ab7e217a50c22e5..bbf4f0f08822403341c660f71f7d3673df02cd42 100644 (file)
@@ -1,14 +1,9 @@
 $NetBSD: distinfo,v 1.3 2014/07/13 17:18:39 rhialto Exp $
 
-SHA1 (fs-uae-2.4.1.tar.gz) = 7a2e0723789b12d1cafc4f19202238403289018a
-RMD160 (fs-uae-2.4.1.tar.gz) = 0965b9281e72eb35d3d1fd7ca1d111ad7e4f775b
-Size (fs-uae-2.4.1.tar.gz) = 4393812 bytes
-SHA1 (patch-Makefile) = 7f54cd3982bcb61f8250e0957c4363f4c56b888d
-SHA1 (patch-common.mk) = eed577f604cc5e99b31f850eaf6c3a24790cc718
-SHA1 (patch-libfsemu_Makefile) = a195c62ad50f6113e92f27bb9d37fbd4800abaa5
-SHA1 (patch-libfsemu_src_emu_input.c) = f29ddb4b15213a52acabdc46234765ffef37d380
-SHA1 (patch-libfsemu_src_filesys.c) = 2db4fb1c6459d36656205fdebc978ac1203b06e6
-SHA1 (patch-libfsemu_src_ml_manymouse_x11__xinput2.c) = 905dea1c7bc604b126abf1a6c3268c5b33554f78
-SHA1 (patch-libfsemu_src_ml_ml.c) = c68ae38054a2920a5c628d6b9682911340b3d9f5
-SHA1 (patch-libfsemu_src_ml_x11.c) = 9ca726ee11c475b44b0c25a1e1e6eb157547eb32
-SHA1 (patch-src_od-fs_bsdsocket__posix.cpp) = a66abde2441715094c413d7498947ff8eb5d0b8a
+SHA1 (fs-uae-2.6.1.tar.gz) = c4697d1ea96d7606f3776ad8ea94edb9dbbe40fe
+RMD160 (fs-uae-2.6.1.tar.gz) = 5bad9a9e4856339d7f37a4d2471b6b02458390c1
+Size (fs-uae-2.6.1.tar.gz) = 4575004 bytes
+SHA1 (patch-libfsemu_src_ml_x11.c) = aabd87d77dcca0c520cc225f9a9e17b682f751f2
+SHA1 (patch-manymouse_x11__xinput2.c) = 023690aeb0fef33894338f057a98e3cf22078df5
+SHA1 (patch-src_od-fs_bsdsocket__posix.cpp) = 5c3fe4ead3506c72609ced19ca243d74bd44765d
+SHA1 (patch-src_od-fs_mman.cpp) = 93b85dabe2e7eb326c7c8ecfa8a038189c042da2
diff --git a/fs-uae/patches/patch-Makefile b/fs-uae/patches/patch-Makefile
deleted file mode 100644 (file)
index dbfbe41..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-$NetBSD: patch-Makefile,v 1.2 2014/07/13 17:18:39 rhialto Exp $
-
---- Makefile.orig      2014-03-22 12:05:05.000000000 +0000
-+++ Makefile
-@@ -167,6 +167,11 @@ else ifeq ($(os), kfreebsd)\r
- else ifeq ($(os), freebsd)\r
-   cppflags += -DFREEBSD\r
-   libs += -lGL -lGLU -lopenal -lX11 -lcompat\r
-+else ifeq ($(os), netbsd)
-+  cppflags += -DNETBSD $(PKG_CFLAGS) $(X11_CFLAGS)
-+  libs += -lGL -lGLU -lopenal -lX11 -lcompat \
-+        $(PKG_LDFLAGS) \
-+        $(X11_LDFLAGS)
- else ifeq ($(os), openbsd)\r
-   cppflags += -DOPENBSD\r
-   libs += -lGL -lGLU -lopenal -lX11 -lcompat\r
diff --git a/fs-uae/patches/patch-common.mk b/fs-uae/patches/patch-common.mk
deleted file mode 100644 (file)
index 34cde0a..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-$NetBSD: patch-common.mk,v 1.1 2013/10/25 22:02:17 rhialto Exp $
-
-Add support for NetBSD.
-
---- common.mk.orig     2013-06-25 19:21:16.000000000 +0000
-+++ common.mk
-@@ -35,6 +35,14 @@ cxx = $(CXX)
- ar = $(AR)
- make = gmake
-+else ifneq ($(findstring NetBSD,$(uname)),)
-+
-+os = netbsd
-+cc = $(CC)
-+cxx = $(CXX)
-+ar = $(AR)
-+make = gmake
-+
- else ifneq ($(findstring OpenBSD,$(uname)),)
- os = openbsd
-@@ -56,5 +64,5 @@ debug := 0
- devel := 0
- optimize := 1
- noflags := 0
--prefix := /usr
-+prefix ?= /usr
- docdir := $(prefix)/share/doc/fs-uae
diff --git a/fs-uae/patches/patch-libfsemu_Makefile b/fs-uae/patches/patch-libfsemu_Makefile
deleted file mode 100644 (file)
index 718a3b9..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
-$NetBSD: patch-libfsemu_Makefile,v 1.1 2013/10/25 22:02:17 rhialto Exp $
-
-Add support for NetBSD.
-
---- libfsemu/Makefile.orig     2013-06-25 19:21:16.000000000 +0000
-+++ libfsemu/Makefile
-@@ -5,6 +5,8 @@ else ifneq ($(findstring Darwin,$(uname)
-     os = macosx
- else ifneq ($(findstring FreeBSD,$(uname)),)
-     os = freebsd
-+else ifneq ($(findstring NetBSD,$(uname)),)
-+    os = netbsd
- else ifneq ($(findstring OpenBSD,$(uname)),)
-     os = openbsd
- else
-@@ -32,6 +34,11 @@ else
-       ar = $(AR)
- endif
-+ifeq ($(os), netbsd)
-+      CFLAGS += $(X11_CFLAGS)
-+      LDFLAGS += $(X11_LDFLAGS)
-+endif
-+
- arch :=
- debug := 0
- noflags := 0
-@@ -159,6 +166,8 @@ else
-               cppflags += -DLINUX
-       else ifeq ($(os), freebsd)
-               cppflags += -DFREEBSD
-+      else ifeq ($(os), netbsd)
-+              cppflags += -DNETBSD
-       else ifeq ($(os), openbsd)
-               cppflags += -DOPENBSD
-       endif
diff --git a/fs-uae/patches/patch-libfsemu_src_emu_input.c b/fs-uae/patches/patch-libfsemu_src_emu_input.c
deleted file mode 100644 (file)
index 6a262c6..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-$NetBSD: patch-libfsemu_src_emu_input.c,v 1.1 2013/10/25 22:02:17 rhialto Exp $
-
-Add support for NetBSD.
-
---- libfsemu/src/emu/input.c.orig      2013-06-25 19:21:16.000000000 +0000
-+++ libfsemu/src/emu/input.c
-@@ -480,6 +480,8 @@ static char *joystick_long_config_name(c
-     const char *platform = "linux";
- #elif defined(FREEBSD)
-     const char *platform = "freebsd";
-+#elif defined(NETBSD)
-+    const char *platform = "netbsd";
- #elif defined(OPENBSD)
-     const char *platform = "openbsd";
- #else
diff --git a/fs-uae/patches/patch-libfsemu_src_filesys.c b/fs-uae/patches/patch-libfsemu_src_filesys.c
deleted file mode 100644 (file)
index b3500b5..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-$NetBSD: patch-libfsemu_src_filesys.c,v 1.1 2013/10/25 22:02:17 rhialto Exp $
-
-Add support for NetBSD.
-
---- libfsemu/src/filesys.c.orig        2013-06-25 19:21:16.000000000 +0000
-+++ libfsemu/src/filesys.c
-@@ -126,7 +126,7 @@ static void file_time_to_time_val(FILETI
- #if defined(WINDOWS)
--#elif defined(MACOSX)
-+#elif defined(MACOSX) || defined(NETBSD)
- #define HAVE_STAT_TV_NSEC2
- #else
- #define HAVE_STAT_TV_NSEC
diff --git a/fs-uae/patches/patch-libfsemu_src_ml_manymouse_x11__xinput2.c b/fs-uae/patches/patch-libfsemu_src_ml_manymouse_x11__xinput2.c
deleted file mode 100644 (file)
index 3d5c8b3..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-$NetBSD: patch-libfsemu_src_ml_manymouse_x11__xinput2.c,v 1.1 2014/07/13 17:18:39 rhialto Exp $
-
-Include proper header file.
-
---- libfsemu/src/ml/manymouse/x11_xinput2.c.orig       2014-05-13 17:57:41.000000000 +0000
-+++ libfsemu/src/ml/manymouse/x11_xinput2.c
-@@ -25,6 +25,7 @@
- #include <stdlib.h>
- #include <string.h>
- #include <dlfcn.h>
-+#include <sys/select.h>
- #include <X11/extensions/XInput2.h>
- /* 32 is good enough for now. */
diff --git a/fs-uae/patches/patch-libfsemu_src_ml_ml.c b/fs-uae/patches/patch-libfsemu_src_ml_ml.c
deleted file mode 100644 (file)
index 214851c..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-$NetBSD: patch-libfsemu_src_ml_ml.c,v 1.1 2013/10/25 22:02:17 rhialto Exp $
-
-Add support for NetBSD.
-
---- libfsemu/src/ml/ml.c.orig  2013-06-25 19:21:16.000000000 +0000
-+++ libfsemu/src/ml/ml.c
-@@ -287,6 +287,8 @@ void fs_ml_init() {
-     fs_log("LINUX\n");
- #elif defined(FREEBSD)
-     fs_log("FREEBSD\n");
-+#elif defined(NETBSD)
-+    fs_log("NETBSD\n");
- #elif defined(OPENBSD)
-     fs_log("OPENBSD\n");
- #else
index bacc1dae0d04c3606f34c11ffe35aa1e9aa172d5..feebbf81e1d4b1f623e8c37c349a26aaa91431fd 100644 (file)
@@ -1,24 +1,24 @@
-$NetBSD: patch-libfsemu_src_ml_x11.c,v 1.1 2014/04/05 21:56:02 rhialto Exp $
+$NetBSD: patch-libfsemu_src_ml_x11.c,v 1.5 2014/12/24 20:17:47 rhialto Exp $
 
 Don't map control and caps lock keys: the user might have them swapped.
 
---- libfsemu/src/ml/x11.c.orig 2013-10-27 20:16:45.000000000 +0000
+--- libfsemu/src/ml/x11.c.orig 2015-08-25 13:35:59.000000000 +0000
 +++ libfsemu/src/ml/x11.c
-@@ -294,7 +294,7 @@ void fs_ml_initialize_keymap() {
+@@ -356,7 +356,7 @@ void fs_ml_initialize_keymap() {
      g_key_map[35] = FS_ML_KEY_RIGHTBRACKET;
      g_key_map[36] = FS_ML_KEY_RETURN;
  
 -    g_key_map[66] = FS_ML_KEY_CAPSLOCK;
-+    //g_key_map[66] = FS_ML_KEY_CAPSLOCK;
++    /*g_key_map[66] = FS_ML_KEY_CAPSLOCK;*/
      g_key_map[38] = FS_ML_KEY_A;
      g_key_map[39] = FS_ML_KEY_S;
      g_key_map[40] = FS_ML_KEY_D;
-@@ -322,7 +322,7 @@ void fs_ml_initialize_keymap() {
+@@ -384,7 +384,7 @@ void fs_ml_initialize_keymap() {
      g_key_map[61] = FS_ML_KEY_SLASH;
      g_key_map[62] = FS_ML_KEY_RSHIFT;
  
 -    g_key_map[37] = FS_ML_KEY_LCTRL;
-+    //g_key_map[37] = FS_ML_KEY_LCTRL;
++    /*g_key_map[37] = FS_ML_KEY_LCTRL;*/
      g_key_map[64] = FS_ML_KEY_LALT;
      g_key_map[65] = FS_ML_KEY_SPACE;
  
diff --git a/fs-uae/patches/patch-manymouse_x11__xinput2.c b/fs-uae/patches/patch-manymouse_x11__xinput2.c
new file mode 100644 (file)
index 0000000..faecfa4
--- /dev/null
@@ -0,0 +1,14 @@
+$NetBSD: patch-manymouse_x11__xinput2.c,v 1.2 2014/12/24 20:17:47 rhialto Exp $
+
+Include proper header file.
+
+--- manymouse/x11_xinput2.c.orig       2015-08-25 13:35:59.000000000 +0000
++++ manymouse/x11_xinput2.c
+@@ -25,6 +25,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <dlfcn.h>
++#include <sys/select.h>
+ #include <X11/extensions/XInput2.h>
+ /* 32 is good enough for now. */
index 42fb1abd7e60cc3f962beb732266fcd7f6e7f682..019814c46b095eec27f3ab44c60a42cc6ee83d0d 100644 (file)
@@ -1,10 +1,10 @@
-$NetBSD: patch-src_od-fs_bsdsocket__posix.cpp,v 1.1 2013/10/25 22:02:17 rhialto Exp $
+$NetBSD: patch-src_od-fs_bsdsocket__posix.cpp,v 1.5 2014/12/24 20:17:47 rhialto Exp $
 
 u_int8_t * won't automagically become const char *.
 
---- src/od-fs/bsdsocket_posix.cpp.orig 2013-06-25 19:21:16.000000000 +0000
+--- src/od-fs/bsdsocket_posix.cpp.orig 2015-09-20 19:51:19.000000000 +0000
 +++ src/od-fs/bsdsocket_posix.cpp
-@@ -929,7 +929,7 @@ static void *bsdlib_threadfunc (void *ar
+@@ -926,7 +926,7 @@ static void *bsdlib_threadfunc (void *ar
          break;
  
          case 7: {
diff --git a/fs-uae/patches/patch-src_od-fs_mman.cpp b/fs-uae/patches/patch-src_od-fs_mman.cpp
new file mode 100644 (file)
index 0000000..e63725d
--- /dev/null
@@ -0,0 +1,26 @@
+$NetBSD$
+
+--- src/od-fs/mman.cpp.orig    2015-10-09 10:30:03.000000000 +0000
++++ src/od-fs/mman.cpp
+@@ -50,12 +50,6 @@ static void GetSystemInfo(SYSTEM_INFO *s
+ #define USE_MMAP
+-#ifdef USE_MMAP
+-#ifdef MACOSX
+-#define MAP_ANONYMOUS MAP_ANON
+-#endif
+-#endif
+-
+ static void *VirtualAlloc(void *lpAddress, size_t dwSize, int flAllocationType,
+               int flProtect)
+ {
+@@ -97,7 +91,7 @@ static void *VirtualAlloc(void *lpAddres
+       if (flAllocationType & MEM_RESERVE) {
+ #ifdef USE_MMAP
+-              memory = mmap(lpAddress, dwSize, 0, MAP_PRIVATE | MAP_ANONYMOUS, -1, 0);
++              memory = mmap(lpAddress, dwSize, 0, MAP_PRIVATE | MAP_ANON, -1, 0);
+               if (memory == (void *) -1) {
+                       write_log("mmap failed errno %d\n", errno);
+                       return NULL;