signify: fix linking libs on Solaris after last change
authorPaolo Vincenzo Olivo <vms@retrobsd.ddns.net>
Wed, 6 Jul 2022 09:19:08 +0000 (11:19 +0200)
committerPaolo Vincenzo Olivo <vms@retrobsd.ddns.net>
Wed, 6 Jul 2022 09:30:52 +0000 (11:30 +0200)
signify: fix linking libs on Solaris after last change.

Explicity set LIBS for all targets to match pkgsrc defaults.
Append any required additional library to the global definitiion and
then pass LIBS to the internal make.

This prevents gmake from resetting LIBS to the projects's defaultis.
Such behaviour became evident on Solaris, as singify was failing to
build on SunOS followinf the last change.

signify/Makefile

index dc2849cf496e5a9422b40fdeac9d799b460f163a..993bcdf54fd7e5a075c72bd07524b48c0a0da428 100644 (file)
@@ -13,7 +13,9 @@ COMMENT=      Cryptographically sign and verify files, from OpenBSD
 LICENSE=       original-bsd AND modified-bsd AND isc AND public-domain
 
 USE_TOOLS+=    gmake
-MAKEFLAGS+=    ALL=src/usr.bin/signify/signify
+MAKE_FLAGS+=   ALL=src/usr.bin/signify/signify
+MAKE_FLAGS+=   LIBS=${LIBS:Q}
+LIBS+=         -lm
 
 INSTALLATION_DIRS=     bin ${PKGMANDIR}/man1
 MAKE_DIRS+=            ${PKG_SYSCONFDIR}/signify