libgweather4: Import libgweather-4.4.4 as wip/libgweather4
authorDan Cîrnaț <dan@alt.md>
Fri, 13 Dec 2024 20:29:16 +0000 (21:29 +0100)
committerDan Cîrnaț <dan@alt.md>
Fri, 13 Dec 2024 20:29:16 +0000 (21:29 +0100)
Makefile
libgweather4/DESCR [new file with mode: 0644]
libgweather4/Makefile [new file with mode: 0644]
libgweather4/PLIST [new file with mode: 0644]
libgweather4/TODO [new file with mode: 0644]
libgweather4/buildlink3.mk [new file with mode: 0644]
libgweather4/distinfo [new file with mode: 0644]

index bdee5db55614a5cfa26c49896623d712cb02f196..b65acb54748962de3f32b9c351933ecefe2333bf 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -2038,6 +2038,7 @@ SUBDIR+=  libgtop
 SUBDIR+=       libgudev
 SUBDIR+=       libguestfs-appliance
 SUBDIR+=       libgusb
+SUBDIR+=       libgweather4
 SUBDIR+=       libgxim
 SUBDIR+=       libgzstream
 SUBDIR+=       libhttpd
diff --git a/libgweather4/DESCR b/libgweather4/DESCR
new file mode 100644 (file)
index 0000000..d0aefd3
--- /dev/null
@@ -0,0 +1,2 @@
+libgweather is a library to access weather information from online
+services for numerous locations.
diff --git a/libgweather4/Makefile b/libgweather4/Makefile
new file mode 100644 (file)
index 0000000..646d414
--- /dev/null
@@ -0,0 +1,34 @@
+# $NetBSD: Makefile,v 1.115 2024/11/17 07:15:45 wiz Exp $
+
+DISTNAME=      libgweather-4.4.4
+PKGNAME=       ${DISTNAME:S/weather/weather4/}
+CATEGORIES=    devel gnome
+MASTER_SITES=  ${MASTER_SITE_GNOME:=sources/${PKGBASE}/4.4/}
+EXTRACT_SUFX=  .tar.xz
+
+MAINTAINER=    pkgsrc-users@NetBSD.org
+HOMEPAGE=      https://wiki.gnome.org/Projects/LibGWeather
+COMMENT=       Weather information access library
+LICENSE=       gnu-gpl-v2
+
+USE_TOOLS+=    pkg-config xgettext
+
+PYTHON_FOR_BUILD_ONLY=         tool
+PYTHON_VERSIONS_INCOMPATIBLE=  27
+
+MESON_ARGS+=   -Dgtk_doc=false
+
+PKGCONFIG_OVERRIDE_STAGE=      pre-install
+PKGCONFIG_OVERRIDE+=           output/meson-private/gweather-3.0.pc
+
+TOOL_DEPENDS+=         py${PYTHON_VERSION_DEFAULT}-gobject3-[0-9]*:../../devel/py-gobject3
+
+.include "../../devel/meson/build.mk"
+.include "../../devel/gobject-introspection/buildlink3.mk"
+.include "../../wip/geocode-glib2/buildlink3.mk"
+.include "../../net/libsoup3/buildlink3.mk"
+.include "../../textproc/json-glib/buildlink3.mk"
+.include "../../lang/python/tool.mk"
+.include "../../lang/vala/buildlink3.mk"
+.include "../../textproc/libxml2/buildlink3.mk"
+.include "../../mk/bsd.pkg.mk"
diff --git a/libgweather4/PLIST b/libgweather4/PLIST
new file mode 100644 (file)
index 0000000..a68dec6
--- /dev/null
@@ -0,0 +1,222 @@
+@comment $NetBSD$
+include/libgweather-4.0/libgweather/gweather-enum-types.h
+include/libgweather-4.0/libgweather/gweather-enums.h
+include/libgweather-4.0/libgweather/gweather-info.h
+include/libgweather-4.0/libgweather/gweather-location.h
+include/libgweather-4.0/libgweather/gweather-version.h
+include/libgweather-4.0/libgweather/gweather.h
+lib/girepository-1.0/GWeather-4.0.typelib
+lib/libgweather-4.so
+lib/libgweather-4.so.0
+lib/libgweather-4.so.0.400.4
+lib/libgweather-4/Locations.bin
+lib/pkgconfig/gweather4.pc
+share/gir-1.0/GWeather-4.0.gir
+share/glib-2.0/schemas/org.gnome.GWeather4.enums.xml
+share/glib-2.0/schemas/org.gnome.GWeather4.gschema.xml
+share/libgweather-4/Locations.xml
+share/libgweather-4/locations.dtd
+share/locale/ab/LC_MESSAGES/libgweather-4.0.mo
+share/locale/af/LC_MESSAGES/libgweather-4.0.mo
+share/locale/am/LC_MESSAGES/libgweather-4.0.mo
+share/locale/ang/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/ar/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/ar/LC_MESSAGES/libgweather-4.0.mo
+share/locale/as/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/as/LC_MESSAGES/libgweather-4.0.mo
+share/locale/ast/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/ast/LC_MESSAGES/libgweather-4.0.mo
+share/locale/az/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/az/LC_MESSAGES/libgweather-4.0.mo
+share/locale/be/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/be/LC_MESSAGES/libgweather-4.0.mo
+share/locale/be@latin/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/be@latin/LC_MESSAGES/libgweather-4.0.mo
+share/locale/bg/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/bg/LC_MESSAGES/libgweather-4.0.mo
+share/locale/bn/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/bn/LC_MESSAGES/libgweather-4.0.mo
+share/locale/bn_IN/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/bn_IN/LC_MESSAGES/libgweather-4.0.mo
+share/locale/br/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/br/LC_MESSAGES/libgweather-4.0.mo
+share/locale/bs/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/bs/LC_MESSAGES/libgweather-4.0.mo
+share/locale/ca/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/ca/LC_MESSAGES/libgweather-4.0.mo
+share/locale/ca@valencia/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/ca@valencia/LC_MESSAGES/libgweather-4.0.mo
+share/locale/crh/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/crh/LC_MESSAGES/libgweather-4.0.mo
+share/locale/cs/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/cs/LC_MESSAGES/libgweather-4.0.mo
+share/locale/cy/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/cy/LC_MESSAGES/libgweather-4.0.mo
+share/locale/da/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/da/LC_MESSAGES/libgweather-4.0.mo
+share/locale/de/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/de/LC_MESSAGES/libgweather-4.0.mo
+share/locale/dz/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/dz/LC_MESSAGES/libgweather-4.0.mo
+share/locale/el/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/el/LC_MESSAGES/libgweather-4.0.mo
+share/locale/en@shaw/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/en@shaw/LC_MESSAGES/libgweather-4.0.mo
+share/locale/en_CA/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/en_CA/LC_MESSAGES/libgweather-4.0.mo
+share/locale/en_GB/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/en_GB/LC_MESSAGES/libgweather-4.0.mo
+share/locale/eo/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/eo/LC_MESSAGES/libgweather-4.0.mo
+share/locale/es/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/es/LC_MESSAGES/libgweather-4.0.mo
+share/locale/es_AR/LC_MESSAGES/libgweather-4.0.mo
+share/locale/es_CL/LC_MESSAGES/libgweather-4.0.mo
+share/locale/es_CO/LC_MESSAGES/libgweather-4.0.mo
+share/locale/es_CR/LC_MESSAGES/libgweather-4.0.mo
+share/locale/es_DO/LC_MESSAGES/libgweather-4.0.mo
+share/locale/es_EC/LC_MESSAGES/libgweather-4.0.mo
+share/locale/es_ES/LC_MESSAGES/libgweather-4.0.mo
+share/locale/es_GT/LC_MESSAGES/libgweather-4.0.mo
+share/locale/es_HN/LC_MESSAGES/libgweather-4.0.mo
+share/locale/es_MX/LC_MESSAGES/libgweather-4.0.mo
+share/locale/es_NI/LC_MESSAGES/libgweather-4.0.mo
+share/locale/es_PA/LC_MESSAGES/libgweather-4.0.mo
+share/locale/es_PE/LC_MESSAGES/libgweather-4.0.mo
+share/locale/es_PR/LC_MESSAGES/libgweather-4.0.mo
+share/locale/es_SV/LC_MESSAGES/libgweather-4.0.mo
+share/locale/es_UY/LC_MESSAGES/libgweather-4.0.mo
+share/locale/es_VE/LC_MESSAGES/libgweather-4.0.mo
+share/locale/et/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/et/LC_MESSAGES/libgweather-4.0.mo
+share/locale/eu/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/eu/LC_MESSAGES/libgweather-4.0.mo
+share/locale/fa/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/fa/LC_MESSAGES/libgweather-4.0.mo
+share/locale/fi/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/fi/LC_MESSAGES/libgweather-4.0.mo
+share/locale/fr/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/fr/LC_MESSAGES/libgweather-4.0.mo
+share/locale/fur/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/fur/LC_MESSAGES/libgweather-4.0.mo
+share/locale/ga/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/ga/LC_MESSAGES/libgweather-4.0.mo
+share/locale/gd/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/gd/LC_MESSAGES/libgweather-4.0.mo
+share/locale/gl/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/gl/LC_MESSAGES/libgweather-4.0.mo
+share/locale/gu/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/gu/LC_MESSAGES/libgweather-4.0.mo
+share/locale/he/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/he/LC_MESSAGES/libgweather-4.0.mo
+share/locale/hi/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/hi/LC_MESSAGES/libgweather-4.0.mo
+share/locale/hr/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/hr/LC_MESSAGES/libgweather-4.0.mo
+share/locale/hu/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/hu/LC_MESSAGES/libgweather-4.0.mo
+share/locale/hy/LC_MESSAGES/libgweather-4.0.mo
+share/locale/id/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/id/LC_MESSAGES/libgweather-4.0.mo
+share/locale/is/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/is/LC_MESSAGES/libgweather-4.0.mo
+share/locale/it/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/it/LC_MESSAGES/libgweather-4.0.mo
+share/locale/ja/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/ja/LC_MESSAGES/libgweather-4.0.mo
+share/locale/ka/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/ka/LC_MESSAGES/libgweather-4.0.mo
+share/locale/kab/LC_MESSAGES/libgweather-4.0.mo
+share/locale/kk/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/kk/LC_MESSAGES/libgweather-4.0.mo
+share/locale/kn/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/kn/LC_MESSAGES/libgweather-4.0.mo
+share/locale/ko/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/ko/LC_MESSAGES/libgweather-4.0.mo
+share/locale/ku/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/ku/LC_MESSAGES/libgweather-4.0.mo
+share/locale/ky/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/ky/LC_MESSAGES/libgweather-4.0.mo
+share/locale/lt/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/lt/LC_MESSAGES/libgweather-4.0.mo
+share/locale/lv/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/lv/LC_MESSAGES/libgweather-4.0.mo
+share/locale/mai/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/mai/LC_MESSAGES/libgweather-4.0.mo
+share/locale/mg/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/mg/LC_MESSAGES/libgweather-4.0.mo
+share/locale/mk/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/mk/LC_MESSAGES/libgweather-4.0.mo
+share/locale/ml/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/ml/LC_MESSAGES/libgweather-4.0.mo
+share/locale/mn/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/mn/LC_MESSAGES/libgweather-4.0.mo
+share/locale/mr/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/mr/LC_MESSAGES/libgweather-4.0.mo
+share/locale/ms/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/ms/LC_MESSAGES/libgweather-4.0.mo
+share/locale/nb/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/nb/LC_MESSAGES/libgweather-4.0.mo
+share/locale/nds/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/ne/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/ne/LC_MESSAGES/libgweather-4.0.mo
+share/locale/nl/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/nl/LC_MESSAGES/libgweather-4.0.mo
+share/locale/nn/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/nn/LC_MESSAGES/libgweather-4.0.mo
+share/locale/oc/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/oc/LC_MESSAGES/libgweather-4.0.mo
+share/locale/or/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/or/LC_MESSAGES/libgweather-4.0.mo
+share/locale/pa/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/pa/LC_MESSAGES/libgweather-4.0.mo
+share/locale/pl/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/pl/LC_MESSAGES/libgweather-4.0.mo
+share/locale/pt/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/pt/LC_MESSAGES/libgweather-4.0.mo
+share/locale/pt_BR/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/pt_BR/LC_MESSAGES/libgweather-4.0.mo
+share/locale/ro/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/ro/LC_MESSAGES/libgweather-4.0.mo
+share/locale/ru/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/ru/LC_MESSAGES/libgweather-4.0.mo
+share/locale/rw/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/rw/LC_MESSAGES/libgweather-4.0.mo
+share/locale/si/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/si/LC_MESSAGES/libgweather-4.0.mo
+share/locale/sk/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/sk/LC_MESSAGES/libgweather-4.0.mo
+share/locale/sl/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/sl/LC_MESSAGES/libgweather-4.0.mo
+share/locale/sq/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/sq/LC_MESSAGES/libgweather-4.0.mo
+share/locale/sr/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/sr/LC_MESSAGES/libgweather-4.0.mo
+share/locale/sr@latin/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/sr@latin/LC_MESSAGES/libgweather-4.0.mo
+share/locale/sv/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/sv/LC_MESSAGES/libgweather-4.0.mo
+share/locale/ta/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/ta/LC_MESSAGES/libgweather-4.0.mo
+share/locale/te/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/te/LC_MESSAGES/libgweather-4.0.mo
+share/locale/th/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/th/LC_MESSAGES/libgweather-4.0.mo
+share/locale/tr/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/tr/LC_MESSAGES/libgweather-4.0.mo
+share/locale/ug/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/ug/LC_MESSAGES/libgweather-4.0.mo
+share/locale/uk/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/uk/LC_MESSAGES/libgweather-4.0.mo
+share/locale/vi/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/vi/LC_MESSAGES/libgweather-4.0.mo
+share/locale/wa/LC_MESSAGES/libgweather-4.0.mo
+share/locale/xh/LC_MESSAGES/libgweather-4.0.mo
+share/locale/zh_CN/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/zh_CN/LC_MESSAGES/libgweather-4.0.mo
+share/locale/zh_HK/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/zh_HK/LC_MESSAGES/libgweather-4.0.mo
+share/locale/zh_TW/LC_MESSAGES/libgweather-4.0-locations.mo
+share/locale/zh_TW/LC_MESSAGES/libgweather-4.0.mo
+share/vala/vapi/gweather4.deps
+share/vala/vapi/gweather4.vapi
diff --git a/libgweather4/TODO b/libgweather4/TODO
new file mode 100644 (file)
index 0000000..0a89c25
--- /dev/null
@@ -0,0 +1 @@
+* build gtk_doc (fails because of meson wrap)
diff --git a/libgweather4/buildlink3.mk b/libgweather4/buildlink3.mk
new file mode 100644 (file)
index 0000000..177bf9a
--- /dev/null
@@ -0,0 +1,16 @@
+# $NetBSD: buildlink3.mk,v 1.85 2024/11/17 07:15:45 wiz Exp $
+
+BUILDLINK_TREE+=       libgweather4
+
+.if !defined(LIBGWEATHER4_BUILDLINK3_MK)
+LIBGWEATHER4_BUILDLINK3_MK:=
+
+BUILDLINK_API_DEPENDS.libgweather4+=   libgweather4>=4.4
+BUILDLINK_ABI_DEPENDS.libgweather4+=   libgweather4>=4.4
+BUILDLINK_PKGSRCDIR.libgweather4?=     ../../wip/libgweather4
+
+.include "../../wip/geocode-glib2/buildlink3.mk"
+.include "../../net/libsoup3/buildlink3.mk"
+.endif # LIBGWEATHER4_BUILDLINK3_MK
+
+BUILDLINK_TREE+=       -libgweather4
diff --git a/libgweather4/distinfo b/libgweather4/distinfo
new file mode 100644 (file)
index 0000000..8eec9a0
--- /dev/null
@@ -0,0 +1,5 @@
+$NetBSD: distinfo,v 1.19 2021/10/26 10:15:21 nia Exp $
+
+BLAKE2s (libgweather-4.4.4.tar.xz) = 0c29da5b64436a8f96bd0a7616545018e669ac1a547b1520db2ac83a2e4ee19c
+SHA512 (libgweather-4.4.4.tar.xz) = 2140c742a89a3816ef0e20d0eac570bbc4af058d1c94982b08819740132e7ca56eb9597b3817385310d19d7f1ab6d478fb665770f99db1eca1c0aab1c073dd2f
+Size (libgweather-4.4.4.tar.xz) = 2843040 bytes