Add py-cutadapt: Finds and removes adapter sequences, primers, poly-A tails, etc
authorJason Bacon <bacon4000@gmail.com>
Fri, 3 Nov 2017 16:35:58 +0000 (11:35 -0500)
committerJason Bacon <bacon4000@gmail.com>
Fri, 3 Nov 2017 16:35:58 +0000 (11:35 -0500)
Makefile
py-cutadapt/DESCR [new file with mode: 0644]
py-cutadapt/Makefile [new file with mode: 0644]
py-cutadapt/PLIST [new file with mode: 0644]
py-cutadapt/TODO [new file with mode: 0644]
py-cutadapt/buildlink3.mk [new file with mode: 0644]
py-cutadapt/distinfo [new file with mode: 0644]

index b016fcbe8c8958873ee095d3487d2cc2e6e650db..9912ebf596c3261c5c458aed89102d79cb92a064 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -2972,6 +2972,7 @@ SUBDIR+=  py-cse
 SUBDIR+=       py-csp
 SUBDIR+=       py-ctutils
 SUBDIR+=       py-cubicweb
+SUBDIR+=       py-cutadapt
 SUBDIR+=       py-cva
 SUBDIR+=       py-cvf
 SUBDIR+=       py-cvxpy
diff --git a/py-cutadapt/DESCR b/py-cutadapt/DESCR
new file mode 100644 (file)
index 0000000..044b13c
--- /dev/null
@@ -0,0 +1,4 @@
+Cutadapt finds and removes adapter sequences, primers, poly-A tails and other
+types of unwanted sequence from your high-throughput sequencing reads.
+
+WWW: https://pypi.python.org/pypi/cutadapt/
diff --git a/py-cutadapt/Makefile b/py-cutadapt/Makefile
new file mode 100644 (file)
index 0000000..606fc81
--- /dev/null
@@ -0,0 +1,23 @@
+# $NetBSD$
+
+###########################################################
+#               Generated by fbsd2pkg                     #
+###########################################################
+
+DISTNAME=      cutadapt-${PORTVERSION}
+PKGNAME=       ${PYPKGPREFIX}-${DISTNAME}
+CATEGORIES=    biology
+MASTER_SITES=  ${MASTER_SITE_PYPI:=c/cutadapt/}
+
+MAINTAINER=    bacon4000@gmail.com
+
+COMMENT=       Finds and removes adapter sequences, primers, poly-A tails, etc
+LICENSE=       mit
+
+USE_LANGUAGES= c
+PYDISTUTILSPKG=        yes
+
+PORTVERSION=   1.14
+
+.include "../../lang/python/egg.mk"
+.include "../../mk/bsd.pkg.mk"
diff --git a/py-cutadapt/PLIST b/py-cutadapt/PLIST
new file mode 100644 (file)
index 0000000..b8a188e
--- /dev/null
@@ -0,0 +1,50 @@
+@comment $NetBSD$
+bin/cutadapt
+${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
+${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
+${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
+${PYSITELIB}/${EGG_INFODIR}/entry_points.txt
+${PYSITELIB}/${EGG_INFODIR}/requires.txt
+${PYSITELIB}/${EGG_INFODIR}/top_level.txt
+${PYSITELIB}/cutadapt/__init__.py
+${PYSITELIB}/cutadapt/__init__.pyc
+${PYSITELIB}/cutadapt/__init__.pyo
+${PYSITELIB}/cutadapt/_align.so
+${PYSITELIB}/cutadapt/_qualtrim.so
+${PYSITELIB}/cutadapt/_seqio.so
+${PYSITELIB}/cutadapt/_version.py
+${PYSITELIB}/cutadapt/_version.pyc
+${PYSITELIB}/cutadapt/_version.pyo
+${PYSITELIB}/cutadapt/adapters.py
+${PYSITELIB}/cutadapt/adapters.pyc
+${PYSITELIB}/cutadapt/adapters.pyo
+${PYSITELIB}/cutadapt/align.py
+${PYSITELIB}/cutadapt/align.pyc
+${PYSITELIB}/cutadapt/align.pyo
+${PYSITELIB}/cutadapt/colorspace.py
+${PYSITELIB}/cutadapt/colorspace.pyc
+${PYSITELIB}/cutadapt/colorspace.pyo
+${PYSITELIB}/cutadapt/compat.py
+${PYSITELIB}/cutadapt/compat.pyc
+${PYSITELIB}/cutadapt/compat.pyo
+${PYSITELIB}/cutadapt/filters.py
+${PYSITELIB}/cutadapt/filters.pyc
+${PYSITELIB}/cutadapt/filters.pyo
+${PYSITELIB}/cutadapt/modifiers.py
+${PYSITELIB}/cutadapt/modifiers.pyc
+${PYSITELIB}/cutadapt/modifiers.pyo
+${PYSITELIB}/cutadapt/qualtrim.py
+${PYSITELIB}/cutadapt/qualtrim.pyc
+${PYSITELIB}/cutadapt/qualtrim.pyo
+${PYSITELIB}/cutadapt/report.py
+${PYSITELIB}/cutadapt/report.pyc
+${PYSITELIB}/cutadapt/report.pyo
+${PYSITELIB}/cutadapt/scripts/__init__.py
+${PYSITELIB}/cutadapt/scripts/__init__.pyc
+${PYSITELIB}/cutadapt/scripts/__init__.pyo
+${PYSITELIB}/cutadapt/scripts/cutadapt.py
+${PYSITELIB}/cutadapt/scripts/cutadapt.pyc
+${PYSITELIB}/cutadapt/scripts/cutadapt.pyo
+${PYSITELIB}/cutadapt/seqio.py
+${PYSITELIB}/cutadapt/seqio.pyc
+${PYSITELIB}/cutadapt/seqio.pyo
diff --git a/py-cutadapt/TODO b/py-cutadapt/TODO
new file mode 100644 (file)
index 0000000..b687356
--- /dev/null
@@ -0,0 +1 @@
+Clean up and test
diff --git a/py-cutadapt/buildlink3.mk b/py-cutadapt/buildlink3.mk
new file mode 100644 (file)
index 0000000..d529cee
--- /dev/null
@@ -0,0 +1,12 @@
+# $NetBSD$
+
+BUILDLINK_TREE+=       cutadapt
+
+.if !defined(CUTADAPT_BUILDLINK3_MK)
+CUTADAPT_BUILDLINK3_MK:=
+
+BUILDLINK_API_DEPENDS.cutadapt+=       cutadapt>=1.8.3
+BUILDLINK_PKGSRCDIR.cutadapt?= ../../wip/py-cutadapt
+.endif # CUTADAPT_BUILDLINK3_MK
+
+BUILDLINK_TREE+=       -cutadapt
diff --git a/py-cutadapt/distinfo b/py-cutadapt/distinfo
new file mode 100644 (file)
index 0000000..6d9b648
--- /dev/null
@@ -0,0 +1,6 @@
+$NetBSD$
+
+SHA1 (cutadapt-1.14.tar.gz) = cffd036c46e1c159fee6b0da23b175499023de37
+RMD160 (cutadapt-1.14.tar.gz) = 591f69a597f04a04a09538cb67d832a838d5a404
+SHA512 (cutadapt-1.14.tar.gz) = 22028c586801293e1942525f343ee72e590f8a10a3244e9aaadaded45a6f4e126f66d0fd6a6aa821b70d36a9735b7cc74f6582f9fe13b6273387f9d917d55a43
+Size (cutadapt-1.14.tar.gz) = 283631 bytes