Import tolua++ 1.0.93 as wip/tolua++
authorCharlotte Koch <cfkoch@edgebsd.org>
Sat, 6 Jul 2019 18:41:42 +0000 (11:41 -0700)
committerCharlotte Koch <cfkoch@edgebsd.org>
Sat, 6 Jul 2019 18:41:42 +0000 (11:41 -0700)
Makefile
tolua++/DESCR [new file with mode: 0644]
tolua++/Makefile [new file with mode: 0644]
tolua++/PLIST [new file with mode: 0644]
tolua++/buildlink3.mk [new file with mode: 0644]
tolua++/distinfo [new file with mode: 0644]

index c3c6efb10e5a18e12e7f9a3b590f1b108399e4eb..9e4006b428f113de595bfe0969e77fe1b358a5c7 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -4718,6 +4718,7 @@ SUBDIR+=  tmva
 SUBDIR+=       tmw
 SUBDIR+=       tnt
 SUBDIR+=       todotxt-git
+SUBDIR+=       tolua++
 SUBDIR+=       tome
 SUBDIR+=       tome2
 SUBDIR+=       toot
diff --git a/tolua++/DESCR b/tolua++/DESCR
new file mode 100644 (file)
index 0000000..8055fd7
--- /dev/null
@@ -0,0 +1,9 @@
+tolua++ is an extension of toLua, a tool to integrate C/C++ code with Lua.
+tolua++ includes new features oriented to c++, such as class templates.
+
+tolua is a tool that greatly simplifies the integration of C/C++ code with
+Lua. Based on a "cleaned" header file, tolua automatically generates the
+binding code to access C/C++ features from Lua. Using Lua-5.0 API and
+metamethod facilities, the current version automatically maps C/C++
+constants, external variables, functions, namespace, classes, and methods to
+Lua. It also provides facilities to create Lua modules.
diff --git a/tolua++/Makefile b/tolua++/Makefile
new file mode 100644 (file)
index 0000000..4b60670
--- /dev/null
@@ -0,0 +1,17 @@
+# $NetBSD$
+
+PKGNAME=       tolua++-1.0.93
+DISTNAME=      toluapp-${PKGVERSION_NOREV}
+CATEGORIES=    devel
+GITHUB_PROJECT=        toluapp
+MASTER_SITES=  ${MASTER_SITE_GITHUB:=LuaDist/}
+
+MAINTAINER=    cfkoch@edgebsd.org
+HOMEPAGE=      https://github.com/LuaDist/toluapp
+COMMENT=       Tool to integrate C/C++ code with Lua
+LICENSE=       mit
+
+USE_CMAKE=     yes
+
+.include "../../lang/lua51/buildlink3.mk"
+.include "../../mk/bsd.pkg.mk"
diff --git a/tolua++/PLIST b/tolua++/PLIST
new file mode 100644 (file)
index 0000000..02cc5ff
--- /dev/null
@@ -0,0 +1,9 @@
+@comment $NetBSD$
+bin/toluapp
+include/tolua++.h
+lib/libtoluapp.so
+share/toluapp/INSTALL
+share/toluapp/README
+share/toluapp/doc/index.html
+share/toluapp/doc/tolua++.html
+share/toluapp/doc/toluapp.gif
diff --git a/tolua++/buildlink3.mk b/tolua++/buildlink3.mk
new file mode 100644 (file)
index 0000000..7bcddde
--- /dev/null
@@ -0,0 +1,15 @@
+# $NetBSD$
+
+BUILDLINK_TREE+=       toluapp
+
+.if !defined(TOLUAPP_BUILDLINK3_MK)
+TOLUAPP_BUILDLINK3_MK:=
+
+BUILDLINK_API_DEPENDS.toluapp+=        tolua++>=1.0.93
+BUILDLINK_ABI_DEPENDS.toluapp+=        tolua++>=1.0.93
+BUILDLINK_PKGSRCDIR.toluapp?=  ../../wip/tolua++
+
+.include "../../lang/lua51/buildlink3.mk"
+.endif # TOLUAPP_BUILDLINK3_MK
+
+BUILDLINK_TREE+=       -toluapp
diff --git a/tolua++/distinfo b/tolua++/distinfo
new file mode 100644 (file)
index 0000000..600782d
--- /dev/null
@@ -0,0 +1,6 @@
+$NetBSD$
+
+SHA1 (toluapp-1.0.93.tar.gz) = 0ab1349cf80e578332764b192eddbe526362027b
+RMD160 (toluapp-1.0.93.tar.gz) = ee0228660fa7b0ac8a2fa6274f8b12bb43cd09c5
+SHA512 (toluapp-1.0.93.tar.gz) = 68f169244f1b37fdeb1a72b0f8fc61a30329c0a828f46af718021c8cfa120fe15379b4b2bc10f0995de90e34735564afd6d302fa1865be60272e52e276e1114f
+Size (toluapp-1.0.93.tar.gz) = 247926 bytes