py-fsspec: Update to 2022.8.2
authorMatthew Danielson <matthewd@fastmail.us>
Sun, 25 Sep 2022 20:07:36 +0000 (13:07 -0700)
committerMatthew Danielson <matthewd@fastmail.us>
Mon, 26 Sep 2022 14:37:41 +0000 (07:37 -0700)
2022.8.2
    don’t close OpenFile on del (#1035)
2022.8.1
    revert #1024 (#1029), with strciter requirements on OpenFile usage
2022.8.0
Enhancements
    writable ZipFileSystem (#1017)
    make OpenFile behave like files and remove dynamic closer in .open() (#1024)
    use isal gunzip (#1008)
Fixes
    remove strip from _parent (#1022)
    disallow aiohttp prereleases (#1018)
    be sure to close cached file (#1016)
    async rm in reverse order (#1014)
    expose fileno in LocalFileOpener (#1010, #1005)
    remove temp files with simplecache writing (#1006)
    azure paths (#1003)
    copy dircache keys before iter

py-fsspec/Makefile
py-fsspec/PLIST
py-fsspec/distinfo

index 1db08b5b4fde9e15845f58cc2969666364894f1e..555ad4a8b01929a2dbdee098f669cc5a15583b8f 100644 (file)
@@ -1,6 +1,7 @@
 # $NetBSD$
 
-DISTNAME=      fsspec-2022.7.1
+FSSPEC_VERSION=        2022.8.2
+DISTNAME=      fsspec-${FSSPEC_VERSION}
 PKGNAME=       ${PYPKGPREFIX}-${DISTNAME}
 CATEGORIES=    sysutils
 GITHUB_PROJECT=        filesystem_spec
@@ -10,7 +11,7 @@ HOMEPAGE=     https://github.com/fsspec/filesystem_spec
 COMMENT=       Specifications for pythonic filesystems
 LICENSE=       modified-bsd
 
-WRKSRC=        ${WRKDIR}/${GITHUB_PROJECT}-2022.7.1
+WRKSRC=        ${WRKDIR}/${GITHUB_PROJECT}-${FSSPEC_VERSION}
 
 PYTHON_VERSIONS_INCOMPATIBLE=  27
 
@@ -22,5 +23,5 @@ TEST_DEPENDS+=        ${PYPKGPREFIX}-test-vcr>=1.0.2:../../wip/py-test-vcr
 do-test:
        cd ${WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHONBIN} -m pytest -s
 
-.include "../../lang/python/egg.mk"
+.include "../../lang/python/wheel.mk"
 .include "../../mk/bsd.pkg.mk"
index 3f647d7656c1b496d3028fee61fd1774a8c36ac5..b29840ebdad22d0b2d7275c43cd7a46562e4d032 100644 (file)
 @comment $NetBSD$
-${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
-${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
-${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
-${PYSITELIB}/${EGG_INFODIR}/not-zip-safe
-${PYSITELIB}/${EGG_INFODIR}/requires.txt
-${PYSITELIB}/${EGG_INFODIR}/top_level.txt
+${PYSITELIB}/${WHEEL_INFODIR}/INSTALLER
+${PYSITELIB}/${WHEEL_INFODIR}/LICENSE
+${PYSITELIB}/${WHEEL_INFODIR}/METADATA
+${PYSITELIB}/${WHEEL_INFODIR}/RECORD
+${PYSITELIB}/${WHEEL_INFODIR}/REQUESTED
+${PYSITELIB}/${WHEEL_INFODIR}/WHEEL
+${PYSITELIB}/${WHEEL_INFODIR}/direct_url.json
+${PYSITELIB}/${WHEEL_INFODIR}/top_level.txt
 ${PYSITELIB}/fsspec/__init__.py
 ${PYSITELIB}/fsspec/__init__.pyc
-${PYSITELIB}/fsspec/__init__.pyo
 ${PYSITELIB}/fsspec/_version.py
 ${PYSITELIB}/fsspec/_version.pyc
-${PYSITELIB}/fsspec/_version.pyo
 ${PYSITELIB}/fsspec/archive.py
 ${PYSITELIB}/fsspec/archive.pyc
-${PYSITELIB}/fsspec/archive.pyo
 ${PYSITELIB}/fsspec/asyn.py
 ${PYSITELIB}/fsspec/asyn.pyc
-${PYSITELIB}/fsspec/asyn.pyo
 ${PYSITELIB}/fsspec/caching.py
 ${PYSITELIB}/fsspec/caching.pyc
-${PYSITELIB}/fsspec/caching.pyo
 ${PYSITELIB}/fsspec/callbacks.py
 ${PYSITELIB}/fsspec/callbacks.pyc
-${PYSITELIB}/fsspec/callbacks.pyo
 ${PYSITELIB}/fsspec/compression.py
 ${PYSITELIB}/fsspec/compression.pyc
-${PYSITELIB}/fsspec/compression.pyo
 ${PYSITELIB}/fsspec/config.py
 ${PYSITELIB}/fsspec/config.pyc
-${PYSITELIB}/fsspec/config.pyo
 ${PYSITELIB}/fsspec/conftest.py
 ${PYSITELIB}/fsspec/conftest.pyc
-${PYSITELIB}/fsspec/conftest.pyo
 ${PYSITELIB}/fsspec/core.py
 ${PYSITELIB}/fsspec/core.pyc
-${PYSITELIB}/fsspec/core.pyo
 ${PYSITELIB}/fsspec/dircache.py
 ${PYSITELIB}/fsspec/dircache.pyc
-${PYSITELIB}/fsspec/dircache.pyo
 ${PYSITELIB}/fsspec/exceptions.py
 ${PYSITELIB}/fsspec/exceptions.pyc
-${PYSITELIB}/fsspec/exceptions.pyo
 ${PYSITELIB}/fsspec/fuse.py
 ${PYSITELIB}/fsspec/fuse.pyc
-${PYSITELIB}/fsspec/fuse.pyo
 ${PYSITELIB}/fsspec/generic.py
 ${PYSITELIB}/fsspec/generic.pyc
-${PYSITELIB}/fsspec/generic.pyo
 ${PYSITELIB}/fsspec/gui.py
 ${PYSITELIB}/fsspec/gui.pyc
-${PYSITELIB}/fsspec/gui.pyo
 ${PYSITELIB}/fsspec/implementations/__init__.py
 ${PYSITELIB}/fsspec/implementations/__init__.pyc
-${PYSITELIB}/fsspec/implementations/__init__.pyo
 ${PYSITELIB}/fsspec/implementations/arrow.py
 ${PYSITELIB}/fsspec/implementations/arrow.pyc
-${PYSITELIB}/fsspec/implementations/arrow.pyo
 ${PYSITELIB}/fsspec/implementations/cached.py
 ${PYSITELIB}/fsspec/implementations/cached.pyc
-${PYSITELIB}/fsspec/implementations/cached.pyo
 ${PYSITELIB}/fsspec/implementations/dask.py
 ${PYSITELIB}/fsspec/implementations/dask.pyc
-${PYSITELIB}/fsspec/implementations/dask.pyo
 ${PYSITELIB}/fsspec/implementations/dbfs.py
 ${PYSITELIB}/fsspec/implementations/dbfs.pyc
-${PYSITELIB}/fsspec/implementations/dbfs.pyo
 ${PYSITELIB}/fsspec/implementations/dirfs.py
 ${PYSITELIB}/fsspec/implementations/dirfs.pyc
-${PYSITELIB}/fsspec/implementations/dirfs.pyo
 ${PYSITELIB}/fsspec/implementations/dvc.py
 ${PYSITELIB}/fsspec/implementations/dvc.pyc
-${PYSITELIB}/fsspec/implementations/dvc.pyo
 ${PYSITELIB}/fsspec/implementations/ftp.py
 ${PYSITELIB}/fsspec/implementations/ftp.pyc
-${PYSITELIB}/fsspec/implementations/ftp.pyo
 ${PYSITELIB}/fsspec/implementations/git.py
 ${PYSITELIB}/fsspec/implementations/git.pyc
-${PYSITELIB}/fsspec/implementations/git.pyo
 ${PYSITELIB}/fsspec/implementations/github.py
 ${PYSITELIB}/fsspec/implementations/github.pyc
-${PYSITELIB}/fsspec/implementations/github.pyo
 ${PYSITELIB}/fsspec/implementations/hdfs.py
 ${PYSITELIB}/fsspec/implementations/hdfs.pyc
-${PYSITELIB}/fsspec/implementations/hdfs.pyo
 ${PYSITELIB}/fsspec/implementations/http.py
 ${PYSITELIB}/fsspec/implementations/http.pyc
-${PYSITELIB}/fsspec/implementations/http.pyo
 ${PYSITELIB}/fsspec/implementations/jupyter.py
 ${PYSITELIB}/fsspec/implementations/jupyter.pyc
-${PYSITELIB}/fsspec/implementations/jupyter.pyo
 ${PYSITELIB}/fsspec/implementations/libarchive.py
 ${PYSITELIB}/fsspec/implementations/libarchive.pyc
-${PYSITELIB}/fsspec/implementations/libarchive.pyo
 ${PYSITELIB}/fsspec/implementations/local.py
 ${PYSITELIB}/fsspec/implementations/local.pyc
-${PYSITELIB}/fsspec/implementations/local.pyo
 ${PYSITELIB}/fsspec/implementations/memory.py
 ${PYSITELIB}/fsspec/implementations/memory.pyc
-${PYSITELIB}/fsspec/implementations/memory.pyo
 ${PYSITELIB}/fsspec/implementations/reference.py
 ${PYSITELIB}/fsspec/implementations/reference.pyc
-${PYSITELIB}/fsspec/implementations/reference.pyo
 ${PYSITELIB}/fsspec/implementations/sftp.py
 ${PYSITELIB}/fsspec/implementations/sftp.pyc
-${PYSITELIB}/fsspec/implementations/sftp.pyo
 ${PYSITELIB}/fsspec/implementations/smb.py
 ${PYSITELIB}/fsspec/implementations/smb.pyc
-${PYSITELIB}/fsspec/implementations/smb.pyo
 ${PYSITELIB}/fsspec/implementations/tar.py
 ${PYSITELIB}/fsspec/implementations/tar.pyc
-${PYSITELIB}/fsspec/implementations/tar.pyo
 ${PYSITELIB}/fsspec/implementations/webhdfs.py
 ${PYSITELIB}/fsspec/implementations/webhdfs.pyc
-${PYSITELIB}/fsspec/implementations/webhdfs.pyo
 ${PYSITELIB}/fsspec/implementations/zip.py
 ${PYSITELIB}/fsspec/implementations/zip.pyc
-${PYSITELIB}/fsspec/implementations/zip.pyo
 ${PYSITELIB}/fsspec/mapping.py
 ${PYSITELIB}/fsspec/mapping.pyc
-${PYSITELIB}/fsspec/mapping.pyo
 ${PYSITELIB}/fsspec/parquet.py
 ${PYSITELIB}/fsspec/parquet.pyc
-${PYSITELIB}/fsspec/parquet.pyo
 ${PYSITELIB}/fsspec/registry.py
 ${PYSITELIB}/fsspec/registry.pyc
-${PYSITELIB}/fsspec/registry.pyo
 ${PYSITELIB}/fsspec/spec.py
 ${PYSITELIB}/fsspec/spec.pyc
-${PYSITELIB}/fsspec/spec.pyo
 ${PYSITELIB}/fsspec/transaction.py
 ${PYSITELIB}/fsspec/transaction.pyc
-${PYSITELIB}/fsspec/transaction.pyo
 ${PYSITELIB}/fsspec/utils.py
 ${PYSITELIB}/fsspec/utils.pyc
-${PYSITELIB}/fsspec/utils.pyo
index 4495ef0368bf94ec55fc7b96b899ed392eaaa29c..01f0c06244d58cac27e973f7013191df9039c0f8 100644 (file)
@@ -1,5 +1,5 @@
 $NetBSD$
 
-BLAKE2s (fsspec-2022.7.1.tar.gz) = 2397e9eafc84a64de8ed15e7e71d863edd92ad5a7efaa8bb9311fbf6967f7920
-SHA512 (fsspec-2022.7.1.tar.gz) = 07178bf22e07091935256296b303e273c03e2ddc15a5aa1110f84c27cadaf9c650204e37c472cb10280e92f24b01fa8b16fe32db21a30d14d232c5a11e05a45c
-Size (fsspec-2022.7.1.tar.gz) = 338526 bytes
+BLAKE2s (fsspec-2022.8.2.tar.gz) = 3839722c4371154a6fa5721848e327c9fdd1987c7c18b128bcbde575479570ea
+SHA512 (fsspec-2022.8.2.tar.gz) = 696f726000c413ba78380b5e17e312ecca30b51093ebf8d7c3658fb7b82ace57223d3aac471e3a772d350523142bdf983b547277838cca0b182ecb4e0a4b3924
+Size (fsspec-2022.8.2.tar.gz) = 338446 bytes