Patched fix for wiimote
authorweabot <weabot@protonmail.com>
Sun, 8 Jan 2017 03:45:14 +0000 (03:45 +0000)
committerweabot <weabot@protonmail.com>
Sun, 8 Jan 2017 03:45:14 +0000 (03:45 +0000)
The compiler optimizations caused some trouble with the
linker. Now src/ will be compiled with -O1 if the wiimote
option is enabled.

clementine/distinfo
clementine/patches/patch-src_CMakeLists.txt [new file with mode: 0644]

index 9e71b9e71b8f445c3fdd66414817ad7a0de1dd57..0e2931d6f22e8826f04cf9edd195603fddb2d92a 100644 (file)
@@ -4,4 +4,5 @@ SHA1 (Clementine/1.3.1.tar.gz) = caf50b46551f2878a6e2e01633cf283ca4f37ffe
 RMD160 (Clementine/1.3.1.tar.gz) = fb5780599a9af524b54c0e7b04f4721eb56ddae1
 SHA512 (Clementine/1.3.1.tar.gz) = 1942a046be24a583b5e2095dd39dc736c1b14a47dc4aad61d6252c1fccf745c26d7b35da907a220d5dc8c0736f5b589d050ed9582de343aa3cb5abc607001790
 Size (Clementine/1.3.1.tar.gz) = 8501827 bytes
+SHA1 (patch-src_CMakeLists.txt) = 08e7dcf38751d557ed867d279226159210f7dfc1
 SHA1 (patch-src_musicbrainz_chromaprinter.cpp) = b2f9916aa77cbf8aa0b5929d6fe6c2b78e652301
diff --git a/clementine/patches/patch-src_CMakeLists.txt b/clementine/patches/patch-src_CMakeLists.txt
new file mode 100644 (file)
index 0000000..222cba7
--- /dev/null
@@ -0,0 +1,15 @@
+$NetBSD$
+
+Disables optimization in src/ when the wiimote option is enabled.
+optimization seems to cause a few problems in the dbus/ dir.
+
+--- src/CMakeLists.txt.orig    2017-01-07 20:24:27.340872864 +0000
++++ src/CMakeLists.txt
+@@ -969,6 +969,7 @@ if(HAVE_DBUS)
+   # Wiimotedev interface classes
+   if(ENABLE_WIIMOTEDEV)
++    set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -O1")
+     qt4_add_dbus_interface(SOURCES
+         dbus/org.wiimotedev.deviceEvents.xml
+         dbus/wiimotedev)