pinentry-qt5: Import version 1.1.1
authorMichael Baeuerle <micha@NetBSD.org>
Fri, 29 Jan 2021 16:33:30 +0000 (17:33 +0100)
committerMichael Baeuerle <micha@NetBSD.org>
Fri, 29 Jan 2021 16:33:30 +0000 (17:33 +0100)
pinentry can use Qt 4 or Qt 5.
This is the Qt 5 based variant.

Makefile
pinentry-qt5/DESCR [new file with mode: 0644]
pinentry-qt5/Makefile [new file with mode: 0644]
pinentry-qt5/PLIST [new file with mode: 0644]

index 4088450935d615a6e9fce77c6b944bb1dec29328..904c7d61b4ae83b01eeee80693e86bd5e4410bc1 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -3074,6 +3074,7 @@ SUBDIR+=  pinentry
 SUBDIR+=       pinentry-dmenu
 SUBDIR+=       pinentry-fltk
 SUBDIR+=       pinentry-gtk2
+SUBDIR+=       pinentry-qt5
 SUBDIR+=       pinkpony
 SUBDIR+=       pioneer
 SUBDIR+=       pipes-c
diff --git a/pinentry-qt5/DESCR b/pinentry-qt5/DESCR
new file mode 100644 (file)
index 0000000..4fb4c06
--- /dev/null
@@ -0,0 +1,6 @@
+This is a collection of simple PIN or passphrase entry dialogs which
+utilize the Assuan protocol as described by the aegypten project.
+It provides programs for several graphical toolkits, such as GTK+ and
+QT, as well as for the console, using curses.
+
+This package contains the QT4 frontend.
diff --git a/pinentry-qt5/Makefile b/pinentry-qt5/Makefile
new file mode 100644 (file)
index 0000000..4ed638d
--- /dev/null
@@ -0,0 +1,24 @@
+# $NetBSD$
+
+PKGNAME=               ${DISTNAME:S/pinentry-/pinentry-qt5-/}
+COMMENT=               Applications for entering PINs or Passphrases, qt5 enabled
+
+.include               "../../wip/pinentry/Makefile.common"
+
+CONFIGURE_ARGS+=       --enable-pinentry-qt
+CONFIGURE_ARGS+=       --disable-pinentry-curses
+CONFIGURE_ARGS+=       --disable-pinentry-emacs
+#CONFIGURE_ARGS+=      --disable-fallback-curses
+CONFIGURE_ARGS+=       --disable-pinentry-gnome3
+CONFIGURE_ARGS+=       --disable-pinentry-gtk2
+CONFIGURE_ARGS+=       --disable-pinentry-fltk
+
+USE_LANGUAGES+=                c c++
+USE_TOOLS+=            pkg-config gmake
+
+INSTALL_DIRS=          qt
+
+BUILDLINK_API_DEPENDS.libgpg-error+=   libgpg-error>=1.0.0
+.include "../../x11/qt5-qtbase/buildlink3.mk"
+
+.include "../../mk/bsd.pkg.mk"
diff --git a/pinentry-qt5/PLIST b/pinentry-qt5/PLIST
new file mode 100644 (file)
index 0000000..e40cf66
--- /dev/null
@@ -0,0 +1,2 @@
+@comment $NetBSD: PLIST,v 1.2 2015/09/30 19:56:42 wiz Exp $
+bin/pinentry-qt