fldiff: Import version 1.1
authorMichael Baeuerle <micha@NetBSD.org>
Fri, 12 May 2023 14:29:06 +0000 (16:29 +0200)
committerMichael Baeuerle <micha@NetBSD.org>
Fri, 12 May 2023 14:29:06 +0000 (16:29 +0200)
fldiff is a graphical diff program that shows the differences between two
files/directories, or a file/directory and a CVS or Subversion repository.

It is inspired by xdiff (Motif-based) and xxdiff (Qt-based).

Makefile
fldiff/DESCR [new file with mode: 0644]
fldiff/Makefile [new file with mode: 0644]
fldiff/PLIST [new file with mode: 0644]
fldiff/distinfo [new file with mode: 0644]
fldiff/patches/patch-DiffWindow.cxx [new file with mode: 0644]

index e60771d48edefff9aa96679c33d2cbd4d21439a9..f52df79f974699ab495168405a6dcae1407a7071 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -907,6 +907,7 @@ SUBDIR+=    flameshot
 SUBDIR+=       flang
 SUBDIR+=       flang-git
 SUBDIR+=       flasm
+SUBDIR+=       fldiff
 SUBDIR+=       flexdock
 SUBDIR+=       flexdump
 SUBDIR+=       flim
diff --git a/fldiff/DESCR b/fldiff/DESCR
new file mode 100644 (file)
index 0000000..eeebb1f
--- /dev/null
@@ -0,0 +1,4 @@
+A graphical diff program that shows the differences between two
+files/directories, or a file/directory and a CVS or Subversion repository.
+
+It is inspired by xdiff (Motif-based) and xxdiff (Qt-based).
diff --git a/fldiff/Makefile b/fldiff/Makefile
new file mode 100644 (file)
index 0000000..0ecb1e8
--- /dev/null
@@ -0,0 +1,22 @@
+# $NetBSD$
+
+DISTNAME=      fldiff-1.1-source
+PKGNAME=       ${DISTNAME:S/-source//}
+# mgdiff is in devel, xxdiff is in textproc
+CATEGORIES=    textproc
+MASTER_SITES=  https://web.archive.org/web/20130406143757/http://www.easysw.com/~mike/fldiff/
+
+MAINTAINER=    micha@NetBSD.org
+HOMEPAGE=      https://web.archive.org/web/20130406143757/http://www.easysw.com/~mike/fldiff/index.html
+COMMENT=       Graphical diff program
+LICENSE=       gnu-gpl-v2
+
+USE_LANGUAGES=         c c++
+GNU_CONFIGURE=         yes
+
+MAKE_FLAGS+=   BUILDROOT=${DESTDIR:Q}
+
+WRKSRC=                ${WRKDIR}/${PKGNAME_NOREV}
+
+.include "../../wip/fltk14-devel/buildlink3.mk"
+.include "../../mk/bsd.pkg.mk"
diff --git a/fldiff/PLIST b/fldiff/PLIST
new file mode 100644 (file)
index 0000000..e461e33
--- /dev/null
@@ -0,0 +1,6 @@
+@comment $NetBSD$
+bin/fldiff
+man/man1/fldiff.1
+share/doc/fldiff/COPYING
+share/doc/fldiff/fldiff.jpg
+share/doc/fldiff/index.html
diff --git a/fldiff/distinfo b/fldiff/distinfo
new file mode 100644 (file)
index 0000000..68d2413
--- /dev/null
@@ -0,0 +1,6 @@
+$NetBSD$
+
+BLAKE2s (fldiff-1.1-source.tar.gz) = 021b168a73078ba50fa24fb523b7067473bab19109ff613182865831d93483e3
+SHA512 (fldiff-1.1-source.tar.gz) = 0b60f5401f57ccde7af59f97410d991c60c6b7b0575ec8406e88f1332ad91e646363402594711e503356e0dd452513f453c3b26813e909d4309f7682b3297650
+Size (fldiff-1.1-source.tar.gz) = 113425 bytes
+SHA1 (patch-DiffWindow.cxx) = 358fd06045c91fb907d4635776cb3aa37f9d55e6
diff --git a/fldiff/patches/patch-DiffWindow.cxx b/fldiff/patches/patch-DiffWindow.cxx
new file mode 100644 (file)
index 0000000..1430df0
--- /dev/null
@@ -0,0 +1,27 @@
+$NetBSD$
+
+Workaround for errors like "call of overloaded 'set(x, y)' is ambiguous".
+
+--- DiffWindow.cxx.orig        2006-11-13 18:54:02.000000000 +0000
++++ DiffWindow.cxx
+@@ -1126,13 +1126,13 @@ void
+ DiffWindow::save_prefs()
+ {
+   // Save the window prefs for the next run...
+-  prefs_.set("color", color());
+-  prefs_.set("selection_color", selection_color());
+-  prefs_.set("showlinenum", showlinenum());
+-  prefs_.set("tabwidth", tabwidth());
+-  prefs_.set("textcolor", textcolor());
+-  prefs_.set("textsize", textsize());
+-  prefs_.set("ignoreblanks", ignoreblanks());
++  prefs_.set("color", (int)color());
++  prefs_.set("selection_color", (int)selection_color());
++  prefs_.set("showlinenum", (int)showlinenum());
++  prefs_.set("tabwidth", (int)tabwidth());
++  prefs_.set("textcolor", (int)textcolor());
++  prefs_.set("textsize", (int)textsize());
++  prefs_.set("ignoreblanks", (int)ignoreblanks());
+ }