wip/py-invoke: import py-invoke-1.4.1
authorK.I.A.Derouiche <kamel.derouiche@gmail.com>
Tue, 3 Nov 2020 15:10:10 +0000 (16:10 +0100)
committerK.I.A.Derouiche <kamel.derouiche@gmail.com>
Tue, 3 Nov 2020 15:10:10 +0000 (16:10 +0100)
py-invoke/DESCR [new file with mode: 0644]
py-invoke/Makefile [new file with mode: 0644]
py-invoke/PLIST [new file with mode: 0644]
py-invoke/distinfo [new file with mode: 0644]

diff --git a/py-invoke/DESCR b/py-invoke/DESCR
new file mode 100644 (file)
index 0000000..f3d7892
--- /dev/null
@@ -0,0 +1,4 @@
+Invoke offers a multifaceted configuration mechanism
+allowing you to configure both core behavior and that
+of your tasks, via a hierarchy of configuration files,
+environment variables, task namespaces and CLI flags
diff --git a/py-invoke/Makefile b/py-invoke/Makefile
new file mode 100644 (file)
index 0000000..9591f74
--- /dev/null
@@ -0,0 +1,16 @@
+# $NetBSD$
+
+DISTNAME=      invoke-1.4.1
+PKGNAME=       ${PYPKGPREFIX}-${DISTNAME}
+CATEGORIES=    devel python
+MASTER_SITES=  ${MASTER_SITE_PYPI:=i/invoke/}
+
+MAINTAINER=    kamelderouiche@yahoo.com
+HOMEPAGE=      http://docs.pyinvoke.org/
+COMMENT=       Pythonic task execution
+LICENSE=       modified-bsd
+
+USE_LANGUAGES= # none
+
+.include "../../lang/python/egg.mk"
+.include "../../mk/bsd.pkg.mk"
diff --git a/py-invoke/PLIST b/py-invoke/PLIST
new file mode 100644 (file)
index 0000000..e57d646
--- /dev/null
@@ -0,0 +1,202 @@
+@comment $NetBSD$
+bin/inv
+bin/invoke
+${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
+${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
+${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
+${PYSITELIB}/${EGG_INFODIR}/entry_points.txt
+${PYSITELIB}/${EGG_INFODIR}/pbr.json
+${PYSITELIB}/${EGG_INFODIR}/top_level.txt
+${PYSITELIB}/invoke/__init__.py
+${PYSITELIB}/invoke/__init__.pyc
+${PYSITELIB}/invoke/__init__.pyo
+${PYSITELIB}/invoke/__main__.py
+${PYSITELIB}/invoke/__main__.pyc
+${PYSITELIB}/invoke/__main__.pyo
+${PYSITELIB}/invoke/_version.py
+${PYSITELIB}/invoke/_version.pyc
+${PYSITELIB}/invoke/_version.pyo
+${PYSITELIB}/invoke/collection.py
+${PYSITELIB}/invoke/collection.pyc
+${PYSITELIB}/invoke/collection.pyo
+${PYSITELIB}/invoke/completion/__init__.py
+${PYSITELIB}/invoke/completion/__init__.pyc
+${PYSITELIB}/invoke/completion/__init__.pyo
+${PYSITELIB}/invoke/completion/bash.completion
+${PYSITELIB}/invoke/completion/complete.py
+${PYSITELIB}/invoke/completion/complete.pyc
+${PYSITELIB}/invoke/completion/complete.pyo
+${PYSITELIB}/invoke/completion/fish.completion
+${PYSITELIB}/invoke/completion/zsh.completion
+${PYSITELIB}/invoke/config.py
+${PYSITELIB}/invoke/config.pyc
+${PYSITELIB}/invoke/config.pyo
+${PYSITELIB}/invoke/context.py
+${PYSITELIB}/invoke/context.pyc
+${PYSITELIB}/invoke/context.pyo
+${PYSITELIB}/invoke/env.py
+${PYSITELIB}/invoke/env.pyc
+${PYSITELIB}/invoke/env.pyo
+${PYSITELIB}/invoke/exceptions.py
+${PYSITELIB}/invoke/exceptions.pyc
+${PYSITELIB}/invoke/exceptions.pyo
+${PYSITELIB}/invoke/executor.py
+${PYSITELIB}/invoke/executor.pyc
+${PYSITELIB}/invoke/executor.pyo
+${PYSITELIB}/invoke/loader.py
+${PYSITELIB}/invoke/loader.pyc
+${PYSITELIB}/invoke/loader.pyo
+${PYSITELIB}/invoke/main.py
+${PYSITELIB}/invoke/main.pyc
+${PYSITELIB}/invoke/main.pyo
+${PYSITELIB}/invoke/parser/__init__.py
+${PYSITELIB}/invoke/parser/__init__.pyc
+${PYSITELIB}/invoke/parser/__init__.pyo
+${PYSITELIB}/invoke/parser/argument.py
+${PYSITELIB}/invoke/parser/argument.pyc
+${PYSITELIB}/invoke/parser/argument.pyo
+${PYSITELIB}/invoke/parser/context.py
+${PYSITELIB}/invoke/parser/context.pyc
+${PYSITELIB}/invoke/parser/context.pyo
+${PYSITELIB}/invoke/parser/parser.py
+${PYSITELIB}/invoke/parser/parser.pyc
+${PYSITELIB}/invoke/parser/parser.pyo
+${PYSITELIB}/invoke/program.py
+${PYSITELIB}/invoke/program.pyc
+${PYSITELIB}/invoke/program.pyo
+${PYSITELIB}/invoke/runners.py
+${PYSITELIB}/invoke/runners.pyc
+${PYSITELIB}/invoke/runners.pyo
+${PYSITELIB}/invoke/tasks.py
+${PYSITELIB}/invoke/tasks.pyc
+${PYSITELIB}/invoke/tasks.pyo
+${PYSITELIB}/invoke/terminals.py
+${PYSITELIB}/invoke/terminals.pyc
+${PYSITELIB}/invoke/terminals.pyo
+${PYSITELIB}/invoke/util.py
+${PYSITELIB}/invoke/util.pyc
+${PYSITELIB}/invoke/util.pyo
+${PYSITELIB}/invoke/vendor/__init__.py
+${PYSITELIB}/invoke/vendor/__init__.pyc
+${PYSITELIB}/invoke/vendor/__init__.pyo
+${PYSITELIB}/invoke/vendor/decorator.py
+${PYSITELIB}/invoke/vendor/decorator.pyc
+${PYSITELIB}/invoke/vendor/decorator.pyo
+${PYSITELIB}/invoke/vendor/fluidity/__init__.py
+${PYSITELIB}/invoke/vendor/fluidity/__init__.pyc
+${PYSITELIB}/invoke/vendor/fluidity/__init__.pyo
+${PYSITELIB}/invoke/vendor/fluidity/backwardscompat.py
+${PYSITELIB}/invoke/vendor/fluidity/backwardscompat.pyc
+${PYSITELIB}/invoke/vendor/fluidity/backwardscompat.pyo
+${PYSITELIB}/invoke/vendor/fluidity/machine.py
+${PYSITELIB}/invoke/vendor/fluidity/machine.pyc
+${PYSITELIB}/invoke/vendor/fluidity/machine.pyo
+${PYSITELIB}/invoke/vendor/lexicon/__init__.py
+${PYSITELIB}/invoke/vendor/lexicon/__init__.pyc
+${PYSITELIB}/invoke/vendor/lexicon/__init__.pyo
+${PYSITELIB}/invoke/vendor/lexicon/alias_dict.py
+${PYSITELIB}/invoke/vendor/lexicon/alias_dict.pyc
+${PYSITELIB}/invoke/vendor/lexicon/alias_dict.pyo
+${PYSITELIB}/invoke/vendor/lexicon/attribute_dict.py
+${PYSITELIB}/invoke/vendor/lexicon/attribute_dict.pyc
+${PYSITELIB}/invoke/vendor/lexicon/attribute_dict.pyo
+${PYSITELIB}/invoke/vendor/six.py
+${PYSITELIB}/invoke/vendor/six.pyc
+${PYSITELIB}/invoke/vendor/six.pyo
+${PYSITELIB}/invoke/vendor/yaml2/__init__.py
+${PYSITELIB}/invoke/vendor/yaml2/__init__.pyc
+${PYSITELIB}/invoke/vendor/yaml2/__init__.pyo
+${PYSITELIB}/invoke/vendor/yaml2/composer.py
+${PYSITELIB}/invoke/vendor/yaml2/composer.pyc
+${PYSITELIB}/invoke/vendor/yaml2/composer.pyo
+${PYSITELIB}/invoke/vendor/yaml2/constructor.py
+${PYSITELIB}/invoke/vendor/yaml2/cyaml.py
+${PYSITELIB}/invoke/vendor/yaml2/cyaml.pyc
+${PYSITELIB}/invoke/vendor/yaml2/cyaml.pyo
+${PYSITELIB}/invoke/vendor/yaml2/dumper.py
+${PYSITELIB}/invoke/vendor/yaml2/dumper.pyc
+${PYSITELIB}/invoke/vendor/yaml2/dumper.pyo
+${PYSITELIB}/invoke/vendor/yaml2/emitter.py
+${PYSITELIB}/invoke/vendor/yaml2/emitter.pyc
+${PYSITELIB}/invoke/vendor/yaml2/emitter.pyo
+${PYSITELIB}/invoke/vendor/yaml2/error.py
+${PYSITELIB}/invoke/vendor/yaml2/error.pyc
+${PYSITELIB}/invoke/vendor/yaml2/error.pyo
+${PYSITELIB}/invoke/vendor/yaml2/events.py
+${PYSITELIB}/invoke/vendor/yaml2/events.pyc
+${PYSITELIB}/invoke/vendor/yaml2/events.pyo
+${PYSITELIB}/invoke/vendor/yaml2/loader.py
+${PYSITELIB}/invoke/vendor/yaml2/loader.pyc
+${PYSITELIB}/invoke/vendor/yaml2/loader.pyo
+${PYSITELIB}/invoke/vendor/yaml2/nodes.py
+${PYSITELIB}/invoke/vendor/yaml2/nodes.pyc
+${PYSITELIB}/invoke/vendor/yaml2/nodes.pyo
+${PYSITELIB}/invoke/vendor/yaml2/parser.py
+${PYSITELIB}/invoke/vendor/yaml2/parser.pyc
+${PYSITELIB}/invoke/vendor/yaml2/parser.pyo
+${PYSITELIB}/invoke/vendor/yaml2/reader.py
+${PYSITELIB}/invoke/vendor/yaml2/representer.py
+${PYSITELIB}/invoke/vendor/yaml2/representer.pyc
+${PYSITELIB}/invoke/vendor/yaml2/representer.pyo
+${PYSITELIB}/invoke/vendor/yaml2/resolver.py
+${PYSITELIB}/invoke/vendor/yaml2/scanner.py
+${PYSITELIB}/invoke/vendor/yaml2/serializer.py
+${PYSITELIB}/invoke/vendor/yaml2/serializer.pyc
+${PYSITELIB}/invoke/vendor/yaml2/serializer.pyo
+${PYSITELIB}/invoke/vendor/yaml2/tokens.py
+${PYSITELIB}/invoke/vendor/yaml2/tokens.pyc
+${PYSITELIB}/invoke/vendor/yaml2/tokens.pyo
+${PYSITELIB}/invoke/vendor/yaml3/__init__.py
+${PYSITELIB}/invoke/vendor/yaml3/__init__.pyc
+${PYSITELIB}/invoke/vendor/yaml3/__init__.pyo
+${PYSITELIB}/invoke/vendor/yaml3/composer.py
+${PYSITELIB}/invoke/vendor/yaml3/composer.pyc
+${PYSITELIB}/invoke/vendor/yaml3/composer.pyo
+${PYSITELIB}/invoke/vendor/yaml3/constructor.py
+${PYSITELIB}/invoke/vendor/yaml3/constructor.pyc
+${PYSITELIB}/invoke/vendor/yaml3/constructor.pyo
+${PYSITELIB}/invoke/vendor/yaml3/cyaml.py
+${PYSITELIB}/invoke/vendor/yaml3/cyaml.pyc
+${PYSITELIB}/invoke/vendor/yaml3/cyaml.pyo
+${PYSITELIB}/invoke/vendor/yaml3/dumper.py
+${PYSITELIB}/invoke/vendor/yaml3/dumper.pyc
+${PYSITELIB}/invoke/vendor/yaml3/dumper.pyo
+${PYSITELIB}/invoke/vendor/yaml3/emitter.py
+${PYSITELIB}/invoke/vendor/yaml3/emitter.pyc
+${PYSITELIB}/invoke/vendor/yaml3/emitter.pyo
+${PYSITELIB}/invoke/vendor/yaml3/error.py
+${PYSITELIB}/invoke/vendor/yaml3/error.pyc
+${PYSITELIB}/invoke/vendor/yaml3/error.pyo
+${PYSITELIB}/invoke/vendor/yaml3/events.py
+${PYSITELIB}/invoke/vendor/yaml3/events.pyc
+${PYSITELIB}/invoke/vendor/yaml3/events.pyo
+${PYSITELIB}/invoke/vendor/yaml3/loader.py
+${PYSITELIB}/invoke/vendor/yaml3/loader.pyc
+${PYSITELIB}/invoke/vendor/yaml3/loader.pyo
+${PYSITELIB}/invoke/vendor/yaml3/nodes.py
+${PYSITELIB}/invoke/vendor/yaml3/nodes.pyc
+${PYSITELIB}/invoke/vendor/yaml3/nodes.pyo
+${PYSITELIB}/invoke/vendor/yaml3/parser.py
+${PYSITELIB}/invoke/vendor/yaml3/parser.pyc
+${PYSITELIB}/invoke/vendor/yaml3/parser.pyo
+${PYSITELIB}/invoke/vendor/yaml3/reader.py
+${PYSITELIB}/invoke/vendor/yaml3/reader.pyc
+${PYSITELIB}/invoke/vendor/yaml3/reader.pyo
+${PYSITELIB}/invoke/vendor/yaml3/representer.py
+${PYSITELIB}/invoke/vendor/yaml3/representer.pyc
+${PYSITELIB}/invoke/vendor/yaml3/representer.pyo
+${PYSITELIB}/invoke/vendor/yaml3/resolver.py
+${PYSITELIB}/invoke/vendor/yaml3/resolver.pyc
+${PYSITELIB}/invoke/vendor/yaml3/resolver.pyo
+${PYSITELIB}/invoke/vendor/yaml3/scanner.py
+${PYSITELIB}/invoke/vendor/yaml3/scanner.pyc
+${PYSITELIB}/invoke/vendor/yaml3/scanner.pyo
+${PYSITELIB}/invoke/vendor/yaml3/serializer.py
+${PYSITELIB}/invoke/vendor/yaml3/serializer.pyc
+${PYSITELIB}/invoke/vendor/yaml3/serializer.pyo
+${PYSITELIB}/invoke/vendor/yaml3/tokens.py
+${PYSITELIB}/invoke/vendor/yaml3/tokens.pyc
+${PYSITELIB}/invoke/vendor/yaml3/tokens.pyo
+${PYSITELIB}/invoke/watchers.py
+${PYSITELIB}/invoke/watchers.pyc
+${PYSITELIB}/invoke/watchers.pyo
diff --git a/py-invoke/distinfo b/py-invoke/distinfo
new file mode 100644 (file)
index 0000000..5e350ec
--- /dev/null
@@ -0,0 +1,6 @@
+$NetBSD$
+
+SHA1 (invoke-1.4.1.tar.gz) = ae5a3f850a252a19a118f16539b26d1f89f3ac2b
+RMD160 (invoke-1.4.1.tar.gz) = 7dfdc6217ead0fb9df1601a0e2b824b4a4069f8d
+SHA512 (invoke-1.4.1.tar.gz) = 9076a1e643e3496b180d486de48efe599eddafc3e8ac32ab5cfcb27c5aabfd4ea360c0e2e59f96aceb65f3453b5ff2c228bf7d76635fe62854fe092b1ebdf3b2
+Size (invoke-1.4.1.tar.gz) = 332271 bytes