Add fossil1 package for cvs2fossil, and depend on it there.
authorThomas Klausner <wiz@gatalith.at>
Sat, 24 Jun 2023 20:16:19 +0000 (22:16 +0200)
committerThomas Klausner <wiz@gatalith.at>
Sat, 24 Jun 2023 20:16:19 +0000 (22:16 +0200)
Makefile
cvs2fossil/Makefile
cvs2fossil/distinfo
cvs2fossil/patches/patch-convert.sh
fossil1/DESCR [new file with mode: 0644]
fossil1/Makefile [new file with mode: 0644]
fossil1/PLIST [new file with mode: 0644]
fossil1/distinfo [new file with mode: 0644]

index 0f7356894f2b5f9ee240ef2241c73775af3f3103..bc211294712c6710eec0feeb49dbb45c1c86566a 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -923,6 +923,7 @@ SUBDIR+=    fnteditfs
 SUBDIR+=       fogleman-craft
 SUBDIR+=       fontaine
 SUBDIR+=       fonttosfnt
+SUBDIR+=       fossil1
 SUBDIR+=       fox
 SUBDIR+=       foxtrotgps
 SUBDIR+=       fpc
index d69746218f74fc2c8b121c671828d7ac516daafa..8a4e5ad24b971b927d8ef0fff7be15f4493733e8 100644 (file)
@@ -9,7 +9,7 @@ HOMEPAGE=       https://wiki.NetBSD.org/github/
 COMMENT=       Tool to convert from CVS to fossil
 #LICENSE=      2-clause-bsd AND mit
 
-DEPENDS+=      fossil-[0-9]*:../../devel/fossil
+DEPENDS+=      fossil1-[0-9]*:../../wip/fossil1
 
 WRKSRC=                ${WRKDIR}/cvs2fossil
 
index f51f43533186575d3a796af01a9f8794240a3070..b82b313cd7f3518f5bb876eddbc75db917b345b9 100644 (file)
@@ -5,4 +5,4 @@ SHA512 (cvs2fossil-20140502.tar.gz) = dc5f64c5af0fe6a35143244c2858dcccd4ad2131fb
 Size (cvs2fossil-20140502.tar.gz) = 1258545 bytes
 SHA1 (patch-04-commit_main.c) = a7afef765fca714dfe672ab7207789d91cd839c8
 SHA1 (patch-common_common.h) = 625959ee61513df52696987c9fba2abb83c91262
-SHA1 (patch-convert.sh) = 40ad2b114773699b68ae3ede1c9c64af526d090e
+SHA1 (patch-convert.sh) = 732fe531076784dd09ab5a90771581784c288e43
index 5b526170e1e8cdb7afdda70ac5bc17ecbc6d31ba..c1c35f5c9bd582a0896c7b79df127f96820b126c 100644 (file)
@@ -30,12 +30,14 @@ Adapt example for pkgsrc paths.
 +time 02-vendorbranches $db
 +time 03-branchtime $db
  rm -f $fossil
- fossil new -A root --date-override "$oldest" $fossil
+-fossil new -A root --date-override "$oldest" $fossil
++fossil1 new -A root --date-override "$oldest" $fossil
  project=eeb7e06236b08dc4b57b6ab3b957fe5756c64f5b
  sqlite3 $fossil 'UPDATE config SET value="'$project'" WHERE name="project-code"'
  initial=$(sqlite3 $fossil 'SELECT uuid FROM blob WHERE rid=1')
 -TMPDIR=. time 04-commit/04-commit -b $initial $db $fossil
 +TMPDIR=. time 04-commit -b $initial $db $fossil
  du -h $fossil
- time fossil rebuild --noverify $fossil
+-time fossil rebuild --noverify $fossil
++time fossil1 rebuild --noverify $fossil
  #TMPDIR=. time sqlite3 $fossil 'pragma synchronous=off; pragma journal_mode=off; vacuum'
diff --git a/fossil1/DESCR b/fossil1/DESCR
new file mode 100644 (file)
index 0000000..32fd08a
--- /dev/null
@@ -0,0 +1,13 @@
+Fossil is a distributed software control system that includes a
+whole palette of useful companion software: for example, bug
+tracking and a wiki.
+
+It allows autosyncing with an upstream before a commit.  fossil is
+a single standalone executable, using bandwidth efficient transfers
+over HTTP. It includes its own HTTP server for providing the
+repository, if needed.
+
+The repository is kept in a sqlite database, only updated with
+atomic commits, which can be checked by fossil itself for consistency.
+
+This package contains the old major version 1, needed by cvs2fossil.
diff --git a/fossil1/Makefile b/fossil1/Makefile
new file mode 100644 (file)
index 0000000..26633b3
--- /dev/null
@@ -0,0 +1,28 @@
+# $NetBSD: Makefile,v 1.38 2016/10/25 17:57:39 kamil Exp $
+
+DISTNAME=      fossil-src-1.37
+PKGNAME=       ${DISTNAME:S/-src/1/}
+CATEGORIES=    devel scm
+MASTER_SITES=  https://fossil-scm.org/home/tarball/version-${PKGVERSION_NOREV}/
+
+MAINTAINER=    pkgsrc-users@NetBSD.org
+HOMEPAGE=      http://www.fossil-scm.org/
+COMMENT=       High-reliability, distributed software configuration management (v1)
+LICENSE=       2-clause-bsd
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS+=       --with-openssl=${BUILDLINK_PREFIX.openssl:Q}
+
+INSTALLATION_DIRS+=    bin ${PKGMANDIR}/man1 share/doc/fossil1
+
+do-install:
+       ${INSTALL_PROGRAM} ${WRKSRC}/fossil ${DESTDIR}${PREFIX}/bin/fossil1
+       ${INSTALL_MAN} ${WRKSRC}/fossil.1 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/fossil1.1
+       ${INSTALL_DATA} ${WRKSRC}/COPYRIGHT-BSD2.txt \
+               ${DESTDIR}${PREFIX}/share/doc/fossil1
+       ${INSTALL_DATA} ${WRKSRC}/src/linenoise.h \
+               ${DESTDIR}${PREFIX}/share/doc/fossil1
+
+.include "../../security/openssl/buildlink3.mk"
+.include "../../devel/zlib/buildlink3.mk"
+.include "../../mk/bsd.pkg.mk"
diff --git a/fossil1/PLIST b/fossil1/PLIST
new file mode 100644 (file)
index 0000000..37a6be0
--- /dev/null
@@ -0,0 +1,5 @@
+@comment $NetBSD: PLIST,v 1.2 2015/12/29 15:31:13 nros Exp $
+bin/fossil1
+man/man1/fossil1.1
+share/doc/fossil1/COPYRIGHT-BSD2.txt
+share/doc/fossil1/linenoise.h
diff --git a/fossil1/distinfo b/fossil1/distinfo
new file mode 100644 (file)
index 0000000..a10ef49
--- /dev/null
@@ -0,0 +1,5 @@
+$NetBSD: distinfo,v 1.27 2016/10/25 17:57:39 kamil Exp $
+
+BLAKE2s (fossil-src-1.37.tar.gz) = f4f39327455c2ea99646677c59fdf388b4aebd750fbb37164b4ed4e021774cf7
+SHA512 (fossil-src-1.37.tar.gz) = b59ddfbb65f2ce6d68e41ec52362ed378885c023be32f5ab0022b09a63be01ae3634277288c8481eab63e313b97eed3bcbe453f0b8ad52f6b4df04aa6fc76aa1
+Size (fossil-src-1.37.tar.gz) = 4794894 bytes