qutebrowser: update to qutebrowser-1.4.0
authorYorick Hardy <yorickhardy@gmail.com>
Tue, 3 Jul 2018 20:26:35 +0000 (22:26 +0200)
committerYorick Hardy <yorickhardy@gmail.com>
Tue, 3 Jul 2018 20:27:50 +0000 (22:27 +0200)
Changelog:

v1.4.0
------

Added
~~~~~

- Support for the bundled `sip` module in PyQt 5.11 and other changes in
  Qt/PyQt 5.11.x.
- New `--debug-flag log-requests` to log requests to the debug log for
  debugging.
- New `--first` flag for `:hint` (bound to `gi` for inputs) which automatically
  selects the first hint.
- New `input.escape_quits_reporter` setting which can be used to avoid
  accidentally quitting the crash reporter when pressing escape.
- New `qute-lastpass` userscript which uses the LastPass CLI to fill passwords.
- The Makefile now installs a `/usr/share/metainfo/qutebrowser.appdata.xml` file.
- QtWebEngine: Support for printing from webpages via `window.print`.
- QtWebEngine: Support for muting tabs:
  * New `{audio}` field for `window.title_format` and `tabs.title.format` which
    displays `[M]`/`[A]` for muted/recently audible tabs.
  * New `:tab-mute` command (bound to `<Alt-m>`) to mute/unmute a tab.
- QtWebEngine: Support for `content.cookies.accept` with third-party cookies
  blocked by default (requires Qt 5.11).
- QtWebEngine: New settings:
  * Support for requesting persistent storage via
    `navigator.webkitPersistentStorage.requestQuota` with a new
    `content.persistent_storage` setting (requires Qt 5.11).
    This setting also supports URL patterns.
  * Support for registering custom protocol handlers via
    `navigator.registerProtocolHandler` with a new
    `content.register_protocol_handler` setting (requires Qt 5.11).
    This setting also supports URL patterns.
  * Support for WebRTC screen sharing with a new `content.desktop_capture`
    setting (requires Qt 5.10).
    This setting also supports URL patterns.
  * New `content.autoplay` setting to enable/disable automatic video playback
    (requires Qt 5.10).
  * New `content.webrtc_public_interfaces_only` setting to only expose public
    interfaces over WebRTC (requires Qt 5.9.2 or 5.11).
  * New `content.canvas_reading` setting to disable reading from canvas
    elements.

Changed
~~~~~~~

- The following settings now support URL patterns:
  * `content.headers.do_not_track`
  * `content.headers.custom`
  * `content.headers.accept_language`
  * `content.headers.user_agent`
  * `content.ssl_strict`
  * `content.geolocation`
  * `content.notifications`
  * `content.media_capture`
- The Windows/macOS releases now bundle Qt 5.11.1 which is based on
  Chromium 65.0.3325.151 with security fixes up to Chromium 67.0.3396.87.
- New short flags for commandline arguments: `-B` and `-T` for `--basedir` and
  `--temp-basedir`; `-d` and `-D` for `--debug` and `--debug-flag`.
- Deleting history items via `:history-clear` or `:completion-item-del` now
  also removes that URL from QtWebEngine's visited links.
- There's now completion for commands taking a variable count of arguments
  (like `:config-cycle`).
- QtWebEngine: On Qt 5.11.1, no reloads are needed anymore when switching
  between pages with changed settings (e.g. `content.javascript.enabled`).
- The `qt.force_software_rendering` setting changed from a boolean to taking
  different values (`software-opengl`, `qt-quick` and `chromium`) for different
  kinds of software rendering workarounds.
- On Qt 5.11, using wayland with QtWebEngine is now possible when using
  software rendering.
- GreaseMonkey scripts now get their own global scope (based on the page's
  one), which allows scripts like OneeChan to work.
- Rapid hinting is now supported with the `yank` and `yank-primary` targets,
  copying newline-separated links.
- QtWebEngine: On Qt 5.11, the developer tools (inspector) can now be used
  securely and without requiring the `--enable-webengine-inspector` option.
- The `<Enter>` key (`:follow-selected`) now follows the currently focused
  element if there's no selection.
- The `--logfilter` argument now can be prepended with an exclamation mark
  (e.g. `--logfilter '!init,destroy'`) to invert the filter.
- `:view-source` now has a `--pygments` flag which uses the "old" way of
  rendering sources even with QtWebEngine.
- Improved error messages when a setting needs a newer Qt version.
- QtWebEngine: Various improvements to make the cursor more visible in caret
  browsing.
- When a prompt is opened in insert/passthrough mode, the mode is restored
  after closing the prompt.
- On Qt 5.10 or newer, dictionaries are now read from the qutebrowser data
  directory (e.g. `~/.local/share/qutebrowser`) instead of `/usr/share/qt`.
  Existing dictionaries are copied over.
- If an error while parsing `~/.netrc` occurs, the cause of the error is now
  logged.
- On Qt 5.9 or newer, certificate errors now show Chromium's detailed error
  page.
- Greasemonkey scripts now support a "@qute-js-world" tag to run them in a
  different JavaScript context.

Fixed
~~~~~

- Various subtle keyboard focus issues.
- The security fix in v1.3.3 caused URLs with ampersands
  (`www.example.com?one=1&two=2`) to send the wrong arguments when clicked on
  the `qute://history` page.
- Crash when opening a PDF page with PDF.js enabled (on QtWebKit), but no
  PDF.js installed.
- Crash when closing a tab shortly after opening it.

Removed
~~~~~~~

- No prebuilt binaries for 32-bit Windows are supplied anymore. This is due to
  Qt removing QtWebEngine support for those upstream. It might be possible to
  distribute 32-bit binaries again with Qt 5.12 in December, but that will only
  happen if it turns out enough people actually need 32-bit support.
- `:tab-detach` which has been deprecated in v1.1.0 has been removed.
- The `content.developer_extras` setting got removed. On QtWebKit, developer
  extras are now automatically enabled when opening the inspector.

qutebrowser/Makefile
qutebrowser/PLIST
qutebrowser/distinfo

index b7e45c71da9c5dea27ab09ae9a1dd32f14e80337..7219395b59dd57c5738255183dcfdce505c8cc97 100644 (file)
@@ -1,9 +1,9 @@
 # $NetBSD$
 
-DISTNAME=      qutebrowser-1.3.3
+DISTNAME=      qutebrowser-1.4.0
 CATEGORIES=    www
 MASTER_SITES=  ${MASTER_SITE_GITHUB:=qutebrowser/}
-GITHUB_TAG=    v1.3.3
+GITHUB_TAG=    v1.4.0
 
 MAINTAINER=    pkgsrc-users@NetBSD.org
 HOMEPAGE=      https://qutebrowser.org/
index af5a2e0ea155b7155ea0603ff268c5e1e4896bcc..9bab452586a6cf76ed4690f3fb11e27ef6288b6f 100644 (file)
@@ -15,6 +15,8 @@ ${PYSITELIB}/qutebrowser/__main__.pyo
 ${PYSITELIB}/qutebrowser/__main__.pyc
 ${PYSITELIB}/qutebrowser/app.pyo
 ${PYSITELIB}/qutebrowser/app.pyc
+${PYSITELIB}/qutebrowser/qt.pyo
+${PYSITELIB}/qutebrowser/qt.pyc
 ${PYSITELIB}/qutebrowser/qutebrowser.pyo
 ${PYSITELIB}/qutebrowser/qutebrowser.pyc
 ${PYSITELIB}/qutebrowser/resources.pyo
@@ -91,6 +93,8 @@ ${PYSITELIB}/qutebrowser/browser/webengine/__init__.pyo
 ${PYSITELIB}/qutebrowser/browser/webengine/__init__.pyc
 ${PYSITELIB}/qutebrowser/browser/webengine/certificateerror.pyo
 ${PYSITELIB}/qutebrowser/browser/webengine/certificateerror.pyc
+${PYSITELIB}/qutebrowser/browser/webengine/cookies.pyo
+${PYSITELIB}/qutebrowser/browser/webengine/cookies.pyc
 ${PYSITELIB}/qutebrowser/browser/webengine/interceptor.pyo
 ${PYSITELIB}/qutebrowser/browser/webengine/interceptor.pyc
 ${PYSITELIB}/qutebrowser/browser/webengine/spell.pyo
@@ -112,6 +116,7 @@ ${PYSITELIB}/qutebrowser/browser/webengine/webenginetab.pyc
 ${PYSITELIB}/qutebrowser/browser/webengine/webview.pyo
 ${PYSITELIB}/qutebrowser/browser/webengine/webview.pyc
 ${PYSITELIB}/qutebrowser/browser/webengine/certificateerror.py
+${PYSITELIB}/qutebrowser/browser/webengine/cookies.py
 ${PYSITELIB}/qutebrowser/browser/webengine/interceptor.py
 ${PYSITELIB}/qutebrowser/browser/webengine/spell.py
 ${PYSITELIB}/qutebrowser/browser/webengine/tabhistory.py
@@ -298,6 +303,7 @@ ${PYSITELIB}/qutebrowser/javascript/greasemonkey_wrapper.js
 ${PYSITELIB}/qutebrowser/javascript/history.js
 ${PYSITELIB}/qutebrowser/javascript/pac_utils.js
 ${PYSITELIB}/qutebrowser/javascript/position_caret.js
+${PYSITELIB}/qutebrowser/javascript/print.js
 ${PYSITELIB}/qutebrowser/javascript/scroll.js
 ${PYSITELIB}/qutebrowser/javascript/stylesheet.js
 ${PYSITELIB}/qutebrowser/javascript/webelem.js
@@ -445,6 +451,7 @@ ${PYSITELIB}/qutebrowser/misc/sessions.py
 ${PYSITELIB}/qutebrowser/misc/split.py
 ${PYSITELIB}/qutebrowser/misc/sql.py
 ${PYSITELIB}/qutebrowser/misc/utilcmds.py
+${PYSITELIB}/qutebrowser/qt.py
 ${PYSITELIB}/qutebrowser/qutebrowser.py
 ${PYSITELIB}/qutebrowser/resources.py
 ${PYSITELIB}/qutebrowser/utils/__init__.py
index 2a6a470de9a92c2cfca2f34f7a6df060617f418e..c2e23fad1b9cd28571539a0d9c4dda21a9f76983 100644 (file)
@@ -1,6 +1,6 @@
 $NetBSD$
 
-SHA1 (qutebrowser-1.3.3.tar.gz) = ffc06f254105a8ba62242580e3cfce5f8e18b27c
-RMD160 (qutebrowser-1.3.3.tar.gz) = 00191825870bc6f2eb240524627f60a006d7292f
-SHA512 (qutebrowser-1.3.3.tar.gz) = d51a1ffad80a8906a4293bd5c83f13109e89b58e0d3c140ab7ecbae9a6d02ba04486503a1acd5c04ef942d4aa6af65277a8d50de665704498dfa4bd1bc5b4d5c
-Size (qutebrowser-1.3.3.tar.gz) = 3103024 bytes
+SHA1 (qutebrowser-1.4.0.tar.gz) = 6d2f10887fd889bc15a18e31a2a41726bcf2885b
+RMD160 (qutebrowser-1.4.0.tar.gz) = 15db9e5a37e39ed331afdc39176c65458cf0bf8f
+SHA512 (qutebrowser-1.4.0.tar.gz) = 4700db292d39ff567dfce2f6afd330298371a15345baf7197ae419e219700a49b27dcde740c538240ffb1eb76feac1d73a75e011626ae4340831f64f1ac061f1
+Size (qutebrowser-1.4.0.tar.gz) = 3120739 bytes