llilc-git: Temporarily drop local patches
authorKamil Rytarowski <n54@gmx.com>
Tue, 23 Feb 2016 11:10:15 +0000 (12:10 +0100)
committerKamil Rytarowski <n54@gmx.com>
Tue, 23 Feb 2016 11:10:26 +0000 (12:10 +0100)
llilc-git/distinfo
llilc-git/patches/patch-include_Jit_LLILCJit.h [deleted file]
llilc-git/patches/patch-lib_CoreDisTools_coredistools.cpp [deleted file]

index 2d7a31deacceaa00b118efbfa8da178dc2e3ab77..afc76512f47f1a4829fec6daf5e8f1c000073bda 100644 (file)
@@ -1,4 +1,2 @@
 $NetBSD$
 
-SHA1 (patch-include_Jit_LLILCJit.h) = d58f2096a435e20f39a80129183290eb519219c0
-SHA1 (patch-lib_CoreDisTools_coredistools.cpp) = 31b5b0b5be6577509f9fb068133be9d3a259d4b8
diff --git a/llilc-git/patches/patch-include_Jit_LLILCJit.h b/llilc-git/patches/patch-include_Jit_LLILCJit.h
deleted file mode 100644 (file)
index e7d03c4..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-$NetBSD$
-
---- include/Jit/LLILCJit.h.orig        2016-02-22 20:43:07.000000000 +0000
-+++ include/Jit/LLILCJit.h
-@@ -25,7 +25,8 @@
- #include "llvm/Support/ThreadLocal.h"
- #include "llvm/ExecutionEngine/Orc/IRCompileLayer.h"
- #include "llvm/ExecutionEngine/Orc/NullResolver.h"
--#include "llvm/Config/config.h"
-+//#include "llvm/Config/config.h"
-+#include "llvm/Config/llvm-config.h"
- class ABIInfo;
- class GcInfo;
diff --git a/llilc-git/patches/patch-lib_CoreDisTools_coredistools.cpp b/llilc-git/patches/patch-lib_CoreDisTools_coredistools.cpp
deleted file mode 100644 (file)
index 981067b..0000000
+++ /dev/null
@@ -1,73 +0,0 @@
-$NetBSD$
-
---- lib/CoreDisTools/coredistools.cpp.orig     2016-02-22 20:43:07.000000000 +0000
-+++ lib/CoreDisTools/coredistools.cpp
-@@ -49,13 +49,13 @@ public:
-   void printInstruction(const MCInst *MI, size_t Address, size_t InstSize,
-                         ArrayRef<uint8_t> Bytes) const;
--  CorDisasm(TargetArch Target) { TargetArch = Target; }
-+  CorDisasm(TargetArch Target) { TheTargetArch = Target; }
- private:
-   bool setTarget();
-   bool verifyPrefixDecoding();
--  TargetArch TargetArch;
-+  TargetArch TheTargetArch;
-   string TargetTriple;
-   const Target *TheTarget;
-@@ -113,20 +113,20 @@ bool CorDisasm::setTarget() {
-   TargetTriple = Triple::normalize(TargetTriple);
-   Triple TheTriple(TargetTriple);
--  switch (TargetArch) {
-+  switch (TheTargetArch) {
-   case Target_Host:
-     switch (TheTriple.getArch()) {
-     case Triple::x86:
--      TargetArch = Target_X86;
-+      TheTargetArch = Target_X86;
-       break;
-     case Triple::x86_64:
--      TargetArch = Target_X64;
-+      TheTargetArch = Target_X64;
-       break;
-     case Triple::thumb:
--      TargetArch = Target_Thumb;
-+      TheTargetArch = Target_Thumb;
-       break;
-     case Triple::aarch64:
--      TargetArch = Target_Arm64;
-+      TheTargetArch = Target_Arm64;
-       break;
-     default:
-       errs() << "Unsupported Architecture"
-@@ -146,7 +146,7 @@ bool CorDisasm::setTarget() {
-     TheTriple.setArch(Triple::x86_64);
-   }
--  assert(TargetArch != Target_Host && "Target Expected to be specific");
-+  assert(TheTargetArch != Target_Host && "Target Expected to be specific");
-   // Get the target specific parser.
-   string Error;
-@@ -235,7 +235,7 @@ bool CorDisasm::init() {
- // X86 prefix bytes are decoded by LLVM -- and learn about
- // any change in behavior.
- bool CorDisasm::verifyPrefixDecoding() {
--  if ((TargetArch != Target_X86) && (TargetArch != Target_X64)) {
-+  if ((TheTargetArch != Target_X86) && (TheTargetArch != Target_X64)) {
-     return true;
-   }
-@@ -296,7 +296,7 @@ size_t CorDisasm::disasmInstruction(size
-     }
-     ContinueDisasm = false;
--    if ((TargetArch == Target_X86) || (TargetArch == Target_X64)) {
-+    if ((TheTargetArch == Target_X86) || (TheTargetArch == Target_X64)) {
-       // Check if the decoded instruction is a prefix byte, and if so,
-       // continue decoding.