qt6-qtbase: cleanup
authorNiclas Rosenvik <nros@NetBSD.org>
Thu, 1 Apr 2021 12:35:43 +0000 (12:35 +0000)
committerNiclas Rosenvik <nros@NetBSD.org>
Thu, 1 Apr 2021 12:39:45 +0000 (12:39 +0000)
remove NETWORK_LIBS for lsolaris there is a patch for that already in
the repo.
add comment about ld_library_path.
update patch for fixing build break due to getauxval being claimed
to exist on solaris.
update TODO.

qt6-qtbase/Makefile
qt6-qtbase/TODO
qt6-qtbase/distinfo
qt6-qtbase/patches/patch-src_corelib_global_qconfig-bootstrapped.h [new file with mode: 0644]
qt6-qtbase/patches/patch-src_corelib_global_qrandom.cpp [deleted file]

index 478b52a498d05653163c1855ed8a86d312d75e60..683715a2f73b6ea93e343a0957239eafb79f4bb7 100644 (file)
@@ -82,7 +82,6 @@ CONFIGURE_ARGS+=              -platform solaris-cc-64
 CONFIGURE_ARGS+=               -platform solaris-cc
 .    endif
 .  endif
-NETWORK_LIBS=                  -lsocket -lnsl
 .elif ${OPSYS} == "Interix"
 CONFIGURE_ARGS+=               -platform interix-g++
 CFLAGS+=                       -I/usr/local/include/bind
@@ -124,7 +123,9 @@ UNLIMIT_RESOURCES=  datasize
 
 BUILDLINK_PASSTHRU_DIRS+=      ${QTPREFIX}
 
-#
+# pkgsrc does not set rapth during build
+# but qdbuscpp2xml and qdbuscpp2xml are
+# executed during build
 MAKE_ENV+=             LD_LIBRARY_PATH=${WRKSRC}/lib
 
 INSTALLATION_DIRS=     lib/pkgconfig
index 6974ac1e856340cfd9fb70bc13059b31965bee04..76823d23b18895a76e74a946a876e6f2fcd7f8cf 100644 (file)
@@ -1,2 +1,2 @@
-test builds for Darwin and Linux
+test builds for Darwin
 remove unneeded stuff in makefiles from qt5
index 9deb36cb7af08fbcbddb90bfed2b30bdaddc6b8b..99d443d503b914495465aea0d61d95f8ff815c56 100644 (file)
@@ -17,11 +17,11 @@ SHA1 (patch-qmake_generators_makefile.cpp) = 1bca636dc88f258876df54bd0c6c64114fa
 SHA1 (patch-qmake_generators_unix_unixmake2.cpp) = 6ea4efd2ce88d7cf3c73e1dc2cdf984fe3b6af04
 SHA1 (patch-src_corelib_CMakeLists.txt) = be1889f2292e932a086ea10a8b857926b7c2156b
 SHA1 (patch-src_corelib_configure.json) = 7a83a356330e602cbc65256dd345a107004a67cb
+SHA1 (patch-src_corelib_global_qconfig-bootstrapped.h) = 3db71f61e51cdd71f01ad1e580e89367fc179c7c
 SHA1 (patch-src_corelib_global_qglobal.cpp) = 6368692c2d5d64633d956a89c6b4607667c121a7
 SHA1 (patch-src_corelib_global_qoperatingsystemversion.cpp) = 84695f7523352f0e7cf925da8d57715e73713bad
 SHA1 (patch-src_corelib_global_qoperatingsystemversion.h) = 33a2e58242e12c44da8ce2c3cdbdd85177673646
 SHA1 (patch-src_corelib_global_qoperatingsystemversion__uname.cpp) = ab30d7f7c3ec3c9ac5eac61cee4383b916d16724
-SHA1 (patch-src_corelib_global_qrandom.cpp) = d910579df42d5b01583b88fa19f514b230596ca7
 SHA1 (patch-src_corelib_io_qstandardpaths_unix.cpp) = b12a41da19b25e34e12fdf80714a37e8c46278f9
 SHA1 (patch-src_corelib_io_qstorageinfo_unix.cpp) = 9919194e9f6b47f1f311b8f8223a6a7519152073
 SHA1 (patch-src_corelib_thread_qmutex__p.h) = 093089b8a37baa3071257c99bbde5f6295bd2eec
diff --git a/qt6-qtbase/patches/patch-src_corelib_global_qconfig-bootstrapped.h b/qt6-qtbase/patches/patch-src_corelib_global_qconfig-bootstrapped.h
new file mode 100644 (file)
index 0000000..adf677e
--- /dev/null
@@ -0,0 +1,18 @@
+$NetBSD$
+
+ getauxval is linux specific but sys/auxv.h is not, solaris has it
+
+--- src/corelib/global/qconfig-bootstrapped.h.orig     2021-04-01 08:27:54.537024937 +0000
++++ src/corelib/global/qconfig-bootstrapped.h
+@@ -88,7 +88,11 @@
+ #define QT_FEATURE_datetimeparser -1
+ #define QT_FEATURE_easingcurve -1
+ #define QT_FEATURE_etw -1
++#ifdef __linux__
+ #define QT_FEATURE_getauxval (__has_include(<sys/auxv.h>) ? 1 : -1)
++#else
++#define QT_FEATURE_getauxval -1
++#endif
+ #define QT_FEATURE_getentropy -1
+ #define QT_NO_GEOM_VARIANT
+ #define QT_FEATURE_hijricalendar -1
diff --git a/qt6-qtbase/patches/patch-src_corelib_global_qrandom.cpp b/qt6-qtbase/patches/patch-src_corelib_global_qrandom.cpp
deleted file mode 100644 (file)
index f7128c2..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-$NetBSD: patch-src_corelib_global_qrandom.cpp,v 1.1 2020/05/03 11:41:45 wiedi Exp $
-
-No getauxval on SunOS
-
---- src/corelib/global/qrandom.cpp.orig        2020-03-27 09:49:31.000000000 +0000
-+++ src/corelib/global/qrandom.cpp
-@@ -277,7 +277,7 @@ static void fallback_fill(quint32 *ptr,
-     if (quint32 v = seed.loadRelaxed())
-         *end++ = v; // 6
--#if QT_CONFIG(getauxval)
-+#if QT_CONFIG(getauxval) && !defined(Q_OS_SOLARIS)
-     // works on Linux -- all modern libc have getauxval
- #  ifdef AT_RANDOM
-     // ELF's auxv AT_RANDOM has 16 random bytes