llvm: Add PLIST substitution of LLVM_MAJOR_VERSION.
authorHavard Eidnes <he@NetBSD.org>
Thu, 5 Dec 2024 11:33:37 +0000 (12:33 +0100)
committerHavard Eidnes <he@NetBSD.org>
Thu, 5 Dec 2024 11:38:42 +0000 (12:38 +0100)
llvm/Makefile

index f3cb534b1989eab9efd9054d3f58eb2b2e32acb1..6bd9e77026f5800ed7895a408300e77ee60f78e9 100644 (file)
@@ -90,6 +90,7 @@ SOEXT=                so
 PLIST.notdylib=        yes
 .endif
 PLIST_SUBST+=  SOEXT=${SOEXT}
+PLIST_SUBST+=  LLVM_MAJOR_VERSION=${LLVM_MAJOR_VERSION}
 
 NOTDYLIBS=             LTO Remarks
 .for libname in ${NOTDYLIBS}