py-cantera: scons related TODO handled and removed from TODO list
authorMayuresh <mayuresh@acm.org>
Mon, 13 Jan 2025 17:31:03 +0000 (23:01 +0530)
committerMayuresh <mayuresh@acm.org>
Mon, 13 Jan 2025 17:31:56 +0000 (23:01 +0530)
py-cantera/Makefile
py-cantera/TODO

index 6c9296f78688e39a9de7e98841ff040d349ef5c3..f27d06bc68c3537ce5acf4ce3b1786f28cdbbbea 100644 (file)
@@ -25,6 +25,12 @@ SCONS_BUILD_ARGS+=   sundials_include=${PREFIX}/include
 SCONS_BUILD_ARGS+=     sundials_libdir=${PREFIX}/lib
 SCONS_BUILD_ARGS+=     run_examples=no
 
+# pkgsrc assumes PREFIX to be a standard argument and adds it implicitly
+# This package uses prefix instead. So have to do the following
+.include "../../devel/scons4/build.mk"
+_SCONS_BUILD_ARGS:=    ${_SCONS_BUILD_ARGS:NPREFIX=${PREFIX}}
+
+
 PKGCONFIG_OVERRIDE+=   platform/posix/cantera.pc.in
 
 DEPENDS+=      ${PYPKGPREFIX}-packaging>0:../../devel/py-packaging
@@ -35,6 +41,7 @@ DEPENDS+=     sundials>=7.1.1:../../wip/sundials
 
 TOOL_DEPENDS+= ${PYPKGPREFIX}-pip>=0:../../devel/py-pip
 TOOL_DEPENDS+= ${PYPKGPREFIX}-ruamel-yaml>=0.18.6:../../devel/py-ruamel-yaml
+TOOL_DEPENDS+= ${PYPKGPREFIX}-setuptools-[0-9]*:../../devel/py-setuptools
 
 CHECK_RELRO=   no
 
@@ -45,7 +52,7 @@ CHECK_RELRO=  no
 .include "../../wip/sundials/buildlink3.mk"
 .include "../../textproc/yaml-cpp/buildlink3.mk"
 .include "../../textproc/fmtlib/buildlink3.mk"
-.include "../../devel/scons4/build.mk"
 .include "../../devel/googletest/buildlink3.mk"
 .include "../../lang/python/wheel.mk"
+.include "../../lang/${PYPACKAGE}/buildlink3.mk"
 .include "../../mk/bsd.pkg.mk"
index c3d7747fbaa983e385ece123baef26ad38a2d7a3..b00ae593e03874c8775cddfb8f762de1f7c32d01 100644 (file)
@@ -1,9 +1,3 @@
-Requires this in scons4/build.mk since PREFIX option is not supported. (Or
-commenting this line should be fine since we add prefix to build args in
-Makefile.) A systematic solution is needed for this.
-
-       _SCONS_BUILD_ARGS+=     prefix=${PREFIX}
-
 Following warning may be handled by building sundials with blas/lapack
 
 - WARNING: External BLAS/LAPACK has been specified for Cantera but SUNDIALS was built without this support. Cantera will use the slower default solver implementations included with SUNDIALS. You can resolve this warning by installing or building SUNDIALS with BLAS/LAPACK support.