Fix the panic() thing differently so it builds on 1.51 and 1.50 alike.
authorHavard Eidnes <he@NetBSD.org>
Thu, 22 Apr 2021 07:51:19 +0000 (09:51 +0200)
committerHavard Eidnes <he@NetBSD.org>
Thu, 22 Apr 2021 07:52:42 +0000 (09:52 +0200)
Restore @PREFIX@ pattern for substitution, file is both patched
and substituted-into...

rust/Makefile
rust/distinfo
rust/patches/patch-src_bootstrap_builder.rs

index f27e0c1c606de3c9b54f5673db617ba44dfcb29a..a7d5b7cb0c7b432b85b6d7aa17e261054d9bfcfe 100644 (file)
@@ -134,7 +134,7 @@ CONFIGURE_ARGS+=    --set llvm.targets="ARM;X86"
 # If we aren't on 9-current, and are on 8.x or 9.x, avoid parallel.
 # \todo Consider avoiding setting this on netbsd-9 past the fix.
 .  if ${MACHINE_PLATFORM:MNetBSD-[1-9].*} && !${MACHINE_PLATFORM:MNetBSD-9.99.*}
-MAKE_JOBS_SAFE=        no
+#MAKE_JOBS_SAFE=       no
 .  endif
 
 # Open PRs
index 1c6161dd0ee7a8773fea427a5f345499b07028b7..15d2b890a6770697ffd5bd6df479f891ffa6754e 100644 (file)
@@ -107,7 +107,7 @@ SHA1 (patch-library_std_src_sys_unix_mod.rs) = 927b03f3f34bd21a81bd2a8b6bcf30fe2
 SHA1 (patch-library_std_src_sys_unix_thread.rs) = f3af869fba5bc0ab8d28042f55fe830f93b8ef54
 SHA1 (patch-library_unwind_build.rs) = ae096a20aed95304eb3806be4cd237fe4ffd9afb
 SHA1 (patch-src_bootstrap_bootstrap.py) = a8c094a781339a613221259d8ce7d00f6e0aa3e6
-SHA1 (patch-src_bootstrap_builder.rs) = 8427f3f9320a168581d0dd0142dc3952b7953183
+SHA1 (patch-src_bootstrap_builder.rs) = e04b3212786a422f70516227f7cbc7b29dcd699d
 SHA1 (patch-src_bootstrap_compile.rs) = 86fe55d04f7a8c5ec05dbdcb0fe5a0d6c07584d5
 SHA1 (patch-src_bootstrap_lib.rs) = 3277f2be69a269ac761a2a6ab4d5389d121e6ca6
 SHA1 (patch-src_llvm-project_llvm_CMakeLists.txt) = d49503d19c30a64d571eb7fa79e7aad7038cd427
index c5b0e06a1b4125b56053e30083528ca2b7351802..75e4eb3b183b3bfea456077d1729b785777b7f5b 100644 (file)
@@ -22,7 +22,7 @@ Workaround for building 1.51 with 1.51 bootstrap.
                  Some("-Wl,-rpath,@loader_path/../lib")
              } else if !target.contains("windows") {
 -                Some("-Wl,-rpath,$ORIGIN/../lib")
-+                Some("-Wl,-rpath,/usr/pkg/lib")
++                Some("-Wl,-rpath,@PREFIX@/lib")
              } else {
                  None
              };
@@ -31,7 +31,7 @@ Workaround for building 1.51 with 1.51 bootstrap.
                      out += &format!("\t{:?}\n", el);
                  }
 -                panic!(out);
-+                std::panic::panic_any(out);
++                panic!("{}", out);
              }
              if let Some(out) = self.cache.get(&step) {
                  self.verbose(&format!("{}c {:?}", "  ".repeat(stack.len()), step));