libretro-mgba: Update to 0.6.0
authorNia Alarie <nia.alarie@gmail.com>
Sun, 16 Jul 2017 23:05:37 +0000 (00:05 +0100)
committerNia Alarie <nia.alarie@gmail.com>
Sun, 16 Jul 2017 23:10:27 +0000 (00:10 +0100)
- All: Add C++ header guards
- All: Move time.h include to common.h
- ARM7: Fix MLA/*MULL/*MLAL timing
- GB: Fix flickering when screen is strobed quickly
- GB: Fix STAT blocking
- GB MBC: Fix ROM bank overflows getting set to bank 0
- GB MBC: Fix swapping carts not detect new MBC
- GB Timer: Improve DIV reset behavior
- GB Timer: Fix DIV batching if TAC changes
- GB Video: Reset renderer when loading state
- GBA: Fix multiboot ROM loading
- GBA: Fix multiboot loading resulting in too small WRAM
- GBA BIOS: Implement BitUnPack
- GBA BIOS: Fix ArcTan sign in HLE BIOS
- GBA BIOS: Fix ArcTan2 sign in HLE BIOS (fixes mgba.io/i/689)
- GBA BIOS: Fix INT_MIN/-1 crash
- GBA Hardware: Fix crash if a savestate lies about game hardware
- GBA I/O: Handle audio registers specially when deserializing
- GBA Memory: Improve initial skipped BIOS state
- GBA Savedata: Fix savedata unmasking (fixes mgba.io/i/441)
- GBA Savedata: Update and fix Sharkport importing (fixes mgba.io/i/658)
- GBA Video: Fix wrong palette on 256-color sprites in OBJWIN
- GBA Video: Don't update background scanline params in mode 0 (fixes mgba.io/i/377)
- Libretro: Fix saving in GB games (fixes mgba.io/i/486)
- LR35902: Fix core never exiting with certain event patterns
- LR35902: Fix pc overflowing current region off-by-one
- LR35902: Fix decoding LD r, $imm and 0-valued immediates (fixes mgba.io/i/735)
- Core: Fix crash with rewind if savestates shrink
- Core: Fix interrupting a thread while on the thread (fixes mgba.io/i/692)
- Core: Fix directory sets crashing on close if base isn't properly detached
- Core: New, faster event timing subsystem
- Core: Clean up some thread state checks
- Core: Add generic checksum function
- Core: Cores can now have multiple sets of callbacks
- Core: Restore sleep callback
- Core: Move rewind diffing to its own thread
- Core: Ability to enumerate and modify video and audio channels
- Core: List memory segments in the core
- Core: Move savestate creation time to extdata
- Core: Config values can now be hexadecimal
- Core: Improved threading interrupted detection
- GB: Trust ROM header for number of SRAM banks (fixes mgba.io/i/726)
- GB: Reset with initial state of DIV register
- GB MBC: New MBC7 implementation
- GB Audio: Simplify envelope code
- GB Audio: Improve initial envelope samples
- GB Audio: Start implementing "zombie" audio (fixes mgba.io/i/389)
- GB Video: Improved video timings
- GBA: Ignore invalid opcodes used by the Wii U VC emulator
- GBA, GB: ROM is now unloaded if a patch is applied
- GBA DMA: Refactor DMA out of memory.c
- GBA DMA: Move DMAs to using absolute timing
- GBA I/O: Clear JOYSTAT RECV flag when reading JOY_RECV registers
- GBA I/O: Set JOYSTAT TRANS flag when writing JOY_TRANS registers
- GBA Memory: Support for Mo Jie Qi Bing by Vast Fame (taizou)
- GBA Memory: Support reading/writing POSTFLG
- GBA Memory: Remove unused prefetch cruft
- GBA Timer: Improve accuracy of timers
- GBA Video: Clean up unused timers
- GBA Video: Allow multiple handles into the same tile cache
- GBA Video, GB Video: Colors are now fully scaled
- GBA Video: Optimize when BLD* registers are written frequently

libretro-mgba/Makefile
libretro-mgba/PLIST
libretro-mgba/distinfo
libretro-mgba/patches/patch-CMakeLists.txt
libretro-mgba/patches/patch-include_mgba-util_math.h [moved from libretro-mgba/patches/patch-src_util_math.h with 69% similarity]
libretro-mgba/patches/patch-src_util_common.h [deleted file]

index 9e5fbecd4f426ccf611ae5af5c73063a33947ae7..6f681ed86a159be325a33ef0c27710b5e0e2022b 100644 (file)
@@ -1,9 +1,10 @@
 # $NetBSD$
 
-DISTNAME=      libretro-mgba-0.5.2
+DISTNAME=      libretro-mgba-0.6.0
 CATEGORIES=    emulators
 MASTER_SITES=  ${MASTER_SITE_GITHUB:=mgba-emu/}
 
+MAINTAINER=    nia.alarie@gmail.com
 HOMEPAGE=      https://mgba.io/
 COMMENT=       Libretro core based on the mGBA emulator
 LICENSE=       mpl-2.0
@@ -13,16 +14,19 @@ GITHUB_PROJECT=     mgba
 WRKSRC=                ${WRKDIR}/mgba-${PKGVERSION_NOREV}
 
 USE_CMAKE=     yes
+USE_LANGUAGES= c c++ # doesn't really use C++, but cmake likes having it?
 
-CMAKE_ARGS+=   -DUSE_CLI_DEBUGGER=OFF
+CMAKE_ARGS+=   -DUSE_DEBUGGERS=OFF
 CMAKE_ARGS+=   -DUSE_GDB_STUB=OFF
 
+CMAKE_ARGS+=   -DUSE_EDITLINE=OFF
 CMAKE_ARGS+=   -DUSE_FFMPEG=OFF
 CMAKE_ARGS+=   -DUSE_ZLIB=OFF
 CMAKE_ARGS+=   -DUSE_MINIZIP=OFF
 CMAKE_ARGS+=   -DUSE_PNG=OFF
 CMAKE_ARGS+=   -DUSE_LIBZIP=OFF
 CMAKE_ARGS+=   -DUSE_MAGICK=OFF
+CMAKE_ARGS+=   -DUSE_SQLITE3=OFF
 CMAKE_ARGS+=   -DUSE_LZMA=OFF
 CMAKE_ARGS+=   -DUSE_EPOXY=OFF
 
index 6348032f64541c27cd037d6a9ffe41dc0f21f566..113500aaab2b20fc22f6f880f6fe858a1fb00aef 100644 (file)
@@ -1,4 +1,5 @@
 @comment $NetBSD$
+include/mgba/flags.h
 lib/libretro/mgba_libretro.so
 share/doc/mGBA/CHANGES
 share/doc/mGBA/README.md
index 4ead6b8f2e8287e676495d3800d31b5505dd07e5..59a03bc608ba8a282294efea180a3fbdc631f1f1 100644 (file)
@@ -1,9 +1,8 @@
 $NetBSD$
 
-SHA1 (libretro-mgba-0.5.2.tar.gz) = 22b09272efb13429be89bf468cdcad9ae6fa4379
-RMD160 (libretro-mgba-0.5.2.tar.gz) = 96ec87c5faae7bf1c54f0d0152a78d618fc0a43b
-SHA512 (libretro-mgba-0.5.2.tar.gz) = 8d3ef901bae9b503f8d5afff63c23be9af4b519f86cc6f3656c51374756107e4852bc0472cb7393cb04c8f0ff2f134367a81e32a5ff3dab8ae0c6cbd7d3858da
-Size (libretro-mgba-0.5.2.tar.gz) = 5343635 bytes
-SHA1 (patch-CMakeLists.txt) = 40a122b32f2ac964218364869630682a84ebd920
-SHA1 (patch-src_util_common.h) = 8fc1fd5d204c0919b924a8461cba27be4751b84d
-SHA1 (patch-src_util_math.h) = a3f7e4412e5df4d2119a13fd9e4122f3d0f6bf23
+SHA1 (libretro-mgba-0.6.0.tar.gz) = 6982b916ac86cad3cc7f24342ac2817f0cd6a49e
+RMD160 (libretro-mgba-0.6.0.tar.gz) = bdca70bac1893e3a0e8921307221f28f64598d20
+SHA512 (libretro-mgba-0.6.0.tar.gz) = 24a9c75370465246e467f03498994e2f142bed18435658aa75ee8dc7ad9f8fa649b476b7846c0f3c4be474ca1d3b7c36e34af05b4088fa3a7a11e3edb0074308
+Size (libretro-mgba-0.6.0.tar.gz) = 7434157 bytes
+SHA1 (patch-CMakeLists.txt) = fad5aa8ac36f80d11cdf59fd5be9fd72faf1019f
+SHA1 (patch-include_mgba-util_math.h) = 448ca1bb3bbe2812e7d9482917c488ddcf3b48f0
index ceeabb9c7906d7cff4c88dd624a4a33cbf1a6579..fa6ed569883abc638b4595b217b86c0f4c11b6f2 100644 (file)
@@ -2,9 +2,9 @@ $NetBSD$
 
 vfs-dirent peeks into non-standard structures and is not needed for libretro.
 
---- CMakeLists.txt.orig        2016-12-31 09:45:51.000000000 +0000
+--- CMakeLists.txt.orig        2017-07-16 19:04:50.000000000 +0000
 +++ CMakeLists.txt
-@@ -185,7 +185,7 @@ elseif(UNIX)
+@@ -208,7 +208,7 @@ elseif(UNIX)
                set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -pthread")
        endif()
  
similarity index 69%
rename from libretro-mgba/patches/patch-src_util_math.h
rename to libretro-mgba/patches/patch-include_mgba-util_math.h
index 9ce1ec979fb9094e81e6a9a44e7b3c1691b9fd20..19c8de8542cb405aa0cbc9027363093e52b70a29 100644 (file)
@@ -1,12 +1,12 @@
 $NetBSD$
 
-NetBSD defines popcount32 in libc
+NetBSD defines popcount32 in libc.
 
---- src/util/math.h.orig       2017-03-29 18:42:18.000000000 +0000
-+++ src/util/math.h
-@@ -8,11 +8,15 @@
+--- include/mgba-util/math.h.orig      2017-07-16 19:04:50.000000000 +0000
++++ include/mgba-util/math.h
+@@ -10,11 +10,15 @@
  
- #include "util/common.h"
+ CXX_GUARD_START
  
 +#ifndef __NetBSD__
  static inline uint32_t popcount32(unsigned bits) {
diff --git a/libretro-mgba/patches/patch-src_util_common.h b/libretro-mgba/patches/patch-src_util_common.h
deleted file mode 100644 (file)
index e7cad98..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-$NetBSD$
-
-Needed for strcasecmp
-
---- src/util/common.h.orig     2017-03-29 18:42:18.000000000 +0000
-+++ src/util/common.h
-@@ -18,6 +18,7 @@
- #include <stdio.h>
- #include <stdlib.h>
- #include <string.h>
-+#include <strings.h>
- #ifdef _WIN32
- // WinSock2 gets very angry if it's included too late