compiler-rt-git: Drop, no longer needed
authorKamil Rytarowski <n54@gmx.com>
Sat, 15 Dec 2018 18:28:11 +0000 (19:28 +0100)
committerKamil Rytarowski <n54@gmx.com>
Sat, 15 Dec 2018 18:28:35 +0000 (19:28 +0100)
compiler-rt-git/DESCR [deleted file]
compiler-rt-git/Makefile [deleted file]
compiler-rt-git/PLIST [deleted file]
compiler-rt-git/buildlink3.mk [deleted file]
compiler-rt-git/distinfo [deleted file]

diff --git a/compiler-rt-git/DESCR b/compiler-rt-git/DESCR
deleted file mode 100644 (file)
index ec4b69e..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-The compiler-rt project consists of:
-
- - builtins - a simple library that provides an implementation of the low-level
-   target-specific hooks required by code generation and other runtime
-   components. For example, when compiling for a 32-bit target, converting a
-   double to a 64-bit unsigned integer is compiling into a runtime call to the
-   "__fixunsdfdi" function. The builtins library provides optimized
-   implementations of this and other low-level routines, either in
-   target-independent C form, or as a heavily-optimized assembly.
-
-   builtins provides full support for the libgcc interfaces on supported
-   targets and high performance hand tuned implementations of commonly used
-   functions like __floatundidf in assembly that are dramatically faster than
-   the libgcc implementations. It should be very easy to bring builtins to
-   support a new target by adding the new routines needed by that target.
-
- - sanitizer runtimes - runtime libraries that are required to run the code
-   with sanitizer instrumentation. This includes runtimes for:
-   *     AddressSanitizer
-   *     ThreadSanitizer
-   *     UndefinedBehaviorSanitizer
-   *     MemorySanitizer
-   *     LeakSanitizer
-   *     DataFlowSanitizer
-
- - profile - library which is used to collect coverage information.
-
- - BlocksRuntime - a target-independent implementation of Apple "Blocks"
-   runtime interfaces.
diff --git a/compiler-rt-git/Makefile b/compiler-rt-git/Makefile
deleted file mode 100644 (file)
index 3345f55..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-# $NetBSD: Makefile.common,v 1.7 2015/07/20 05:49:53 adam Exp $
-
-PKGNAME=       compiler-rt-6.0.0
-CATEGORIES=    lang devel
-
-GIT_REPOSITORIES=      compiler-rt
-GIT_REPO.compiler-rt=  https://github.com/llvm-mirror/compiler-rt.git
-
-MAINTAINER=    pkgsrc-users@NetBSD.org
-HOMEPAGE=      http://compiler-rt.llvm.org/
-COMMENT=       LLVM runtime libraries
-LICENSE=       modified-bsd OR mit
-
-WRKSRC=                        ${WRKDIR}/build
-
-USE_LANGUAGES=         c c++11
-USE_CMAKE=             yes
-GCC_REQD+=             4.8
-
-WRKSRC=                        ${WRKDIR}/${PKGBASE}
-CONFIGURE_DIRS=                ${WRKDIR}/build
-CMAKE_ARG_PATH=                ${WRKSRC}
-
-CMAKE_ARGS+=   -DCMAKE_BUILD_TYPE=Release
-CMAKE_ARGS+=   -DCMAKE_C_COMPILER=${CC:Q}
-CMAKE_ARGS+=   -DCMAKE_CXX_COMPILER=${CXX:Q}
-CMAKE_ARGS+=   -DCOMPILER_RT_OS_DIR:STRING=${LOWER_OPSYS}${OS_VERSION:R}
-CMAKE_ARGS+=   -DCOMPILER_RT_INSTALL_PATH:STRING=lib/clang/${PKGVERSION_NOREV}
-#CMAKE_ARGS+=  -DCOMPILER_RT_INCLUDE_TESTS:BOOL=ON
-# Not supported in standalone build
-CMAKE_ARGS+=   -DCOMPILER_RT_INCLUDE_TESTS:BOOL=OFF
-
-PLIST_SUBST+=  COMPILER_RT_OS_DIR=${LOWER_OPSYS}${OS_VERSION:R}
-
-#TEST_TARGET=          check-compiler-rt
-#TEST_ENV+=            LD_LIBRARY_PATH=${WRKDIR}/build/lib
-
-post-extract:
-       ${RUN} mkdir -p ${WRKDIR}/build
-
-.include "../../wip/mk/git-package.mk"
-.include "../../devel/googletest/buildlink3.mk"
-DEPENDS+=      llvm-${PKGVERSION_NOREV}{,nb*}:../../wip/llvm-git
-.include "../../wip/llvm-git/buildlink3.mk"
-.include "../../mk/bsd.pkg.mk"
diff --git a/compiler-rt-git/PLIST b/compiler-rt-git/PLIST
deleted file mode 100644 (file)
index ee38c6a..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-@comment $NetBSD$
-lib/clang/${PKGVERSION}/asan_blacklist.txt
-lib/clang/${PKGVERSION}/cfi_blacklist.txt
-lib/clang/${PKGVERSION}/include/sanitizer/allocator_interface.h
-lib/clang/${PKGVERSION}/include/sanitizer/asan_interface.h
-lib/clang/${PKGVERSION}/include/sanitizer/common_interface_defs.h
-lib/clang/${PKGVERSION}/include/sanitizer/coverage_interface.h
-lib/clang/${PKGVERSION}/include/sanitizer/dfsan_interface.h
-lib/clang/${PKGVERSION}/include/sanitizer/esan_interface.h
-lib/clang/${PKGVERSION}/include/sanitizer/linux_syscall_hooks.h
-lib/clang/${PKGVERSION}/include/sanitizer/lsan_interface.h
-lib/clang/${PKGVERSION}/include/sanitizer/msan_interface.h
-lib/clang/${PKGVERSION}/include/sanitizer/tsan_interface.h
-lib/clang/${PKGVERSION}/include/sanitizer/tsan_interface_atomic.h
-lib/clang/${PKGVERSION}/include/xray/xray_interface.h
-lib/clang/${PKGVERSION}/include/xray/xray_log_interface.h
-lib/clang/${PKGVERSION}/lib/${COMPILER_RT_OS_DIR}/libclang_rt.asan-i386.a
-lib/clang/${PKGVERSION}/lib/${COMPILER_RT_OS_DIR}/libclang_rt.asan-i386.so
-lib/clang/${PKGVERSION}/lib/${COMPILER_RT_OS_DIR}/libclang_rt.asan-preinit-i386.a
-lib/clang/${PKGVERSION}/lib/${COMPILER_RT_OS_DIR}/libclang_rt.asan-preinit-x86_64.a
-lib/clang/${PKGVERSION}/lib/${COMPILER_RT_OS_DIR}/libclang_rt.asan-x86_64.a
-lib/clang/${PKGVERSION}/lib/${COMPILER_RT_OS_DIR}/libclang_rt.asan-x86_64.a.syms
-lib/clang/${PKGVERSION}/lib/${COMPILER_RT_OS_DIR}/libclang_rt.asan-x86_64.so
-lib/clang/${PKGVERSION}/lib/${COMPILER_RT_OS_DIR}/libclang_rt.asan_cxx-i386.a
-lib/clang/${PKGVERSION}/lib/${COMPILER_RT_OS_DIR}/libclang_rt.asan_cxx-x86_64.a
-lib/clang/${PKGVERSION}/lib/${COMPILER_RT_OS_DIR}/libclang_rt.asan_cxx-x86_64.a.syms
-lib/clang/${PKGVERSION}/lib/${COMPILER_RT_OS_DIR}/libclang_rt.builtins-i386.a
-lib/clang/${PKGVERSION}/lib/${COMPILER_RT_OS_DIR}/libclang_rt.builtins-x86_64.a
-lib/clang/${PKGVERSION}/lib/${COMPILER_RT_OS_DIR}/libclang_rt.fuzzer-x86_64.a
-lib/clang/${PKGVERSION}/lib/${COMPILER_RT_OS_DIR}/libclang_rt.fuzzer_no_main-x86_64.a
-lib/clang/${PKGVERSION}/lib/${COMPILER_RT_OS_DIR}/libclang_rt.safestack-i386.a
-lib/clang/${PKGVERSION}/lib/${COMPILER_RT_OS_DIR}/libclang_rt.safestack-x86_64.a
-lib/clang/${PKGVERSION}/lib/${COMPILER_RT_OS_DIR}/libclang_rt.stats-i386.a
-lib/clang/${PKGVERSION}/lib/${COMPILER_RT_OS_DIR}/libclang_rt.stats-x86_64.a
-lib/clang/${PKGVERSION}/lib/${COMPILER_RT_OS_DIR}/libclang_rt.stats_client-i386.a
-lib/clang/${PKGVERSION}/lib/${COMPILER_RT_OS_DIR}/libclang_rt.stats_client-x86_64.a
-lib/clang/${PKGVERSION}/lib/${COMPILER_RT_OS_DIR}/libclang_rt.ubsan_minimal-i386.a
-lib/clang/${PKGVERSION}/lib/${COMPILER_RT_OS_DIR}/libclang_rt.ubsan_minimal-i386.so
-lib/clang/${PKGVERSION}/lib/${COMPILER_RT_OS_DIR}/libclang_rt.ubsan_minimal-x86_64.a
-lib/clang/${PKGVERSION}/lib/${COMPILER_RT_OS_DIR}/libclang_rt.ubsan_minimal-x86_64.a.syms
-lib/clang/${PKGVERSION}/lib/${COMPILER_RT_OS_DIR}/libclang_rt.ubsan_minimal-x86_64.so
-lib/clang/${PKGVERSION}/lib/${COMPILER_RT_OS_DIR}/libclang_rt.ubsan_standalone-i386.a
-lib/clang/${PKGVERSION}/lib/${COMPILER_RT_OS_DIR}/libclang_rt.ubsan_standalone-i386.so
-lib/clang/${PKGVERSION}/lib/${COMPILER_RT_OS_DIR}/libclang_rt.ubsan_standalone-x86_64.a
-lib/clang/${PKGVERSION}/lib/${COMPILER_RT_OS_DIR}/libclang_rt.ubsan_standalone-x86_64.a.syms
-lib/clang/${PKGVERSION}/lib/${COMPILER_RT_OS_DIR}/libclang_rt.ubsan_standalone-x86_64.so
-lib/clang/${PKGVERSION}/lib/${COMPILER_RT_OS_DIR}/libclang_rt.ubsan_standalone_cxx-i386.a
-lib/clang/${PKGVERSION}/lib/${COMPILER_RT_OS_DIR}/libclang_rt.ubsan_standalone_cxx-x86_64.a
-lib/clang/${PKGVERSION}/lib/${COMPILER_RT_OS_DIR}/libclang_rt.ubsan_standalone_cxx-x86_64.a.syms
diff --git a/compiler-rt-git/buildlink3.mk b/compiler-rt-git/buildlink3.mk
deleted file mode 100644 (file)
index 904e0e5..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-# $NetBSD$
-
-BUILDLINK_TREE+=       compiler-rt
-
-.if !defined(COMPILER_RT_BUILDLINK3_MK)
-COMPILER_RT_BUILDLINK3_MK:=
-
-BUILDLINK_API_DEPENDS.compiler-rt+=    compiler-rt>=4.0.0nb20160924
-BUILDLINK_PKGSRCDIR.compiler-rt?=      ../../wip/compiler-rt-git
-
-.include "../../wip/llvm-git/buildlink3.mk"
-.endif # COMPILER_RT_BUILDLINK3_MK
-
-BUILDLINK_TREE+=       -compiler-rt
diff --git a/compiler-rt-git/distinfo b/compiler-rt-git/distinfo
deleted file mode 100644 (file)
index 7931384..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-$NetBSD: distinfo,v 1.35 2015/09/11 01:21:57 tnn Exp $
-
-SHA1 (cfe-3.6.2.src.tar.xz) = 7ba809c9c17819a16b668640a642ed134d7052f0
-RMD160 (cfe-3.6.2.src.tar.xz) = 10d913b4d5317f8c2520e5fc6117df30937317a8
-Size (cfe-3.6.2.src.tar.xz) = 8617576 bytes
-SHA1 (compiler-rt-3.6.2.src.tar.xz) = c6c52d2923a60f1a2ca2f22fea1770fd2e25728d
-RMD160 (compiler-rt-3.6.2.src.tar.xz) = 9b68a32d49d4bef4603d550934192f39fea42895
-Size (compiler-rt-3.6.2.src.tar.xz) = 1128080 bytes
-SHA1 (libcxx-3.6.2.src.tar.xz) = 6c5aee9f05ecf17d1e3ecb1add34a33a5a904469
-RMD160 (libcxx-3.6.2.src.tar.xz) = 42b8832d01d4e6b553babc93cb5dbd4ce2bb1931
-Size (libcxx-3.6.2.src.tar.xz) = 944020 bytes
-SHA1 (llvm-3.6.2.src.tar.xz) = 7a00257eb2bc9431e4c77c3a36b033072c54bc7e
-RMD160 (llvm-3.6.2.src.tar.xz) = 521cbc5fe2925ea3c6e90c7a31f752a04045c972
-Size (llvm-3.6.2.src.tar.xz) = 12802380 bytes