wip/pinentry-dmenu: import pinentry-dmenu-0.2.2
authorKamil Rytarowski <n54@gmx.com>
Tue, 27 Oct 2020 00:33:15 +0000 (01:33 +0100)
committerKamil Rytarowski <n54@gmx.com>
Tue, 27 Oct 2020 00:33:15 +0000 (01:33 +0100)
pinentry-dmenu is a pinentry program with the charm of dmenu.

pinentry-dmenu/DESCR [new file with mode: 0644]
pinentry-dmenu/Makefile [new file with mode: 0644]
pinentry-dmenu/PLIST [new file with mode: 0644]
pinentry-dmenu/distinfo [new file with mode: 0644]
pinentry-dmenu/patches/patch-pinentry_pinentry.c [new file with mode: 0644]

diff --git a/pinentry-dmenu/DESCR b/pinentry-dmenu/DESCR
new file mode 100644 (file)
index 0000000..4d0044b
--- /dev/null
@@ -0,0 +1 @@
+pinentry-dmenu is a pinentry program with the charm of dmenu.
diff --git a/pinentry-dmenu/Makefile b/pinentry-dmenu/Makefile
new file mode 100644 (file)
index 0000000..ff8c2eb
--- /dev/null
@@ -0,0 +1,23 @@
+# $NetBSD$
+
+DISTNAME=      pinentry-dmenu-0.2.2
+CATEGORIES=    x11
+MASTER_SITES=  ${MASTER_SITE_GITHUB:=ritze/}
+
+MAINTAINER=    pkgsrc-users@NetBSD.org
+HOMEPAGE=      https://github.com/ritze/pinentry-dmenu/
+COMMENT=       A pinentry program with the charm of dmenu
+LICENSE=       gnu-gpl-v2
+
+WRKSRC=        ${WRKDIR}/pinentry-dmenu-0.2.2
+
+CFLAGS.NetBSD+=        -D_NETBSD_SOURCE
+
+USE_X11=yes
+
+#.include "../../x11/libXft/buildlink3.mk"
+.include "../../graphics/freetype2/buildlink3.mk"
+#.include "../../x11/libX11/buildlink3.mk"
+.include "../../devel/libconfig/buildlink3.mk"
+.include "../../security/libassuan2/buildlink3.mk"
+.include "../../mk/bsd.pkg.mk"
diff --git a/pinentry-dmenu/PLIST b/pinentry-dmenu/PLIST
new file mode 100644 (file)
index 0000000..92ba51a
--- /dev/null
@@ -0,0 +1,4 @@
+@comment $NetBSD$
+@comment TODO: to fill this file with the file listing:
+@comment TODO: 1. run "/usr/bin/make package"
+@comment TODO: 2. run "/usr/bin/make print-PLIST"
diff --git a/pinentry-dmenu/distinfo b/pinentry-dmenu/distinfo
new file mode 100644 (file)
index 0000000..07d306e
--- /dev/null
@@ -0,0 +1,7 @@
+$NetBSD$
+
+SHA1 (pinentry-dmenu/0.2.2.zip) = 0eac07b2990f39dcba079e837efa52f26c278cf5
+RMD160 (pinentry-dmenu/0.2.2.zip) = fc47dd4363e2fb61ae3aae522b579dd629dccd09
+SHA512 (pinentry-dmenu/0.2.2.zip) = 8eb897542fcde9db6c8b2137a80d706801071957ba30f699b97e96a264227943908834859bf4a86fe831358b7f5ace3ce1dfca82bd7851f940d2face3567d24d
+Size (pinentry-dmenu/0.2.2.zip) = 67065 bytes
+SHA1 (patch-pinentry_pinentry.c) = f5817cc4e2bede300e93a1f1d42fb374d4a7c897
diff --git a/pinentry-dmenu/patches/patch-pinentry_pinentry.c b/pinentry-dmenu/patches/patch-pinentry_pinentry.c
new file mode 100644 (file)
index 0000000..53d8ae5
--- /dev/null
@@ -0,0 +1,14 @@
+$NetBSD$
+
+- include strings.h for strcasecmp(3) on NetBSD
+
+--- pinentry/pinentry.c.orig   2020-05-23 11:50:06.000000000 +0000
++++ pinentry/pinentry.c
+@@ -19,6 +19,7 @@
+ #include <stdlib.h>
+ #include <string.h>
++#include <strings.h>
+ #include <unistd.h>
+ #include <assert.h>