Import ympd-1.3.0 as wip/ympd.
authorKamil Rytarowski <n54@gmx.com>
Fri, 19 Aug 2016 02:52:07 +0000 (04:52 +0200)
committerKamil Rytarowski <n54@gmx.com>
Fri, 19 Aug 2016 02:52:07 +0000 (04:52 +0200)
ympd is a lightweight MPD (Music Player Daemon) web client that runs without a
dedicated webserver or interpreters like PHP, NodeJS or Ruby. It's tuned for
minimal resource usage and requires only very litte dependencies.

ympd/DESCR [new file with mode: 0644]
ympd/Makefile [new file with mode: 0644]
ympd/PLIST [new file with mode: 0644]
ympd/distinfo [new file with mode: 0644]
ympd/patches/patch-CMakeLists.txt [new file with mode: 0644]

diff --git a/ympd/DESCR b/ympd/DESCR
new file mode 100644 (file)
index 0000000..cb3727b
--- /dev/null
@@ -0,0 +1,3 @@
+ympd is a lightweight MPD (Music Player Daemon) web client that runs without a
+dedicated webserver or interpreters like PHP, NodeJS or Ruby. It's tuned for
+minimal resource usage and requires only very litte dependencies.
diff --git a/ympd/Makefile b/ympd/Makefile
new file mode 100644 (file)
index 0000000..6febb87
--- /dev/null
@@ -0,0 +1,18 @@
+# $NetBSD$
+
+DISTNAME=      ympd-1.3.0
+CATEGORIES=    audio
+MASTER_SITES=  ${MASTER_SITE_GITHUB:=notandy/}
+GITHUB_TAG=    v${PKGVERSION_NOREV}
+
+MAINTAINER=    pkgsrc-users@NetBSD.org
+HOMEPAGE=      http://www.ympd.org/
+COMMENT=       Standalone MPD Web GUI written in C
+LICENSE=       gnu-gpl-v2
+
+USE_CMAKE=     yes
+
+USE_LANGUAGES= c c++
+
+.include "../../audio/libmpdclient/buildlink3.mk"
+.include "../../mk/bsd.pkg.mk"
diff --git a/ympd/PLIST b/ympd/PLIST
new file mode 100644 (file)
index 0000000..e1497c0
--- /dev/null
@@ -0,0 +1,3 @@
+@comment $NetBSD$
+bin/ympd
+man/man1/ympd.1
diff --git a/ympd/distinfo b/ympd/distinfo
new file mode 100644 (file)
index 0000000..a8e14aa
--- /dev/null
@@ -0,0 +1,7 @@
+$NetBSD$
+
+SHA1 (ympd-1.3.0.tar.gz) = 588df4e0622fa292e42074d357a4d09e37e308a3
+RMD160 (ympd-1.3.0.tar.gz) = b78cba8aa05dcd7bf7244af1b8e1d6360486b8c5
+SHA512 (ympd-1.3.0.tar.gz) = 7e2bd4124b0e7692e2528e9fc50955d1b357ba042d8c97941160ad31ee0c89bc53b349195b45d27ce77aaa954bc01aceba1a30cdb89d9f58644a0b4934498a16
+Size (ympd-1.3.0.tar.gz) = 350115 bytes
+SHA1 (patch-CMakeLists.txt) = 164d1b408be2301ff316d28adcedc57be8c4ea9c
diff --git a/ympd/patches/patch-CMakeLists.txt b/ympd/patches/patch-CMakeLists.txt
new file mode 100644 (file)
index 0000000..0773a52
--- /dev/null
@@ -0,0 +1,23 @@
+$NetBSD$
+
+Install man-page into appropriate directory.
+
+--- CMakeLists.txt.orig        2016-02-13 21:01:52.000000000 +0000
++++ CMakeLists.txt
+@@ -1,5 +1,7 @@
+ cmake_minimum_required(VERSION 2.6)
++include(GNUInstallDirs)
++
+ project (ympd)
+ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${PROJECT_SOURCE_DIR}/cmake/")
+ set(CPACK_PACKAGE_VERSION_MAJOR "1")
+@@ -73,7 +75,7 @@ add_executable(ympd ${SOURCES})
+ target_link_libraries(ympd ${LIBMPDCLIENT_LIBRARY} ${CMAKE_THREAD_LIBS_INIT} ${OPENSSL_LIBRARIES})
+ install(TARGETS ympd DESTINATION bin)
+-install(FILES ympd.1 DESTINATION ${CMAKE_INSTALL_PREFIX}/share/man/man1)
++install(FILES ympd.1 DESTINATION ${CMAKE_INSTALL_MANDIR}/man1)
+ if(WITH_DYNAMIC_ASSETS)
+     install(DIRECTORY htdocs DESTINATION share/${PROJECT_NAME})
+ endif()