Fix build on NetBSD by requiring gcc 9.
This removes the linker error when
using std::filesystem.
Since gcc 9 has std::filesystem in stdc++
don't link to stdc++fs on NetBSD.
Telemetry is not supported on NetBSD and
FreeBSD so disable it in pkgsrc to make
the PLIST consistent.
While here depend on cxxopts from pkgsrc
instead of the bundled one.
USE_TOOLS+= pkg-config
USE_LANGUAGES= c c++
USE_TOOLS+= perl
-GCC_REQD+= 8 # uses std::filesystem
-LIBS+= -lstdc++fs
+GCC_REQD+= 9 # uses std::filesystem
+#LIBS+= -lstdc++fs
#.include "../../mk/bsd.prefs.mk"
#PKGSRC_COMPILER= clang
#BUILDLINK_DEPMETHOD.clang= build
CMAKE_ARGS+= -DDISABLE_VCPKG=ON
-
+CMAKE_ARGS+= -DDISABLE_TELEMETRY=ON
PKGCONFIG_OVERRIDE+= external_imported/Catch2/CMake/catch2.pc.in
PKGCONFIG_OVERRIDE+= external_imported/UniversalStacktrace/external/Catch2/CMake/catch2.pc.in
PKGCONFIG_OVERRIDE+= external_imported/vcpkg/ports/v8/v8_libplatform.pc.in
PKGCONFIG_OVERRIDE+= external_imported/vcpkg/ports/v8/v8_monolith.pc.in
+.include "../../devel/cxxopts/buildlink3.mk"
.include "../../devel/protobuf/buildlink3.mk"
.include "../../security/libsodium/buildlink3.mk"
@comment $NetBSD$
-bin/crashpad_handler
bin/et
bin/etserver
bin/etterminal
bin/htm
bin/htmd
-lib/cmake/sentry/sentry_crashpad-targets.cmake
-lib/libcrashpad_client.a
-lib/libcrashpad_handler_lib.a
-lib/libcrashpad_minidump.a
-lib/libcrashpad_snapshot.a
-lib/libcrashpad_tools.a
-lib/libcrashpad_util.a
-lib/libmini_chromium.a
/usr/obj/pkgsrc/wip/et/work/EternalTerminal-et-v6.1.11/src/base/LogHandler.cpp:51: undefined reference to `std::filesystem::permissions(std::filesystem::__cxx11::path const&, std::filesystem::perms, std::filesystem::perm_options)'
collect2: error: ld returned 1 exit status
+nros: The above is now fixed.
BLAKE2s (EternalTerminal/et-6.1.11.tar.gz) = 0e7079816a169b76e08c395c3f010df424a2f5abe95d99c0b08af53ae0b021e5
SHA512 (EternalTerminal/et-6.1.11.tar.gz) = 71b1fe20096a46e6f0ce87ec18d5074f90f48193a1637becb9692b20e7d92fc3b091cf843cecca30a4591fc94396494ff8282343ec6068a2905afd8f4225b3e4
Size (EternalTerminal/et-6.1.11.tar.gz) = 22081590 bytes
-SHA1 (patch-CMakeLists.txt) = 34356ce801a003d8d0962691a9e046d593bb6461
+SHA1 (patch-CMakeLists.txt) = b3f41dc56c7d9828f24ddb49e2b5157c6495ffd6
$NetBSD$
---- CMakeLists.txt.orig 2022-02-18 19:34:07.809964843 +0000
+* use pkgsrc cxxopts
+
+--- CMakeLists.txt.orig 2022-01-11 14:53:44.000000000 +0000
+++ CMakeLists.txt
@@ -281,11 +281,6 @@ macro(DECORATE_TARGET TARGET_NAME)
add_sanitizers(${TARGET_NAME})
endmacro()
include_directories(
+@@ -293,7 +288,6 @@ include_directories(
+ ${EXTERNAL_DIR}/ThreadPool
+ ${EXTERNAL_DIR}/PlatformFolders
+ ${EXTERNAL_DIR}/Catch2/single_include
+- ${EXTERNAL_DIR}/cxxopts/include
+ ${EXTERNAL_DIR}/msgpack-c/include
+ ${EXTERNAL_DIR}/sentry-native/include
+ ${EXTERNAL_DIR}/json/single_include/nlohmann