corefx-git: Revamp Makefile for passing env and args to build.sh
authorKamil Rytarowski <n54@gmx.com>
Mon, 8 Feb 2016 10:46:56 +0000 (11:46 +0100)
committerKamil Rytarowski <n54@gmx.com>
Mon, 8 Feb 2016 10:46:56 +0000 (11:46 +0100)
corefx-git/Makefile

index b6d96fced5bfee3deecbf53200376b2996f7b1b6..76d9b6bb1e4a386e3e79b6263b966cfad4164eb1 100644 (file)
@@ -12,14 +12,19 @@ HOMEPAGE=   https://github.com/dotnet/corefx
 COMMENT=       The .NET Core foundational libraries
 LICENSE=       mit
 
-#USE_CMAKE=    yes
+# We need to set CMake this way to get defined CMAKE_ARGS
+USE_CMAKE=     yes
 USE_LANGUAGES= c c++
 
 USE_TOOLS+=    bash
 REPLACE_BASH+= build.sh
 
+do-configure:
+       ${RUN} ${ECHO} Skip configure and call CMake via build.sh
+
 do-build:
-               ${RUN} cd ${WRKSRC} && PYTHON=${PYTHONBIN} ./build.sh native verbose
+       ${RUN} cd ${WRKSRC} && \
+       ${PKGSRC_SETENV} ${CONFIGURE_ENV} CMAKE_ARGS_EXTRA=${CMAKE_ARGS:Q} ./build.sh native verbose
 
 .include "../../textproc/icu/buildlink3.mk"
 .include "../../wip/llvm-git/buildlink3.mk"