pike8.0: mark some phony targets
authorWilliam Welliver <william@welliver.org>
Tue, 29 Jan 2019 06:02:33 +0000 (01:02 -0500)
committerWilliam Welliver <william@welliver.org>
Tue, 29 Jan 2019 06:02:33 +0000 (01:02 -0500)
pike8.0/Makefile
pike8.0/builtin_module.mk

index 7dac51620e7d74f423906dae665dd7908dbd935f..0145ae253150f4e83e8ab96112d4cb79a98c6a39 100644 (file)
@@ -83,6 +83,8 @@ post-build:
        ${SED} -e 's~${WRKSRC}/smartlink~${PREFIX}/include/${NAME}/smartlink~' < ${WRKSRC}/specs > ${WRKSRC}/specs.tmp
        mv ${WRKSRC}/specs.tmp ${WRKSRC}/specs
 
+.PHONY: remove-subpackage-modules remove-dumped-modules fix-versioned-filenames prepare-docs-dir install-modrefs install-shared-docs print-vars
+
 post-install: remove-dumped-modules remove-subpackage-modules fix-versioned-filenames prepare-docs-dir install-shared-docs install-modrefs
 
 remove-subpackage-modules:
index d6f3adc8136774c704d9dfcbc4d62912d5634237..0073b0c786d0a163837c994f8e75196fcee76809 100644 (file)
@@ -91,6 +91,8 @@ do-install:
 
 post-install: remove-dumped-modules remove-main-package-files prepare-docs-dir install-shared-docs install-modrefs
 
+.PHONY: remove-main-package-files remove-dumped-modules prepare-docs-dir install-modrefs install-shared-docs
+
 # remove files that overlap with files in the main pike package, located under PREFIX
 remove-main-package-files:
        cd ${DESTDIR}/${PREFIX} && \