+py-lsp-jsonrpc in wip
authorK.I.A.Derouiche <kamelderouiche@yahoo.com>
Fri, 4 Nov 2022 16:09:27 +0000 (16:09 +0000)
committerK.I.A.Derouiche <kamelderouiche@yahoo.com>
Fri, 4 Nov 2022 16:09:27 +0000 (16:09 +0000)
Makefile
py-lsp-jsonrpc/DESCR [new file with mode: 0644]
py-lsp-jsonrpc/Makefile [new file with mode: 0644]
py-lsp-jsonrpc/PLIST [new file with mode: 0644]
py-lsp-jsonrpc/distinfo [new file with mode: 0644]

index 6630ec26c6b5d5e62628b4dd03d7ad660ad093aa..630fe421976da97efe650f2668c5e03ccf4f9fca 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -4116,6 +4116,7 @@ SUBDIR+=  py-loky
 SUBDIR+=       py-louie
 SUBDIR+=       py-louvain
 SUBDIR+=       py-lrparsing
+SUBDIR+=       py-lsp-jsonrpc
 SUBDIR+=       py-lsqfit
 SUBDIR+=       py-luminous
 SUBDIR+=       py-lxmlproc
diff --git a/py-lsp-jsonrpc/DESCR b/py-lsp-jsonrpc/DESCR
new file mode 100644 (file)
index 0000000..54d0281
--- /dev/null
@@ -0,0 +1,2 @@
+A Python 3.6+ server implementation of the JSON RPC 2.0 protocol.
+This library has been pulled out of the Python LSP Server project.
diff --git a/py-lsp-jsonrpc/Makefile b/py-lsp-jsonrpc/Makefile
new file mode 100644 (file)
index 0000000..5e34c1d
--- /dev/null
@@ -0,0 +1,18 @@
+# $NetBSD$
+
+DISTNAME=      python-lsp-jsonrpc-1.0.0
+PKGNAME=       ${PYPKGPREFIX}-${DISTNAME:S/python-//}
+CATEGORIES=    devel python
+MASTER_SITES=  ${MASTER_SITE_PYPI:=p/python-lsp-jsonrpc/}
+
+MAINTAINER=    kamelderouiche@yahoo.com
+HOMEPAGE=      https://github.com/python-lsp/python-lsp-jsonrpc
+COMMENT=       JSON RPC 2.0 server library
+LICENSE=       mit
+
+DEPENDS+=      ${PYPKGPREFIX}-ujson>=3.0.0:../../textproc/py-ujson
+
+USE_LANGUAGES= # none
+
+.include "../../lang/python/egg.mk"
+.include "../../mk/bsd.pkg.mk"
diff --git a/py-lsp-jsonrpc/PLIST b/py-lsp-jsonrpc/PLIST
new file mode 100644 (file)
index 0000000..885527b
--- /dev/null
@@ -0,0 +1,24 @@
+@comment $NetBSD$
+${PYSITELIB}/pylsp_jsonrpc/__init__.py
+${PYSITELIB}/pylsp_jsonrpc/__init__.pyc
+${PYSITELIB}/pylsp_jsonrpc/__init__.pyo
+${PYSITELIB}/pylsp_jsonrpc/_version.py
+${PYSITELIB}/pylsp_jsonrpc/_version.pyc
+${PYSITELIB}/pylsp_jsonrpc/_version.pyo
+${PYSITELIB}/pylsp_jsonrpc/dispatchers.py
+${PYSITELIB}/pylsp_jsonrpc/dispatchers.pyc
+${PYSITELIB}/pylsp_jsonrpc/dispatchers.pyo
+${PYSITELIB}/pylsp_jsonrpc/endpoint.py
+${PYSITELIB}/pylsp_jsonrpc/endpoint.pyc
+${PYSITELIB}/pylsp_jsonrpc/endpoint.pyo
+${PYSITELIB}/pylsp_jsonrpc/exceptions.py
+${PYSITELIB}/pylsp_jsonrpc/exceptions.pyc
+${PYSITELIB}/pylsp_jsonrpc/exceptions.pyo
+${PYSITELIB}/pylsp_jsonrpc/streams.py
+${PYSITELIB}/pylsp_jsonrpc/streams.pyc
+${PYSITELIB}/pylsp_jsonrpc/streams.pyo
+${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
+${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
+${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
+${PYSITELIB}/${EGG_INFODIR}/requires.txt
+${PYSITELIB}/${EGG_INFODIR}/top_level.txt
diff --git a/py-lsp-jsonrpc/distinfo b/py-lsp-jsonrpc/distinfo
new file mode 100644 (file)
index 0000000..41c3b13
--- /dev/null
@@ -0,0 +1,5 @@
+$NetBSD$
+
+BLAKE2s (python-lsp-jsonrpc-1.0.0.tar.gz) = 28b8d6e7409a0bfc2a81c87508f0c88a7624d5075624c4f14950c6f8fe389342
+SHA512 (python-lsp-jsonrpc-1.0.0.tar.gz) = 447835fc6c3810f486d80f85295089c021b792843bdf88d461c021b8b04407d8f7e6a99c07351a23658a5dff46eb475bc64e51bdec029787cd33330b54d4dfec
+Size (python-lsp-jsonrpc-1.0.0.tar.gz) = 10011 bytes