py-jsonpatch: Add tools, test target, COMMIT_MSG
authorMalte Dehling <mdehling@gmail.com>
Wed, 22 May 2024 18:21:39 +0000 (11:21 -0700)
committerMalte Dehling <mdehling@gmail.com>
Wed, 22 May 2024 21:48:50 +0000 (14:48 -0700)
py-jsonpatch/COMMIT_MSG [new file with mode: 0644]
py-jsonpatch/Makefile

diff --git a/py-jsonpatch/COMMIT_MSG b/py-jsonpatch/COMMIT_MSG
new file mode 100644 (file)
index 0000000..133d596
--- /dev/null
@@ -0,0 +1,3 @@
+devel/py-jsonpatch: Add v1.33
+
+Library to apply JSON Patches according to RFC 6902.
index eae89e80dd0c386cea83bae10c3f650fc351dfe5..a4d96f6497d7445b5072f840ebee2b5d2bb95473 100644 (file)
@@ -11,9 +11,12 @@ COMMENT=     Apply JSON Patches according to RFC 6902
 LICENSE=       modified-bsd
 
 USE_LANGUAGES= # none
+USE_PYTEST=    no
 
 PYTHON_VERSIONS_INCOMPATIBLE=  27
 
+TOOL_DEPENDS+= ${PYPKGPREFIX}-setuptools-[0-9]*:../../devel/py-setuptools
+TOOL_DEPENDS+= ${PYPKGPREFIX}-wheel-[0-9]*:../../devel/py-wheel
 DEPENDS+=      ${PYPKGPREFIX}-jsonpointer>=1.9:../../wip/py-jsonpointer
 
 post-install:
@@ -21,5 +24,8 @@ post-install:
                ${MV} bin/jsondiff bin/jsondiff-${PYVERSSUFFIX} &&      \
                ${MV} bin/jsonpatch bin/jsonpatch-${PYVERSSUFFIX}
 
+do-test:
+       cd ${WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHONBIN} -m unittest
+
 .include "../../lang/python/wheel.mk"
 .include "../../mk/bsd.pkg.mk"