Import py-prettytable 2.0.0 as wip/py-prettytable.
authorFrederic Cambus <fred@statdns.com>
Sat, 27 Feb 2021 11:34:17 +0000 (12:34 +0100)
committerFrederic Cambus <fred@statdns.com>
Sat, 27 Feb 2021 11:35:58 +0000 (12:35 +0100)
PrettyTable is a simple Python library designed to make it quick and easy
to represent tabular data in visually appealing ASCII tables.

PrettyTable lets you control many aspects of the table, like the width of
the column padding, the alignment of text within columns, which characters
are used to draw the table border, whether you even want a border, and much
more. You can control which subsets of the columns and rows are printed, and
you can sort the rows by the value of a particular column.

Makefile
py-prettytable/DESCR [new file with mode: 0644]
py-prettytable/Makefile [new file with mode: 0644]
py-prettytable/PLIST [new file with mode: 0644]
py-prettytable/distinfo [new file with mode: 0644]

index 298fff21dcb494bc0aee187ed36ac104146dd52a..b8e539c10139244b57d613435f0497b29e1b97d0 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -4190,6 +4190,7 @@ SUBDIR+=  py-ppscore
 SUBDIR+=       py-prayertime
 SUBDIR+=       py-prel
 SUBDIR+=       py-premailer
+SUBDIR+=       py-prettytable
 SUBDIR+=       py-print
 SUBDIR+=       py-prioritized-methods
 SUBDIR+=       py-priority
diff --git a/py-prettytable/DESCR b/py-prettytable/DESCR
new file mode 100644 (file)
index 0000000..447c8a8
--- /dev/null
@@ -0,0 +1,8 @@
+PrettyTable is a simple Python library designed to make it quick and easy
+to represent tabular data in visually appealing ASCII tables.
+
+PrettyTable lets you control many aspects of the table, like the width of
+the column padding, the alignment of text within columns, which characters
+are used to draw the table border, whether you even want a border, and much
+more. You can control which subsets of the columns and rows are printed, and
+you can sort the rows by the value of a particular column.
diff --git a/py-prettytable/Makefile b/py-prettytable/Makefile
new file mode 100644 (file)
index 0000000..24d855c
--- /dev/null
@@ -0,0 +1,18 @@
+# $NetBSD$
+
+DISTNAME=      prettytable-2.0.0
+PKGNAME=       ${PYPKGPREFIX}-${DISTNAME}
+CATEGORIES=    textproc python
+MASTER_SITES=  ${MASTER_SITE_PYPI:=p/prettytable/}
+
+MAINTAINER=    fcambus@NetBSD.org
+HOMEPAGE=      https://pypi.org/project/prettytable/
+COMMENT=       Display tabular data in a visually appealing ASCII table format
+LICENSE=       modified-bsd
+
+USE_LANGUAGES= # none
+
+DEPENDS+=      ${PYPKGPREFIX}-wcwidth-[0-9]*:../../devel/py-wcwidth
+
+.include "../../lang/python/egg.mk"
+.include "../../mk/bsd.pkg.mk"
diff --git a/py-prettytable/PLIST b/py-prettytable/PLIST
new file mode 100644 (file)
index 0000000..4ec6aa0
--- /dev/null
@@ -0,0 +1,12 @@
+@comment $NetBSD$
+${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
+${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
+${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
+${PYSITELIB}/${EGG_INFODIR}/requires.txt
+${PYSITELIB}/${EGG_INFODIR}/top_level.txt
+${PYSITELIB}/prettytable/__init__.py
+${PYSITELIB}/prettytable/__init__.pyc
+${PYSITELIB}/prettytable/__init__.pyo
+${PYSITELIB}/prettytable/prettytable.py
+${PYSITELIB}/prettytable/prettytable.pyc
+${PYSITELIB}/prettytable/prettytable.pyo
diff --git a/py-prettytable/distinfo b/py-prettytable/distinfo
new file mode 100644 (file)
index 0000000..7daca41
--- /dev/null
@@ -0,0 +1,6 @@
+$NetBSD$
+
+SHA1 (prettytable-2.0.0.tar.gz) = 3bb4dd7478e9cfe23e498082a09033ffc4fbcc0b
+RMD160 (prettytable-2.0.0.tar.gz) = 57c2ab6c0eeb64c4909ab8f0607839c5ce5256fe
+SHA512 (prettytable-2.0.0.tar.gz) = b7c47df7d85a91e9518dea8dafcb27037e5cde81f59dd2b9e9468ae44b18431dd7d943fed487d5713e2c5aa25df76a8eb6587d045f73b8f25f53715a8a2085fc
+Size (prettytable-2.0.0.tar.gz) = 43072 bytes