ruby-gh: Adjust depends pattern and add OVERRIDE_GEMSPEC
authorLeonardo Taccari <leot@NetBSD.org>
Mon, 8 Jul 2019 16:29:50 +0000 (18:29 +0200)
committerLeonardo Taccari <leot@NetBSD.org>
Mon, 8 Jul 2019 16:31:21 +0000 (18:31 +0200)
Some dependency patterns are too strict, try to workaround them with
more liberal patterns via OVERRIDE_GEMSPECS.

ruby-gh/Makefile

index 15ad945f711cffd56b86a90b6289d7405654abe0..09062aa42e8115014e34071f1956a338daa743d1 100644 (file)
@@ -11,10 +11,15 @@ LICENSE=    mit
 DEPENDS+=      ${RUBY_PKGPREFIX}-addressable-[0-9]*:../../net/ruby-addressable
 DEPENDS+=      ${RUBY_PKGPREFIX}-backports-[0-9]*:../../devel/ruby-backports
 DEPENDS+=      ${RUBY_PKGPREFIX}-faraday>=0.8:../../www/ruby-faraday
-DEPENDS+=      ${RUBY_PKGPREFIX}-multi_json-[0-9]*:../../textproc/ruby-multi_json
+DEPENDS+=      ${RUBY_PKGPREFIX}-multi_json>=1.0:../../textproc/ruby-multi_json
 DEPENDS+=      ${RUBY_PKGPREFIX}-net-http-persistent>=2.9:../../www/ruby-net-http-persistent
 DEPENDS+=      ${RUBY_PKGPREFIX}-net-http-pipeline-[0-9]*:../../wip/ruby-net-http-pipeline
 
+OVERRIDE_GEMSPEC+=     addressable>=2.4.0
+OVERRIDE_GEMSPEC+=     faraday>=0.8
+OVERRIDE_GEMSPEC+=     multi_json>=1.0
+OVERRIDE_GEMSPEC+=     net-http-persistent>=2.9
+
 #RUBYGEM_OPTIONS+=     --format-executable
 
 .include "../../lang/ruby/gem.mk"