wip/fgallery: fix scrolling on large overviews
authorast <ast@NetBSD.org>
Sun, 30 Oct 2016 09:28:38 +0000 (10:28 +0100)
committerast <ast@NetBSD.org>
Sun, 30 Oct 2016 17:17:52 +0000 (18:17 +0100)
fgallery/distinfo
fgallery/files/overview.css
fgallery/patches/patch-view_index.css

index 5b757792f27e340a0005ceec2366182ae199018c..4c91191af1534e599a7da22d2b39ba29f29cfe69 100644 (file)
@@ -5,6 +5,6 @@ RMD160 (fgallery-1.8.2.zip) = 959854b675a813379e78d8e66022dd2f56e30561
 SHA512 (fgallery-1.8.2.zip) = 1e782b86c74b7cafbb61e46f346b2e42dab9cc3133cf8cedef827f916b5eb29316d86a52020305b56a42fa9d6555423b9d5a175dac4446a0f7f5d538beb9311f
 Size (fgallery-1.8.2.zip) = 158562 bytes
 SHA1 (patch-fgallery) = 58d3b0eacff0c61f3236ff16bc56084719abf1b8
-SHA1 (patch-view_index.css) = e30afdc2f5706b2a44efc325b1777dd3571aa1de
+SHA1 (patch-view_index.css) = 562587d10dc72d8a22a9577cba9cc63fa9473c86
 SHA1 (patch-view_index.html) = 1e62672675b873d547eb11a1f48bf4af582869c6
 SHA1 (patch-view_index.js) = fb0a55b13d2e9db1170d576dfb28753da7608b5e
index 77d55e4c616c30695e813cac0d660310f0a231b8..c4eff14460fa8d2eb265c89cf09cc475fc4b22e3 100644 (file)
@@ -1,4 +1,4 @@
-/* General reset */
+/* General reset of index.css */
 html, body
 {
   overflow: hidden; /* IE<9 */
@@ -10,6 +10,7 @@ html, body
 
 body
 {
+  overflow: scroll;
   background-color: #eee;
 }
 
@@ -51,4 +52,3 @@ body
 .overview-img-div:hover img {
   opacity: 0.7;
 }
-
index d6bb711c9b8b5db31f41ee96c7c268a4b8f77191..1dc23add46189762a4611ec9cc7dd8ed7a827bb2 100644 (file)
@@ -5,7 +5,11 @@ Make the (optional) download/date text slightly less conspicuous
 
 --- view/index.css.orig        2016-01-11 19:17:15.000000000 +0000
 +++ view/index.css
-@@ -5,6 +5,7 @@ html, body
+@@ -1,10 +1,10 @@
+-/* General reset */
+ html, body
+ {
+   overflow: hidden; /* IE<9 */
    padding: 0;
    margin: 0;
    border: 0;
@@ -13,7 +17,7 @@ Make the (optional) download/date text slightly less conspicuous
  }
  
  img
-@@ -110,6 +111,7 @@ img
+@@ -110,6 +110,7 @@ img
    background: #111; /* IE<9 */
    background: rgba(0, 0, 0, 0.7);
    font-family: sans-serif;