libreswan: shuffle directories
authorAndrew Cagney <andrew.cagney@gmail.com>
Wed, 17 Apr 2024 15:26:38 +0000 (15:26 +0000)
committerAndrew Cagney <andrew.cagney@gmail.com>
Wed, 17 Apr 2024 15:26:38 +0000 (15:26 +0000)
Result is libreswan-4, libreswan-5, libreswan-git

12 files changed:
libreswan-4/COMMIT_MSG [moved from libreswan/COMMIT_MSG with 100% similarity]
libreswan-4/DESCR [moved from libreswan/DESCR with 100% similarity]
libreswan-4/Makefile [moved from libreswan/Makefile with 100% similarity]
libreswan-4/PLIST [moved from libreswan/PLIST with 100% similarity]
libreswan-4/TODO [moved from libreswan/TODO with 100% similarity]
libreswan-4/distinfo [moved from libreswan/distinfo with 100% similarity]
libreswan-5/COMMIT_MSG [new file with mode: 0644]
libreswan-5/DESCR [new file with mode: 0644]
libreswan-5/Makefile [new file with mode: 0644]
libreswan-5/PLIST [new file with mode: 0644]
libreswan-5/TODO [new file with mode: 0644]
libreswan-5/distinfo [new file with mode: 0644]

similarity index 100%
rename from libreswan/COMMIT_MSG
rename to libreswan-4/COMMIT_MSG
similarity index 100%
rename from libreswan/DESCR
rename to libreswan-4/DESCR
similarity index 100%
rename from libreswan/Makefile
rename to libreswan-4/Makefile
similarity index 100%
rename from libreswan/PLIST
rename to libreswan-4/PLIST
similarity index 100%
rename from libreswan/TODO
rename to libreswan-4/TODO
similarity index 100%
rename from libreswan/distinfo
rename to libreswan-4/distinfo
diff --git a/libreswan-5/COMMIT_MSG b/libreswan-5/COMMIT_MSG
new file mode 100644 (file)
index 0000000..47fe032
--- /dev/null
@@ -0,0 +1,14 @@
+Libreswan: import version 5.0pre0.20230808
+
+Libreswan is an Internet Key Exchange (IKE) daemon for managing IPsec.
+
+Libreswan supports IKEv1 and IKEv2 and has support for most of the
+extensions (RFC + IETF drafts) related to IPsec, including IKEv2,
+X.509 Digital Certificates, NAT Traversal, and many others.
+
+On NetBSD and FreeBSD, Libreswan uses the PF_KEY_V2 IPsec stack.  On
+Linux, Libreswan uses the XFRM IPsec stack.
+
+Libreswan was forked from Openswan 2.6.38, which was forked from
+FreeS/WAN 2.04. See the CREDITS files for contributor acknowledgments.
+
diff --git a/libreswan-5/DESCR b/libreswan-5/DESCR
new file mode 100644 (file)
index 0000000..461ef66
--- /dev/null
@@ -0,0 +1,11 @@
+Libreswan is an Internet Key Exchange (IKE) daemon for managing IPsec.
+
+Libreswan supports IKEv1 and IKEv2 and has support for most of the
+extensions (RFC + IETF drafts) related to IPsec, including IKEv2,
+X.509 Digital Certificates, NAT Traversal, and many others.
+
+On NetBSD and FreeBSD, Libreswan uses the PF_KEY_V2 IPsec stack.  On
+Linux, Libreswan uses the XFRM IPsec stack.
+
+Libreswan was forked from Openswan 2.6.38, which was forked from
+FreeS/WAN 2.04. See the CREDITS files for contributor acknowledgments.
diff --git a/libreswan-5/Makefile b/libreswan-5/Makefile
new file mode 100644 (file)
index 0000000..079cbb2
--- /dev/null
@@ -0,0 +1,87 @@
+# $NetBSD$
+
+# Libreswan is built using GNU Make.  It does not use autoconf.
+#
+# Configuration parameters can be found in mk/config.mk and OS
+# specific overides in mk/default/*.mk (for instance,
+# mk/default/netbsd.mk).
+
+# See:
+#    pkg_admin pmatch 'foo>=5.0rc1' foo-5.0pre0.20230807
+# the suggestion is:
+#
+# libreswan-git: 5.0pre0.YYYYMMDD 5.0rc1 5.0rc1.YYYYMMDD 5.0
+# 5.1pre.YYYYMMDD ...
+#
+# libreswan: 5.0 5.0nb1 ...
+
+
+#DISTNAME=      libreswan-5.0pre0.20231114
+DISTNAME=      libreswan-5.0rc2
+GITHUB_PROJECT=        libreswan
+GITHUB_TAG=    v5.0rc2
+MASTER_SITES=  ${MASTER_SITE_GITHUB:=${GITHUB_PROJECT}/}
+DIST_SUBDIR=   ${GITHUB_PROJECT}
+
+CATEGORIES=    security
+MAINTAINER=    pkgsrc-users@NetBSD.org
+HOMEPAGE=      https://libreswan.org/
+# Libreswan is an ...
+COMMENT=       Internet Key Exchange Daemon for managing IPsec
+LICENSE=       gnu-gpl-v2
+
+USE_TOOLS+=    pkg-config
+USE_TOOLS+=    gmake
+USE_TOOLS+=    flex
+USE_TOOLS+=    bison
+#default is: USE_LANGUAGES+=   c
+
+EGDIR=         ${PREFIX}/share/examples/libreswan
+
+# Config files: stop libreswan 4.10+ scribbling into /etc
+MAKE_FLAGS+=   INSTALL_CONFIGS=false
+
+# Init scripts aka rc.d: stop libreswan 4.10+ scribbing into /etc
+MAKE_FLAGS+=   INSTALL_INITSYSTEM=false
+FILESDIR=      ${DESTDIR}${EGDIR}/rc.d
+post-install:
+       mv $(FILESDIR)/pluto $(FILESDIR)/pluto.sh
+#RCD_SCRIPTS=  pluto
+#CONF_FILES+=  ${EGDIR}/rc.d/ipsec ${PKG_SYSCONFDIR}/rc.d/ipsec
+
+# populate /etc
+PERMS=$(REAL_ROOT_USER) $(REAL_ROOT_GROUP) 0700
+MAKE_DIRS_PERMS+=      ${PKG_SYSCONFDIR}/ipsec.d $(PERMS)
+MAKE_DIRS_PERMS+=      ${PKG_SYSCONFDIR}/ipsec.d/policies $(PERMS)
+CONF_FILES_PERMS+=     ${EGDIR}/ipsec.secrets-sample ${PKG_SYSCONFDIR}/ipsec.secrets $(PERMS)
+CONF_FILES_PERMS+=     ${EGDIR}/ipsec.conf-sample ${PKG_SYSCONFDIR}/ipsec.conf $(PERMS)
+CONF_FILES+=           ${EGDIR}/ipsec.d/policies/portexcludes.conf ${PKG_SYSCONFDIR}/ipsec.d/policies/portexcludes.conf
+# needs a for loop
+CONF_FILES+=           ${EGDIR}/ipsec.d/policies/block ${PKG_SYSCONFDIR}/ipsec.d/policies/block
+CONF_FILES+=           ${EGDIR}/ipsec.d/policies/clear ${PKG_SYSCONFDIR}/ipsec.d/policies/clear
+CONF_FILES+=           ${EGDIR}/ipsec.d/policies/clear-or-private ${PKG_SYSCONFDIR}/ipsec.d/policies/clear-or-private
+CONF_FILES+=           ${EGDIR}/ipsec.d/policies/private ${PKG_SYSCONFDIR}/ipsec.d/policies/private
+CONF_FILES+=           ${EGDIR}/ipsec.d/policies/private-or-clear ${PKG_SYSCONFDIR}/ipsec.d/policies/private-or-clear
+
+# Always install pam.d!?
+MAKE_DIRS+=    ${PKG_SYSCONFDIR}/pam.d
+CONF_FILES+=   ${EGDIR}/pam.d/pluto ${PKG_SYSCONFDIR}/pam.d/pluto
+
+# Alway install logrotate!?!
+MAKE_DIRS+=    ${PKG_SYSCONFDIR}/logrotate.d
+CONF_FILES+=   ${EGDIR}/logrotate.d/libreswan ${PKG_SYSCONFDIR}/logrotate.d/libreswan
+
+CHECK_PORTABILITY_SKIP=        mk/docker-targets.mk
+
+# code not clean enough; XXX: why?
+#BUILDLINK_TRANSFORM+= rm:-Werror
+
+# some stuff uses .include, some does not
+DEPENDS+=      xmlto-[0-9]*:../../textproc/xmlto
+
+# libevent?
+.include "../../net/unbound/buildlink3.mk"
+.include "../../www/curl/buildlink3.mk"
+.include "../../devel/nss/buildlink3.mk"
+.include "../../net/ldns/buildlink3.mk"
+.include "../../mk/bsd.pkg.mk"
diff --git a/libreswan-5/PLIST b/libreswan-5/PLIST
new file mode 100644 (file)
index 0000000..b6fb9e8
--- /dev/null
@@ -0,0 +1,103 @@
+@comment $NetBSD$
+libexec/ipsec/_asn1check
+libexec/ipsec/_dncheck
+libexec/ipsec/_enumcheck
+libexec/ipsec/_hunkcheck
+libexec/ipsec/_import_crl
+libexec/ipsec/_ipcheck
+libexec/ipsec/_jambufcheck
+libexec/ipsec/_keyidcheck
+libexec/ipsec/_plutorun
+libexec/ipsec/_timecheck
+libexec/ipsec/_ttodatacheck
+libexec/ipsec/_unbound-hook
+libexec/ipsec/_updown
+libexec/ipsec/_updown.bsd
+libexec/ipsec/_vendoridcheck
+libexec/ipsec/addconn
+libexec/ipsec/algparse
+libexec/ipsec/cavp
+libexec/ipsec/ecdsasigkey
+libexec/ipsec/letsencrypt
+libexec/ipsec/newhostkey
+libexec/ipsec/pluto
+libexec/ipsec/readwriteconf
+libexec/ipsec/rsasigkey
+libexec/ipsec/setup
+libexec/ipsec/showhostkey
+libexec/ipsec/showroute
+libexec/ipsec/whack
+man/man5/ipsec.conf.5
+man/man5/ipsec.secrets.5
+man/man7/libreswan.7
+man/man8/ipsec-_plutorun.8
+man/man8/ipsec-_updown.8
+man/man8/ipsec-_updown.bsd.8
+man/man8/ipsec-add.8
+man/man8/ipsec-addconn.8
+man/man8/ipsec-algparse.8
+man/man8/ipsec-briefconnectionstatus.8
+man/man8/ipsec-briefstatus.8
+man/man8/ipsec-certutil.8
+man/man8/ipsec-checkconfig.8
+man/man8/ipsec-checknflog.8
+man/man8/ipsec-checknss.8
+man/man8/ipsec-connectionstatus.8
+man/man8/ipsec-crlutil.8
+man/man8/ipsec-delete.8
+man/man8/ipsec-down.8
+man/man8/ipsec-ecdsasigkey.8
+man/man8/ipsec-fetchcrls.8
+man/man8/ipsec-fipsstatus.8
+man/man8/ipsec-globalstatus.8
+man/man8/ipsec-import.8
+man/man8/ipsec-initnss.8
+man/man8/ipsec-letsencrypt.8
+man/man8/ipsec-listall.8
+man/man8/ipsec-listcacerts.8
+man/man8/ipsec-listcerts.8
+man/man8/ipsec-listcrls.8
+man/man8/ipsec-listen.8
+man/man8/ipsec-listpubkeys.8
+man/man8/ipsec-modutil.8
+man/man8/ipsec-newhostkey.8
+man/man8/ipsec-ondemand.8
+man/man8/ipsec-pk12util.8
+man/man8/ipsec-pluto.8
+man/man8/ipsec-purgeocsp.8
+man/man8/ipsec-readwriteconf.8
+man/man8/ipsec-redirect.8
+man/man8/ipsec-replace.8
+man/man8/ipsec-rereadall.8
+man/man8/ipsec-rereadcerts.8
+man/man8/ipsec-rereadsecrets.8
+man/man8/ipsec-restart.8
+man/man8/ipsec-route.8
+man/man8/ipsec-rsasigkey.8
+man/man8/ipsec-setup.8
+man/man8/ipsec-showhostkey.8
+man/man8/ipsec-showroute.8
+man/man8/ipsec-showstates.8
+man/man8/ipsec-shuntstatus.8
+man/man8/ipsec-start.8
+man/man8/ipsec-status.8
+man/man8/ipsec-stop.8
+man/man8/ipsec-trafficstatus.8
+man/man8/ipsec-unroute.8
+man/man8/ipsec-up.8
+man/man8/ipsec-vfychain.8
+man/man8/ipsec-whack.8
+man/man8/ipsec.8
+man/man8/pluto.8
+sbin/ipsec
+share/examples/libreswan/ipsec.conf-sample
+share/examples/libreswan/ipsec.d/policies/block
+share/examples/libreswan/ipsec.d/policies/clear
+share/examples/libreswan/ipsec.d/policies/clear-or-private
+share/examples/libreswan/ipsec.d/policies/portexcludes.conf
+share/examples/libreswan/ipsec.d/policies/private
+share/examples/libreswan/ipsec.d/policies/private-or-clear
+share/examples/libreswan/ipsec.secrets-sample
+share/examples/libreswan/logrotate.d/libreswan
+share/examples/libreswan/pam.d/pluto
+share/examples/libreswan/rc.d/pluto.sh
diff --git a/libreswan-5/TODO b/libreswan-5/TODO
new file mode 100644 (file)
index 0000000..8b8d76a
--- /dev/null
@@ -0,0 +1,12 @@
+- platforms other than NetBSD (Linux, and FreeBSD)?
+
+  PFKEYV2 and XFRM are pretty esoteric.
+
+- /etc/ipsec*
+
+  ipsec.conf, ipsec.secrets and ipsec.d/*
+
+- logrotate https://github.com/libreswan/libreswan/issues/767
+
+  It's a weak dependency / suggested package.  If libreswan is
+  using syslog, say, it isn't needed.
diff --git a/libreswan-5/distinfo b/libreswan-5/distinfo
new file mode 100644 (file)
index 0000000..cbcbbaa
--- /dev/null
@@ -0,0 +1,5 @@
+$NetBSD$
+
+BLAKE2s (libreswan/libreswan-5.0rc2.tar.gz) = e969849745eff82c463d10875e723ae891e6b4a5f2c2da84640783e1e5a83486
+SHA512 (libreswan/libreswan-5.0rc2.tar.gz) = a7f47b820d6aacf46eb3ab80f3436af3580b07e3cce23624329b9c3771bd4a0f75a7cc9c1b25b438a024c2feb1b473595ee6ddbc6773a2d1788639f055e1a15d
+Size (libreswan/libreswan-5.0rc2.tar.gz) = 3951446 bytes