wip/py-texext: import py37-texext-0.6.6
authorK.I.A.Derouiche <kamel.derouiche@gmail.com>
Mon, 14 Sep 2020 00:52:31 +0000 (01:52 +0100)
committerK.I.A.Derouiche <kamel.derouiche@gmail.com>
Mon, 14 Sep 2020 00:52:31 +0000 (01:52 +0100)
Sphinx extensions for working with LaTeX math

py-texext/DESCR [new file with mode: 0644]
py-texext/Makefile [new file with mode: 0644]
py-texext/PLIST [new file with mode: 0644]
py-texext/distinfo [new file with mode: 0644]

diff --git a/py-texext/DESCR b/py-texext/DESCR
new file mode 100644 (file)
index 0000000..374cf82
--- /dev/null
@@ -0,0 +1 @@
+Sphinx extensions for working with LaTeX math
diff --git a/py-texext/Makefile b/py-texext/Makefile
new file mode 100644 (file)
index 0000000..04d92c6
--- /dev/null
@@ -0,0 +1,18 @@
+# $NetBSD$
+
+DISTNAME=      texext-0.6.6
+PKGNAME=       ${PYPKGPREFIX}-${DISTNAME}
+CATEGORIES=    textproc math
+MASTER_SITES=  https://files.pythonhosted.org/packages/11/76/ea529fb6409fd4dde7054e77e40d681900a486d8b3d83ea3a35878885975/
+
+MAINTAINER=    kamelderouiche@yahoo.com
+HOMEPAGE=      https://github.com/matthew-brett/texext
+COMMENT=       Sphinx extensions for working with LaTeX math
+LICENSE=       modified-bsd
+
+DEPENDS+=      ${PYPKGPREFIX}-six>=1.4.0:../../lang/py-six
+DEPENDS+=      ${PYPKGPREFIX}-docutils>=0.16:../../textproc/py-docutils
+DEPENDS+=      ${PYPKGPREFIX}-sphinx>=2.4.4:../../textproc/py-sphinx
+
+.include "../../lang/python/egg.mk"
+.include "../../mk/bsd.pkg.mk"
diff --git a/py-texext/PLIST b/py-texext/PLIST
new file mode 100644 (file)
index 0000000..2571702
--- /dev/null
@@ -0,0 +1,57 @@
+@comment $NetBSD$
+${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
+${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
+${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
+${PYSITELIB}/${EGG_INFODIR}/requires.txt
+${PYSITELIB}/${EGG_INFODIR}/top_level.txt
+${PYSITELIB}/texext/__init__.py
+${PYSITELIB}/texext/__init__.pyc
+${PYSITELIB}/texext/__init__.pyo
+${PYSITELIB}/texext/_version.py
+${PYSITELIB}/texext/_version.pyc
+${PYSITELIB}/texext/_version.pyo
+${PYSITELIB}/texext/math_dollar.py
+${PYSITELIB}/texext/math_dollar.pyc
+${PYSITELIB}/texext/math_dollar.pyo
+${PYSITELIB}/texext/mathcode.py
+${PYSITELIB}/texext/mathcode.pyc
+${PYSITELIB}/texext/mathcode.pyo
+${PYSITELIB}/texext/tests/__init__.py
+${PYSITELIB}/texext/tests/__init__.pyc
+${PYSITELIB}/texext/tests/__init__.pyo
+${PYSITELIB}/texext/tests/conftest.py
+${PYSITELIB}/texext/tests/conftest.pyc
+${PYSITELIB}/texext/tests/conftest.pyo
+${PYSITELIB}/texext/tests/for_docstrings.py
+${PYSITELIB}/texext/tests/for_docstrings.pyc
+${PYSITELIB}/texext/tests/for_docstrings.pyo
+${PYSITELIB}/texext/tests/plotdirective/_static/README.txt
+${PYSITELIB}/texext/tests/plotdirective/conf.py
+${PYSITELIB}/texext/tests/plotdirective/conf.pyc
+${PYSITELIB}/texext/tests/plotdirective/conf.pyo
+${PYSITELIB}/texext/tests/plotdirective/index.rst
+${PYSITELIB}/texext/tests/plotdirective/plot_and_math.rst
+${PYSITELIB}/texext/tests/test_custom_plotcontext.py
+${PYSITELIB}/texext/tests/test_custom_plotcontext.pyc
+${PYSITELIB}/texext/tests/test_custom_plotcontext.pyo
+${PYSITELIB}/texext/tests/test_custom_plotdirective.py
+${PYSITELIB}/texext/tests/test_custom_plotdirective.pyc
+${PYSITELIB}/texext/tests/test_custom_plotdirective.pyo
+${PYSITELIB}/texext/tests/test_docstrings.py
+${PYSITELIB}/texext/tests/test_docstrings.pyc
+${PYSITELIB}/texext/tests/test_docstrings.pyo
+${PYSITELIB}/texext/tests/test_mathdollar.py
+${PYSITELIB}/texext/tests/test_mathdollar.pyc
+${PYSITELIB}/texext/tests/test_mathdollar.pyo
+${PYSITELIB}/texext/tests/test_plotdirective.py
+${PYSITELIB}/texext/tests/test_plotdirective.pyc
+${PYSITELIB}/texext/tests/test_plotdirective.pyo
+${PYSITELIB}/texext/tests/test_tinypages.py
+${PYSITELIB}/texext/tests/test_tinypages.pyc
+${PYSITELIB}/texext/tests/test_tinypages.pyo
+${PYSITELIB}/texext/tests/tinypages/_static/README.txt
+${PYSITELIB}/texext/tests/tinypages/conf.py
+${PYSITELIB}/texext/tests/tinypages/conf.pyc
+${PYSITELIB}/texext/tests/tinypages/conf.pyo
+${PYSITELIB}/texext/tests/tinypages/index.rst
+${PYSITELIB}/texext/tests/tinypages/some_math.rst
diff --git a/py-texext/distinfo b/py-texext/distinfo
new file mode 100644 (file)
index 0000000..54b1910
--- /dev/null
@@ -0,0 +1,6 @@
+$NetBSD$
+
+SHA1 (texext-0.6.6.tar.gz) = 00fac6fa6050b4efbc7093e855d5f2b199ade689
+RMD160 (texext-0.6.6.tar.gz) = ab4de8be26172653fe1e6eaf87d92c97f508de61
+SHA512 (texext-0.6.6.tar.gz) = 117a74c85fc36af8921a145e387b560e3c6c115090f777539178021cafac0075077fc81c62d18fa2bbee0b0f59e256274a9526f2a688d00a99ecbda2ac944ccd
+Size (texext-0.6.6.tar.gz) = 38121 bytes