denise: a working way to get it to link and it even runs.
authorOlaf Seibert <rhialto@falu.nl>
Sun, 25 Oct 2020 21:37:45 +0000 (22:37 +0100)
committerOlaf Seibert <rhialto@falu.nl>
Mon, 26 Oct 2020 19:14:59 +0000 (20:14 +0100)
denise/Makefile
denise/distinfo
denise/patches/patch-driver_Makefile
denise/patches/patch-driver_video_opengl_opengl.h [deleted file]

index 927d83dc5953b5ad4420b98a7c270308ee2cdf4c..304426afc6fe2ca02b441bd058c3037187f48a87 100644 (file)
@@ -9,7 +9,7 @@ EXTRACT_SUFX=   .tar.bz2
 MAINTAINER=    rhialto@NetBSD.org
 HOMEPAGE=      https://bitbucket.org/piciji/denise/
 COMMENT=       Commodore-64 emulator
-#LICENSE=      # TODO: (see mk/license.mk)
+LICENSE=       gnu-gpl-v3
 
 WRKSRC=                ${WRKDIR}/piciji-denise-b0f2c4bf4115
 USE_LANGUAGES= c c++   #c++17
@@ -17,7 +17,6 @@ USE_TOOLS+=   gmake
 
 .include "../../x11/gtk3/buildlink3.mk"
 .include "../../graphics/MesaLib/buildlink3.mk"
-.include "../../graphics/glew/buildlink3.mk"   # needed? glUseProgram, glDeleteSync, glGetUniformLocation, glClientWaitSync, glBindFramebuffer, ...
 .include "../../audio/pulseaudio/buildlink3.mk"
 .include "../../audio/openal-soft/buildlink3.mk"
 .include "../../devel/SDL2/buildlink3.mk"
index d2ad49144917937738c13b0e95d0c1614580b3bc..c845fe027f4e5ccd1914c7123fe1f555b41ee972 100644 (file)
@@ -5,5 +5,5 @@ RMD160 (v1.0.9.tar.bz2) = 8f204e0c3aef864ecd1e5ebad08fc26b5014bf41
 SHA512 (v1.0.9.tar.bz2) = e106db70e37a22c0e861e2860e9fe4c08a91759da401e107b0d00bf0c35c4758367925eaa3b330ed021944ce86d4b4903038dcdb419e401b587293519ab71183
 Size (v1.0.9.tar.bz2) = 5941348 bytes
 SHA1 (patch-Makefile) = ffaa85b5cd947b87fa423e1ecb2bb54a9bd8f46a
-SHA1 (patch-driver_Makefile) = fdf126d30eec635fdc01f9adac5ac330404b4b3a
-SHA1 (patch-driver_video_opengl_opengl.h) = f4a18802efc2d05e7f68ed23e3d12c75541256f9
+SHA1 (patch-driver_Makefile) = cfb336839ccbef29e01e4fb3fe045340592ff90c
+SHA1 (patch-driver_video_opengl_bind.h) = c09521cece8c1dd1ddd88dda7d5f50a3ae9d867c
index e89a2c6319021d9078d1dd884f08c6c2db09fbba..216814f97153f22c1e360a052a7ebdd06a9e6966 100644 (file)
@@ -23,11 +23,3 @@ Also, GLEW may be the wrong thing but at least it compiles and links.
      drvlink += $(if $(findstring openal,$(drv)),-lopenal)
      ifneq ($(findstring xlib,$(drv)),)
        drvlink += $(if $(findstring sdl,$(drv)), $(shell $(env)sdl2-config --libs))
-@@ -74,6 +74,6 @@ drvlink += $(if $(findstring iokit,$(drv
- drvlink += $(if $(findstring cgl,$(drv)),-framework OpenGL)
- drvlink += $(if $(findstring coreaudio,$(drv)),-framework CoreAudio -framework AudioToolbox)
--drvlink += $(if $(findstring glx,$(drv)),-lGL)
-+drvlink += $(if $(findstring glx,$(drv)),-lGL -lGLEW)
- drvlink += $(if $(findstring udev,$(drv)),-ludev)
- drvlink += $(if $(findstring pulseaudio,$(drv)),-lpulse)
diff --git a/denise/patches/patch-driver_video_opengl_opengl.h b/denise/patches/patch-driver_video_opengl_opengl.h
deleted file mode 100644 (file)
index 06dc968..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-$NetBSD$
-
-Lots of functions remain undeclared in the original. I'm not sure which
-header should be included. With <GL/glew.h> you also need to link with -lGLEW
-which makes me uncomfortable.
-
---- driver/video/opengl/opengl.h.orig  2020-10-25 12:34:43.000000000 +0000
-+++ driver/video/opengl/opengl.h
-@@ -6,6 +6,7 @@
-     #include <GL/glext.h>
-     #define glGetProcAddress(name) wglGetProcAddress(name)
- #else
-+    #include <GL/glew.h>
-     #include <GL/gl.h>
-     #include <GL/glx.h>
-     #define glGetProcAddress(name) (*glXGetProcAddress)((const GLubyte*)(name))