roswell: Import roswell-21.10.14.111 as wip/roswell
authorgnebbia <16106651+gnebbia@users.noreply.github.com>
Fri, 16 Sep 2022 23:32:57 +0000 (01:32 +0200)
committergnebbia <16106651+gnebbia@users.noreply.github.com>
Fri, 16 Sep 2022 23:32:57 +0000 (01:32 +0200)
Roswell is a Lisp implementation installer/manager, launcher, and
much more!

Roswell started out as a command-line tool with the aim to make
installing and managing Common Lisp implementations really simple
and easy.

Roswell has now evolved into a full-stack environment for Common
Lisp development, and has many features that makes it easy to test,
share, and distribute your Lisp applications.  With Roswell, we
aim to push the Common Lisp community to a whole new level of
productivity.

Makefile
roswell/DESCR [new file with mode: 0644]
roswell/Makefile [new file with mode: 0644]
roswell/PLIST [new file with mode: 0644]
roswell/distinfo [new file with mode: 0644]
roswell/patches/patch-configure [new file with mode: 0644]

index 2c4c550ee466548d4a915afc5871893942db486b..cd11370e426c1ed2a4d4d7eb5bd292aba4605c63 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -5079,6 +5079,7 @@ SUBDIR+=  rom64
 SUBDIR+=       rootcheck
 SUBDIR+=       rootsh
 SUBDIR+=       rosegarden
+SUBDIR+=       roswell
 SUBDIR+=       rott
 SUBDIR+=       rottexpr
 SUBDIR+=       roundcube-plugin-carddav
diff --git a/roswell/DESCR b/roswell/DESCR
new file mode 100644 (file)
index 0000000..3b776e7
--- /dev/null
@@ -0,0 +1,18 @@
+Roswell is a Lisp implementation installer/manager, launcher, and
+much more!
+
+Roswell started out as a command-line tool with the aim to make
+installing and managing Common Lisp implementations really simple
+and easy.
+
+Roswell has now evolved into a full-stack environment for Common
+Lisp development, and has many features that makes it easy to test,
+share, and distribute your Lisp applications.  With Roswell, we
+aim to push the Common Lisp community to a whole new level of
+productivity.
+
+Roswell is still in beta. Despite this, the basic interfaces are
+stable and not likely to change. Roswell currently works well on
+Unix-like platforms such as Linux, Mac OS X and FreeBSD.  Roswell
+also works on other operating systems, but currently some parts or
+features might be missing or unstable.
diff --git a/roswell/Makefile b/roswell/Makefile
new file mode 100644 (file)
index 0000000..b8fe59d
--- /dev/null
@@ -0,0 +1,24 @@
+# $NetBSD$
+
+GITHUB_TAG=    refs/tags/v${PKGVERSION_NOREV}
+DISTNAME=      roswell-21.10.14.111
+CATEGORIES=    lang
+MASTER_SITES=  ${MASTER_SITE_GITHUB:=roswell/}
+WRKSRC=                ${WRKDIR}/${DISTNAME}
+
+MAINTAINER=    nebbionegiuseppe@gmail.com
+HOMEPAGE=      https://github.com/roswell/roswell/
+COMMENT=       Lisp implementation installer/manager, launcher, and much more!
+LICENSE=       mit
+
+
+USE_TOOLS+=    automake
+GNU_CONFIGURE= yes
+
+
+post-extract:
+       cd ${WRKSRC} && sh bootstrap
+
+
+.include "../../www/curl/buildlink3.mk"
+.include "../../mk/bsd.pkg.mk"
diff --git a/roswell/PLIST b/roswell/PLIST
new file mode 100644 (file)
index 0000000..46c3051
--- /dev/null
@@ -0,0 +1,140 @@
+@comment $NetBSD$
+bin/ros
+libexec/roswell/balus.ros
+libexec/roswell/build-asd.lisp
+libexec/roswell/build-ros.lisp
+libexec/roswell/build.ros
+libexec/roswell/checkout.ros
+libexec/roswell/client-swank.lisp
+libexec/roswell/client.ros
+libexec/roswell/compile-file.ros
+libexec/roswell/config.ros
+libexec/roswell/delete-asdf.lisp
+libexec/roswell/delete-default.lisp
+libexec/roswell/delete-dump.lisp
+libexec/roswell/delete-env.lisp
+libexec/roswell/delete-git.lisp
+libexec/roswell/delete.ros
+libexec/roswell/dist-add.lisp
+libexec/roswell/dist-clean.lisp
+libexec/roswell/dist-default.lisp
+libexec/roswell/dist-delete.lisp
+libexec/roswell/dist-disable.lisp
+libexec/roswell/dist-enable.lisp
+libexec/roswell/dist-list.lisp
+libexec/roswell/dist-preference.lisp
+libexec/roswell/dist-use.lisp
+libexec/roswell/dist-versions.lisp
+libexec/roswell/dist.ros
+libexec/roswell/dump-ccl.lisp
+libexec/roswell/dump-clisp.lisp
+libexec/roswell/dump-cmucl.lisp
+libexec/roswell/dump-ecl.lisp
+libexec/roswell/dump-sbcl.lisp
+libexec/roswell/dump.ros
+libexec/roswell/ecl-config.ros
+libexec/roswell/emacs.ros
+libexec/roswell/exec.ros
+libexec/roswell/extend-quicklisp-system.lisp
+libexec/roswell/extend-quicklisp.lisp
+libexec/roswell/fmt.ros
+libexec/roswell/get.ros
+libexec/roswell/git.ros
+libexec/roswell/help-install.lisp
+libexec/roswell/help-options.lisp
+libexec/roswell/help-run.lisp
+libexec/roswell/help.ros
+libexec/roswell/helper.el
+libexec/roswell/hg.ros
+libexec/roswell/init-default.lisp
+libexec/roswell/init-dist.lisp
+libexec/roswell/init-env.lisp
+libexec/roswell/init.lisp
+libexec/roswell/init.ros
+libexec/roswell/install+7zip.lisp
+libexec/roswell/install+externals-clasp.lisp
+libexec/roswell/install+ffcall.lisp
+libexec/roswell/install+msys2.lisp
+libexec/roswell/install+sigsegv.lisp
+libexec/roswell/install-abcl-bin.lisp
+libexec/roswell/install-allegro.lisp
+libexec/roswell/install-asdf.lisp
+libexec/roswell/install-ccl-bin.lisp
+libexec/roswell/install-clasp-bin.lisp
+libexec/roswell/install-clasp.lisp
+libexec/roswell/install-clisp-head.lisp
+libexec/roswell/install-clisp.lisp
+libexec/roswell/install-cmu-bin.lisp
+libexec/roswell/install-ecl.lisp
+libexec/roswell/install-lispworks.lisp
+libexec/roswell/install-mkcl.lisp
+libexec/roswell/install-npt.lisp
+libexec/roswell/install-quicklisp.lisp
+libexec/roswell/install-sbcl-bin.lisp
+libexec/roswell/install-sbcl-head.lisp
+libexec/roswell/install-sbcl-source.lisp
+libexec/roswell/install-sbcl.lisp
+libexec/roswell/install-slime.lisp
+libexec/roswell/install-sly.lisp
+libexec/roswell/install.ros
+libexec/roswell/list-asdf.lisp
+libexec/roswell/list-default.lisp
+libexec/roswell/list-dump.lisp
+libexec/roswell/list-env.lisp
+libexec/roswell/list-git.lisp
+libexec/roswell/list-installed.lisp
+libexec/roswell/list-versions.lisp
+libexec/roswell/list.ros
+libexec/roswell/locations.lisp
+libexec/roswell/make-depends.ros
+libexec/roswell/patch-quicklisp.lisp
+libexec/roswell/patch/sbcl-1.3.11.patch
+libexec/roswell/patch/sbcl-posix-tests.patch
+libexec/roswell/run.ros
+libexec/roswell/serve-default.lisp
+libexec/roswell/serve-swank.lisp
+libexec/roswell/serve.ros
+libexec/roswell/setup.ros
+libexec/roswell/shell.ros
+libexec/roswell/system.lisp
+libexec/roswell/template.ros
+libexec/roswell/update-default.lisp
+libexec/roswell/update-git.lisp
+libexec/roswell/update-hg.lisp
+libexec/roswell/update-quicklisp.lisp
+libexec/roswell/update.ros
+libexec/roswell/use-asdf.lisp
+libexec/roswell/use-env.lisp
+libexec/roswell/use.ros
+libexec/roswell/util-config.lisp
+libexec/roswell/util-dump.lisp
+libexec/roswell/util-install-quicklisp.lisp
+libexec/roswell/util-install.lisp
+libexec/roswell/util-main.lisp
+libexec/roswell/util-swank.lisp
+libexec/roswell/util-template.lisp
+libexec/roswell/util-use.lisp
+libexec/roswell/util.lisp
+libexec/roswell/version.ros
+libexec/roswell/wait.ros
+libexec/roswell/which.ros
+man/man1/ros-asdf.1
+man/man1/ros-build.1
+man/man1/ros-checkout.1
+man/man1/ros-client.1
+man/man1/ros-config.1
+man/man1/ros-delete.1
+man/man1/ros-dump.1
+man/man1/ros-emacs.1
+man/man1/ros-help.1
+man/man1/ros-init.1
+man/man1/ros-install.1
+man/man1/ros-list.1
+man/man1/ros-run.1
+man/man1/ros-serve.1
+man/man1/ros-setup.1
+man/man1/ros-template.1
+man/man1/ros-update.1
+man/man1/ros-use.1
+man/man1/ros-wait.1
+man/man1/ros.1
diff --git a/roswell/distinfo b/roswell/distinfo
new file mode 100644 (file)
index 0000000..7a1672a
--- /dev/null
@@ -0,0 +1,6 @@
+$NetBSD$
+
+BLAKE2s (roswell-21.10.14.111.tar.gz) = 419c7eb4918e6d3b9ddcb964c028c01fe6ce41c650143bee5ecb909b959673bd
+SHA512 (roswell-21.10.14.111.tar.gz) = d6979974807385e1e7be993610b5ed6ef5297ded21727162b6bc3240d402168cfe32b6b243f535c69b91620d0af4a3b7e046080be2881610ffbe0d3babfa3b23
+Size (roswell-21.10.14.111.tar.gz) = 172464 bytes
+SHA1 (patch-configure) = 7d9b0699160516c1f8d71c6dbacc1f0549054d2c
diff --git a/roswell/patches/patch-configure b/roswell/patches/patch-configure
new file mode 100644 (file)
index 0000000..7e8ff8d
--- /dev/null
@@ -0,0 +1,15 @@
+$NetBSD$
+
+Use /libexec as directory for lisp scripts instead of /etc
+
+--- configure.orig     2022-09-14 10:25:05.613740278 +0000
++++ configure
+@@ -818,7 +818,7 @@ sbindir='${exec_prefix}/sbin'
+ libexecdir='${exec_prefix}/libexec'
+ datarootdir='${prefix}/share'
+ datadir='${datarootdir}'
+-sysconfdir='${prefix}/etc'
++sysconfdir='${prefix}/libexec'
+ sharedstatedir='${prefix}/com'
+ localstatedir='${prefix}/var'
+ runstatedir='${localstatedir}/run'