canlock-hp: Import snapshot 3.3.0pre18
authorMichael Baeuerle <micha@NetBSD.org>
Fri, 1 Oct 2021 17:43:00 +0000 (19:43 +0200)
committerMichael Baeuerle <micha@NetBSD.org>
Fri, 1 Oct 2021 17:43:00 +0000 (19:43 +0200)
New library libcanlock-hp.
Header parser API for C programs added.

Makefile
canlock-hp/DESCR [new file with mode: 0644]
canlock-hp/Makefile [new file with mode: 0644]
canlock-hp/PLIST [new file with mode: 0644]
canlock-hp/buildlink3.mk [new file with mode: 0644]
canlock-hp/distinfo [new file with mode: 0644]

index b94a687a15387f8b07e1a61a9678de35fcdac46c..833cd802804bc1eeba055bcb3b1b78936ebdda38 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -375,6 +375,7 @@ SUBDIR+=    calcurse
 SUBDIR+=       calendarsupport
 SUBDIR+=       calibre
 SUBDIR+=       calypso-git
+SUBDIR+=       canlock-hp
 SUBDIR+=       canna
 SUBDIR+=       canna-canuum
 SUBDIR+=       canna-dict
diff --git a/canlock-hp/DESCR b/canlock-hp/DESCR
new file mode 100644 (file)
index 0000000..7039f54
--- /dev/null
@@ -0,0 +1,10 @@
+The canlock-hp package contains standalone header parsers that can be used to
+implement RFC 8315 Netnews Cancel-Locks on the receiving (server) side.
+They are intended as preprocessors for canlock, the command line frontend of
+libcanlock, but are independent programs.
+
+canlock-mhp (Message Header Parser) is intended to process RFC 5536 Netnews
+articles and can be used to extract and unfold a single header field.
+
+canlock-hfp (Header Field Parser) is intended to process RFC 8315 header fields
+("Cancel-Lock" and "Cancel-Key").
diff --git a/canlock-hp/Makefile b/canlock-hp/Makefile
new file mode 100644 (file)
index 0000000..8b5c4cc
--- /dev/null
@@ -0,0 +1,26 @@
+# $NetBSD$
+
+DISTNAME=      libcanlock-3.3.0pre18
+PKGNAME=       ${DISTNAME:S/libcanlock/canlock-hp/}
+CATEGORIES=    news
+MASTER_SITES=  http://micha.freeshell.org/libcanlock/src/
+EXTRACT_SUFX=  .tar.bz2
+
+MAINTAINER=    micha@NetBSD.org
+HOMEPAGE=      http://micha.freeshell.org/canlock-hp/
+COMMENT=       Parsers for RFC 5536 message headers and RFC 8315 header fields
+LICENSE=       mit
+
+USE_TOOLS+=    lex yacc
+USE_LANGUAGES+=        c99
+USE_LIBTOOL=   yes
+
+GNU_CONFIGURE=         yes
+CONFIGURE_ARGS+=       --enable-pc-files
+CONFIGURE_ARGS+=       --with-pkgconfigdir=${PREFIX}/lib/pkgconfig
+
+CONFIGURE_DIRS=        hp
+BUILD_DIRS=    hp
+TEST_TARGET=   test
+
+.include "../../mk/bsd.pkg.mk"
diff --git a/canlock-hp/PLIST b/canlock-hp/PLIST
new file mode 100644 (file)
index 0000000..711a9af
--- /dev/null
@@ -0,0 +1,11 @@
+@comment $NetBSD$
+bin/canlock-hfp
+bin/canlock-mhp
+include/libcanlock-3/canlock-hp.h
+lib/libcanlock-hp.la
+lib/pkgconfig/libcanlock-hp-3.pc
+man/man1/canlock-hfp.1
+man/man1/canlock-mhp.1
+man/man3/cl_hp_get_field.3
+man/man3/cl_hp_parse_field.3
+man/man3/cl_hp_unfold_field.3
diff --git a/canlock-hp/buildlink3.mk b/canlock-hp/buildlink3.mk
new file mode 100644 (file)
index 0000000..0ca53a3
--- /dev/null
@@ -0,0 +1,12 @@
+# $NetBSD$
+
+BUILDLINK_TREE+=       canlock-hp
+
+.if !defined(CANLOCK_HP_BUILDLINK3_MK)
+CANLOCK_HP_BUILDLINK3_MK:=
+
+BUILDLINK_API_DEPENDS.canlock-hp+=     canlock-hp>=3.3.0
+BUILDLINK_PKGSRCDIR.canlock-hp?=       ../../wip/canlock-hp
+.endif # CANLOCK_HP_BUILDLINK3_MK
+
+BUILDLINK_TREE+=       -canlock-hp
diff --git a/canlock-hp/distinfo b/canlock-hp/distinfo
new file mode 100644 (file)
index 0000000..8ca6cfc
--- /dev/null
@@ -0,0 +1,6 @@
+$NetBSD$
+
+SHA1 (libcanlock-3.3.0pre18.tar.bz2) = 76b18ef438531b71513916745158561d8420f04f
+RMD160 (libcanlock-3.3.0pre18.tar.bz2) = a65c2c120812912f85f37d7f331351762bcc5e6f
+SHA512 (libcanlock-3.3.0pre18.tar.bz2) = f9cbf204990957239309163ac868d6df62f1f421d4a0080c06d4372df0f6ed45f7f292fa8ca8789e6fbb422f94f5ab29f374b4a924d2e1132d97ee60aaa5a4a3
+Size (libcanlock-3.3.0pre18.tar.bz2) = 620792 bytes