Import go-config-0.13.0 to wip
authorK.I.A.Derouiche <kamel.derouiche@gmail.com>
Tue, 12 Jan 2021 09:13:15 +0000 (10:13 +0100)
committerK.I.A.Derouiche <kamel.derouiche@gmail.com>
Tue, 12 Jan 2021 09:13:15 +0000 (10:13 +0100)
Makefile
go-config/DESCR [new file with mode: 0644]
go-config/Makefile [new file with mode: 0644]
go-config/PLIST [new file with mode: 0644]
go-config/distinfo [new file with mode: 0644]

index 0713cb7c1f3b4309b35bff736b3f317cd998fda8..e0f16eb4f7d7f41fb8d18afc4b1d79640a7b0454 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1183,6 +1183,7 @@ SUBDIR+=  go-cascadia
 SUBDIR+=       go-copier
 SUBDIR+=       go-circbuf
 SUBDIR+=       go-clir
+SUBDIR+=       go-config
 SUBDIR+=       go-collectd
 SUBDIR+=       go-color
 SUBDIR+=       go-cyclo
diff --git a/go-config/DESCR b/go-config/DESCR
new file mode 100644 (file)
index 0000000..060a9d5
--- /dev/null
@@ -0,0 +1,4 @@
+This package implements a basic configuration
+file parser language whichn provides a structure
+similar to what you would find on Microsoft
+Windows INI files
diff --git a/go-config/Makefile b/go-config/Makefile
new file mode 100644 (file)
index 0000000..5021880
--- /dev/null
@@ -0,0 +1,18 @@
+# $NetBSD$
+
+DISTNAME=      go-config-0.13.0
+GITHUB_PROJECT=        config
+GITHUB_TAG=    v${PKGVERSION_NOREV}
+CATEGORIES=    devel
+MASTER_SITES=  ${MASTER_SITE_GITHUB:=revel/}
+
+MAINTAINER=    kamelderouiche@yahoo.com
+HOMEPAGE=      https://github.com/revel/config/
+COMMENT=       Configuration file parser for INI format
+LICENSE=       apache-2.0
+
+GO_DIST_BASE=  ${GITHUB_PROJECT}-${PKGVERSION_NOREV}
+GO_SRCPATH=    github.com/revel/${GITHUB_PROJECT}
+
+.include "../../lang/go/go-package.mk"
+.include "../../mk/bsd.pkg.mk"
diff --git a/go-config/PLIST b/go-config/PLIST
new file mode 100644 (file)
index 0000000..be96242
--- /dev/null
@@ -0,0 +1,21 @@
+@comment $NetBSD$
+gopkg/pkg/${GO_PLATFORM}/github.com/revel/config.a
+gopkg/src/github.com/revel/config/Doc/AUTHORS.md
+gopkg/src/github.com/revel/config/Doc/CONTRIBUTORS.md
+gopkg/src/github.com/revel/config/Doc/LICENSE_Apache.txt
+gopkg/src/github.com/revel/config/Doc/NEWS.md
+gopkg/src/github.com/revel/config/README.md
+gopkg/src/github.com/revel/config/all_test.go
+gopkg/src/github.com/revel/config/config.go
+gopkg/src/github.com/revel/config/context.go
+gopkg/src/github.com/revel/config/error.go
+gopkg/src/github.com/revel/config/option.go
+gopkg/src/github.com/revel/config/read.go
+gopkg/src/github.com/revel/config/section.go
+gopkg/src/github.com/revel/config/testdata/app-invalid.conf
+gopkg/src/github.com/revel/config/testdata/conf-path1/app.conf
+gopkg/src/github.com/revel/config/testdata/conf-path2/app.conf
+gopkg/src/github.com/revel/config/testdata/source.cfg
+gopkg/src/github.com/revel/config/testdata/target.cfg
+gopkg/src/github.com/revel/config/type.go
+gopkg/src/github.com/revel/config/write.go
diff --git a/go-config/distinfo b/go-config/distinfo
new file mode 100644 (file)
index 0000000..cb02040
--- /dev/null
@@ -0,0 +1,6 @@
+$NetBSD$
+
+SHA1 (go-config-0.13.0.tar.gz) = a433a2f8177739dfb87b1f907d9e635b4cfc8d64
+RMD160 (go-config-0.13.0.tar.gz) = 3fb150171d20bc6ffc348e7c2e9cc1a336cd79b8
+SHA512 (go-config-0.13.0.tar.gz) = c436b8a35e1715ba49590eb584a1f54ff1832f4407ea59794ab65681e63ef643da1f99aa226a299edb26d1df9cb4ec410c0a37437a1f46434481c939ede8bd42
+Size (go-config-0.13.0.tar.gz) = 15293 bytes