Import cli-0.0.0nb20160130 as wip/cli-git.
authorKamil Rytarowski <n54@gmx.com>
Sat, 30 Jan 2016 00:19:27 +0000 (01:19 +0100)
committerKamil Rytarowski <n54@gmx.com>
Sat, 30 Jan 2016 00:19:27 +0000 (01:19 +0100)
This repo contains the .NET Core runtime, called CoreCLR, and the base library,
called mscorlib. It includes the garbage collector, JIT compiler, base .NET
data types and many low-level classes.

cli-git/DESCR [new file with mode: 0644]
cli-git/Makefile [new file with mode: 0644]
cli-git/PLIST [new file with mode: 0644]
cli-git/distinfo [new file with mode: 0644]

diff --git a/cli-git/DESCR b/cli-git/DESCR
new file mode 100644 (file)
index 0000000..9e69cfc
--- /dev/null
@@ -0,0 +1,3 @@
+This repo contains the .NET Core runtime, called CoreCLR, and the base library,
+called mscorlib. It includes the garbage collector, JIT compiler, base .NET
+data types and many low-level classes.
diff --git a/cli-git/Makefile b/cli-git/Makefile
new file mode 100644 (file)
index 0000000..5b5ebed
--- /dev/null
@@ -0,0 +1,32 @@
+# $NetBSD: Makefile,v 1.3 2015/04/25 10:01:54 krytarowski Exp $
+
+GIT_REPOSITORIES=      cli
+GIT_REPO.cli=  https://github.com/dotnet/cli.git
+
+DISTNAME=      cli
+PKGNAME=       cli-0.0.0
+CATEGORIES=    devel
+
+MAINTAINER=    pkgsrc-users@NetBSD.org
+HOMEPAGE=      https://github.com/dotnet/cli
+COMMENT=       The .NET command-line (CLI) tools
+LICENSE=       mit
+
+#USE_CMAKE=    yes
+USE_LANGUAGES= c c++
+
+USE_TOOLS+=    bash
+REPLACE_BASH+= build.sh
+
+do-build:
+               ${RUN} cd ${WRKSRC} && PYTHON=${PYTHONBIN} ./build.sh
+
+.include "../../textproc/icu/buildlink3.mk"
+.include "../../wip/llvm-git/buildlink3.mk"
+.include "../../wip/lldb-git/buildlink3.mk"
+.include "../../wip/clang-git/buildlink3.mk"
+.include "../../lang/python/extension.mk"
+.include "../../lang/python/application.mk"
+.include "../../lang/python/tool.mk"
+.include "../../wip/mk/git-package.mk"
+.include "../../mk/bsd.pkg.mk"
diff --git a/cli-git/PLIST b/cli-git/PLIST
new file mode 100644 (file)
index 0000000..ab85218
--- /dev/null
@@ -0,0 +1 @@
+@comment $NetBSD: PLIST,v 1.1 2015/04/13 00:06:34 krytarowski Exp $
diff --git a/cli-git/distinfo b/cli-git/distinfo
new file mode 100644 (file)
index 0000000..d1a6297
--- /dev/null
@@ -0,0 +1,10 @@
+$NetBSD$
+
+SHA1 (patch-src_pal_inc_pal__char16.h) = 46aab244c78afbef9af1fd93afafb2ed731894e6
+SHA1 (patch-src_pal_src_config.h.in) = bbf370ef53a770051ef1b64ff57e093061563828
+SHA1 (patch-src_pal_src_configure.cmake) = d7f4f70c2ba17552aadbb2f1ffb8f524aeda70d2
+SHA1 (patch-src_pal_src_cruntime_file.cpp) = 315ad5db53ef2b893a77aa131ce97999214e0e11
+SHA1 (patch-src_pal_src_exception_seh-unwind.cpp) = ffb395a23d66e33e5cf1b0f3f4ff5feff52a56fc
+SHA1 (patch-src_pal_src_exception_signal.cpp) = 1bcb47f927a0c8037876b47ca4d15afb24cbd410
+SHA1 (patch-src_pal_src_include_pal_context.h) = 962cf83ef0ba0a4e2e57e344809a566f12f2e01d
+SHA1 (patch-src_pal_src_misc_sysinfo.cpp) = 63a2a981180bd615be883ea9d53cc002306aa6b5