flightgear: Import flightgear-2.8.0 as wip/flightgear.
authorMateusz Poszwa <old4@o2.pl>
Fri, 6 Nov 2015 21:40:10 +0000 (22:40 +0100)
committerMateusz Poszwa <old4@o2.pl>
Fri, 6 Nov 2015 21:40:10 +0000 (22:40 +0100)
FlightGear is a free, open-source, multi-platform, and sophisticated
flight simulator framework for the development and pursuit of interesting
flight simulator ideas.

12 files changed:
flightgear/DESCR [new file with mode: 0644]
flightgear/MESSAGE [new file with mode: 0644]
flightgear/Makefile [new file with mode: 0644]
flightgear/PLIST [new file with mode: 0644]
flightgear/distinfo [new file with mode: 0644]
flightgear/patches/patch-CMakeModules_FindPLIB_cmake [new file with mode: 0644]
flightgear/patches/patch-src_Canvas_ShivaVG_src_shConfig_h [new file with mode: 0644]
flightgear/patches/patch-src_FDM_JSBSim_models_propulsion_FGEngine.cpp [new file with mode: 0644]
flightgear/patches/patch-src_Main_locale_cxx [new file with mode: 0644]
flightgear/patches/patch-src_Network_ATC-Inputs_cxx [new file with mode: 0644]
flightgear/patches/patch-src_Network_ATC-Outputs_cxx [new file with mode: 0644]
flightgear/patches/patch-utils_TerraSync_terrasync_cxx [new file with mode: 0644]

diff --git a/flightgear/DESCR b/flightgear/DESCR
new file mode 100644 (file)
index 0000000..d1511d3
--- /dev/null
@@ -0,0 +1,3 @@
+FlightGear is a free, open-source, multi-platform, and sophisticated
+flight simulator framework for the development and pursuit of interesting
+flight simulator ideas.
diff --git a/flightgear/MESSAGE b/flightgear/MESSAGE
new file mode 100644 (file)
index 0000000..10df80a
--- /dev/null
@@ -0,0 +1,5 @@
+===========================================================================
+$NetBSD: MESSAGE,v 1.1 2010/08/27 07:54:22 adam Exp $
+
+To use FlightGear, you may also need to install pkgsrc/games/flightgear-data.
+===========================================================================
diff --git a/flightgear/Makefile b/flightgear/Makefile
new file mode 100644 (file)
index 0000000..534fac5
--- /dev/null
@@ -0,0 +1,32 @@
+# $NetBSD: Makefile,v 1.53 2015/06/30 09:57:35 ryoon Exp $
+
+DISTNAME=      flightgear-2.8.0
+PKGREVISION=   24
+CATEGORIES=    games
+MASTER_SITES=  ftp://ftp.flightgear.org/pub/fgfs/Source/ \
+               http://mirrors.ibiblio.org/pub/mirrors/flightgear/ftp/Source/ \
+               ftp://ftp.kingmont.com/flightsims/flightgear/Source/
+EXTRACT_SUFX=  .tar.bz2
+
+MAINTAINER=    pkgsrc-users@NetBSD.org
+HOMEPAGE=      http://www.flightgear.org/
+COMMENT=       The FlightGear Simulator
+LICENSE=       gnu-gpl-v2 AND gnu-lgpl-v2.1
+
+USE_LANGUAGES=         c c++
+USE_PKGLOCALEDIR=      yes
+USE_CMAKE=             yes
+CMAKE_ARGS+=           -DJPEG_FACTORY:BOOL=ON
+
+.include "../../mk/jpeg.buildlink3.mk"
+.include "../../audio/freealut/buildlink3.mk"
+.include "../../audio/openal/buildlink3.mk"
+.include "../../devel/SDL/buildlink3.mk"
+.include "../../devel/boost-headers/buildlink3.mk"
+.include "../../games/plib/buildlink3.mk"
+BUILDLINK_API_DEPENDS.simgear+=        simgear>=2.0.0
+.include "../../games/simgear/buildlink3.mk"
+.include "../../graphics/glut/buildlink3.mk"
+.include "../../graphics/osg/buildlink3.mk"
+.include "../../mk/pthread.buildlink3.mk"
+.include "../../mk/bsd.pkg.mk"
diff --git a/flightgear/PLIST b/flightgear/PLIST
new file mode 100644 (file)
index 0000000..c012f0f
--- /dev/null
@@ -0,0 +1,19 @@
+@comment $NetBSD: PLIST,v 1.3 2012/09/30 10:04:33 dholland Exp $
+bin/GPSsmooth
+bin/MIDGsmooth
+bin/UGsmooth
+bin/fgfs
+bin/fgjs
+bin/fgpanel
+bin/fgviewer
+bin/js_demo
+bin/metar
+bin/terrasync
+bin/yasim
+bin/yasim-proptest
+man/man1/fgfs.1
+man/man1/fgjs.1
+man/man1/fgpanel.1
+man/man1/gl-info.1
+man/man1/js_demo.1
+man/man1/terrasync.1
diff --git a/flightgear/distinfo b/flightgear/distinfo
new file mode 100644 (file)
index 0000000..6e527cc
--- /dev/null
@@ -0,0 +1,13 @@
+$NetBSD: distinfo,v 1.6 2015/11/03 20:56:49 agc Exp $
+
+SHA1 (flightgear-2.8.0.tar.bz2) = fee4b2f1f6aca8e163ea018ae9897b99971c20bd
+RMD160 (flightgear-2.8.0.tar.bz2) = 97d8f572aeb186bfed27eb5b06803a0fa5213a61
+SHA512 (flightgear-2.8.0.tar.bz2) = 4d9b2584dd7c2fa4ad28d9769a9429809e420c7bf858967a5bb461f8ecb78dd079ff01c78febb95b7c3edce40dbf01e077bf7423324958e0b0a3cc74df12e1c1
+Size (flightgear-2.8.0.tar.bz2) = 2311023 bytes
+SHA1 (patch-CMakeModules_FindPLIB_cmake) = c5761d425743761f5f0c711ef2ca384a06f6d524
+SHA1 (patch-src_Canvas_ShivaVG_src_shConfig_h) = bd70a1e41a59196e31789e38ec67e65cef546edf
+SHA1 (patch-src_FDM_JSBSim_models_propulsion_FGEngine.cpp) = 9c066364096452868194f84d8c853131aec83f80
+SHA1 (patch-src_Main_locale_cxx) = 327f4103ff3aea60f2394a2ed192c5f6af36f60b
+SHA1 (patch-src_Network_ATC-Inputs_cxx) = 08644c682ddddcefea48aa84fa538b8fd20289c0
+SHA1 (patch-src_Network_ATC-Outputs_cxx) = d5367f8536988b2705b2ba4f8d86e28576b04648
+SHA1 (patch-utils_TerraSync_terrasync_cxx) = 48855911a5052301f2c7a449ac8ff14ada9ae8ea
diff --git a/flightgear/patches/patch-CMakeModules_FindPLIB_cmake b/flightgear/patches/patch-CMakeModules_FindPLIB_cmake
new file mode 100644 (file)
index 0000000..b0608ad
--- /dev/null
@@ -0,0 +1,25 @@
+$NetBSD: patch-CMakeModules_FindPLIB_cmake,v 1.1 2012/09/30 10:04:33 dholland Exp $
+
+Recognize BSDs other than FreeBSD.
+
+--- CMakeModules/FindPLIB.cmake~       2012-08-16 14:20:57.000000000 +0000
++++ CMakeModules/FindPLIB.cmake
+@@ -169,6 +169,18 @@ if(${haveJs} GREATER -1)
+         find_library(USBHID_LIBRARY usbhid)
+         # check_function_exists(hidinit)
+         set(JS_LIBS ${USBHID_LIBRARY})
++    elseif(CMAKE_SYSTEM_NAME MATCHES "NetBSD")
++        find_library(USBHID_LIBRARY usbhid)
++        # check_function_exists(hidinit)
++        set(JS_LIBS ${USBHID_LIBRARY})
++    elseif(CMAKE_SYSTEM_NAME MATCHES "OpenBSD")
++        find_library(USBHID_LIBRARY usbhid)
++        # check_function_exists(hidinit)
++        set(JS_LIBS ${USBHID_LIBRARY})
++    elseif(CMAKE_SYSTEM_NAME MATCHES "DragonFly")
++        find_library(USBHID_LIBRARY usbhid)
++        # check_function_exists(hidinit)
++        set(JS_LIBS ${USBHID_LIBRARY})
+     else()
+         message(WARNING "Unsupported platform for PLIB JS libs")
+     endif()
diff --git a/flightgear/patches/patch-src_Canvas_ShivaVG_src_shConfig_h b/flightgear/patches/patch-src_Canvas_ShivaVG_src_shConfig_h
new file mode 100644 (file)
index 0000000..6862d8e
--- /dev/null
@@ -0,0 +1,18 @@
+$NetBSD: patch-src_Canvas_ShivaVG_src_shConfig_h,v 1.1 2012/09/30 10:04:33 dholland Exp $
+
+This sublibrary insists on being able to work out its OS type, and
+only knows a few, even though it uses the results for just about
+nothing. So give it some crayons to play with.
+
+--- src/Canvas/ShivaVG/src/shConfig.h~ 2012-08-16 14:20:56.000000000 +0000
++++ src/Canvas/ShivaVG/src/shConfig.h
+@@ -34,7 +34,8 @@
+ #else\r
\r
+     // Unsupported system\r
+-    #error This operating system is not supported by SFML library\r
++    //#error This operating system is not supported by SFML library\r
++    #define VG_API_OTHER\r
\r
+ #endif\r
\r
diff --git a/flightgear/patches/patch-src_FDM_JSBSim_models_propulsion_FGEngine.cpp b/flightgear/patches/patch-src_FDM_JSBSim_models_propulsion_FGEngine.cpp
new file mode 100644 (file)
index 0000000..355f0b6
--- /dev/null
@@ -0,0 +1,22 @@
+$NetBSD: patch-src_FDM_JSBSim_models_propulsion_FGEngine.cpp,v 1.1 2014/08/19 13:32:46 joerg Exp $
+
+--- src/FDM/JSBSim/models/propulsion/FGEngine.cpp.orig 2014-08-19 13:11:25.000000000 +0000
++++ src/FDM/JSBSim/models/propulsion/FGEngine.cpp
+@@ -83,7 +83,7 @@ FGEngine::FGEngine(FGFDMExec* exec, Elem
+   Name = engine_element->GetAttributeValue("name");
+-  Load(engine_element, PropertyManager, to_string(EngineNumber)); // Call ModelFunctions loader
++  Load(engine_element, PropertyManager, ::to_string(EngineNumber)); // Call ModelFunctions loader
+ // Find and set engine location
+@@ -132,7 +132,7 @@ FGEngine::FGEngine(FGFDMExec* exec, Elem
+   property_name = base_property_name + "/fuel-used-lbs";
+   PropertyManager->Tie( property_name.c_str(), this, &FGEngine::GetFuelUsedLbs);
+-  PostLoad(engine_element, PropertyManager, to_string(EngineNumber));
++  PostLoad(engine_element, PropertyManager, ::to_string(EngineNumber));
+   Debug(0);
+ }
diff --git a/flightgear/patches/patch-src_Main_locale_cxx b/flightgear/patches/patch-src_Main_locale_cxx
new file mode 100644 (file)
index 0000000..72fa37e
--- /dev/null
@@ -0,0 +1,15 @@
+$NetBSD: patch-src_Main_locale_cxx,v 1.1 2012/09/30 10:04:33 dholland Exp $
+
+Use standard headers.
+
+--- src/Main/locale.cxx~       2012-08-16 14:20:56.000000000 +0000
++++ src/Main/locale.cxx
+@@ -20,6 +20,8 @@
+ #ifdef HAVE_WINDOWS_H
+ #include <windows.h>
++#else
++#include <cstdlib>
+ #endif
+ #include <simgear/props/props_io.hxx>
diff --git a/flightgear/patches/patch-src_Network_ATC-Inputs_cxx b/flightgear/patches/patch-src_Network_ATC-Inputs_cxx
new file mode 100644 (file)
index 0000000..3ff1673
--- /dev/null
@@ -0,0 +1,23 @@
+$NetBSD: patch-src_Network_ATC-Inputs_cxx,v 1.1 2012/09/30 10:04:33 dholland Exp $
+
+Fix build failure.
+
+--- src/Network/ATC-Inputs.cxx~        2012-08-16 14:20:57.000000000 +0000
++++ src/Network/ATC-Inputs.cxx
+@@ -27,14 +27,14 @@
+ #include <simgear/compiler.h>
+-#if defined( unix ) || defined( __CYGWIN__ )
++//#if defined( unix ) || defined( __CYGWIN__ )
+ #  include <sys/types.h>
+ #  include <sys/stat.h>
+ #  include <fcntl.h>
+ #  include <stdlib.h>
+ #  include <unistd.h>
+ #  include <istream>
+-#endif
++//#endif
+ #include <errno.h>
+ #include <math.h>
diff --git a/flightgear/patches/patch-src_Network_ATC-Outputs_cxx b/flightgear/patches/patch-src_Network_ATC-Outputs_cxx
new file mode 100644 (file)
index 0000000..4934e69
--- /dev/null
@@ -0,0 +1,23 @@
+$NetBSD: patch-src_Network_ATC-Outputs_cxx,v 1.1 2012/09/30 10:04:33 dholland Exp $
+
+Fix build failure.
+
+--- src/Network/ATC-Outputs.cxx~       2012-08-16 14:20:57.000000000 +0000
++++ src/Network/ATC-Outputs.cxx
+@@ -27,14 +27,14 @@
+ #include <simgear/compiler.h>
+-#if defined( unix ) || defined( __CYGWIN__ )
++//#if defined( unix ) || defined( __CYGWIN__ )
+ #  include <sys/types.h>
+ #  include <sys/stat.h>
+ #  include <fcntl.h>
+ #  include <stdlib.h>
+ #  include <unistd.h>
+ #  include <ostream>
+-#endif
++//#endif
+ #include <errno.h>
+ #include <math.h>
diff --git a/flightgear/patches/patch-utils_TerraSync_terrasync_cxx b/flightgear/patches/patch-utils_TerraSync_terrasync_cxx
new file mode 100644 (file)
index 0000000..1a019ec
--- /dev/null
@@ -0,0 +1,15 @@
+$NetBSD: patch-utils_TerraSync_terrasync_cxx,v 1.1 2012/09/30 10:04:33 dholland Exp $
+
+Recognize more BSDs.
+
+--- utils/TerraSync/terrasync.cxx~     2012-08-16 14:20:53.000000000 +0000
++++ utils/TerraSync/terrasync.cxx
+@@ -51,7 +51,7 @@
+ #if defined(_MSC_VER) || defined(__MINGW32__)
+     typedef void (__cdecl * sighandler_t)(int);
+-#elif defined( __APPLE__ ) || defined (__FreeBSD__)
++#elif defined( __APPLE__ ) || defined (__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__DragonFly__)
+     typedef sig_t sighandler_t;
+ #endif