compiler-rt-netbsd: Define INITIAL_EXEC_ATTRIBUTE for NetBSD
authorKamil Rytarowski <n54@gmx.com>
Fri, 6 Oct 2017 14:42:44 +0000 (16:42 +0200)
committerKamil Rytarowski <n54@gmx.com>
Fri, 6 Oct 2017 14:44:28 +0000 (16:44 +0200)
Sponsored by <The NetBSD Foundation>

compiler-rt-netbsd/distinfo
compiler-rt-netbsd/patches/patch-lib_sanitizer__common_sanitizer__internal__defs.h [new file with mode: 0644]

index d7d8265e83677ea7586b4064435871f3f654e10a..f4b32606c7b56d89a2c3dba420e9a15557917134 100644 (file)
@@ -2,6 +2,7 @@ $NetBSD: distinfo,v 1.35 2015/09/11 01:21:57 tnn Exp $
 
 SHA1 (patch-cmake_config-ix.cmake) = 5b1842f08cc8c2b96e0529b552b09c7adf2065dc
 SHA1 (patch-lib_fuzzer_tests_CMakeLists.txt) = eaffd9f8f2621ad465b5c734a764bdff0243af3d
+SHA1 (patch-lib_sanitizer__common_sanitizer__internal__defs.h) = f5825b7081758e07e36dbd47a887f31a20912a83
 SHA1 (patch-lib_sanitizer__common_sanitizer__linux.cc) = 25cba9ff9d61910bb74d500e515da083af4e6cb7
 SHA1 (patch-lib_tsan_go_buildgo.sh) = fe64b3389bbf6ae2ddf187df3e0600b2f817f51d
 SHA1 (patch-lib_tsan_rtl_tsan__platform.h) = 9ba65b81bb95bdf3b949da801cb9b97bf94174c4
diff --git a/compiler-rt-netbsd/patches/patch-lib_sanitizer__common_sanitizer__internal__defs.h b/compiler-rt-netbsd/patches/patch-lib_sanitizer__common_sanitizer__internal__defs.h
new file mode 100644 (file)
index 0000000..c6bca26
--- /dev/null
@@ -0,0 +1,13 @@
+$NetBSD$
+
+--- lib/sanitizer_common/sanitizer_internal_defs.h.orig        2017-10-02 13:17:03.000000000 +0000
++++ lib/sanitizer_common/sanitizer_internal_defs.h
+@@ -36,7 +36,7 @@
+ #endif
+ // TLS is handled differently on different platforms
+-#if SANITIZER_LINUX
++#if SANITIZER_LINUX || SANITIZER_NETBSD
+ # define SANITIZER_TLS_INITIAL_EXEC_ATTRIBUTE \
+     __attribute__((tls_model("initial-exec"))) thread_local
+ #else