execline: Turn off a certain warning-as-error
authorCharlotte Koch <cfkoch@edgebsd.org>
Sun, 21 Oct 2018 07:31:35 +0000 (00:31 -0700)
committerCharlotte Koch <cfkoch@edgebsd.org>
Sun, 21 Oct 2018 07:33:47 +0000 (00:33 -0700)
Of course, the real fix is to actually fix the error

execline/Makefile

index f7dcafe3b40cf2177affd6bddf1834ebd3ac8653..10c5efadde98449b980d262d019552da6f8755de 100644 (file)
@@ -1,6 +1,7 @@
 # $NetBSD$
 
 DISTNAME=      execline-2.3.0.3
+PKGREVISION=   1
 CATEGORIES=    devel
 MASTER_SITES=  http://skarnet.org/software/execline/
 
@@ -15,6 +16,7 @@ CONFIGURE_ARGS+=      --prefix=${PREFIX}
 CONFIGURE_ARGS+=       --with-sysdeps=${PREFIX}/lib/skalibs/sysdeps
 CONFIGURE_ARGS+=       --with-lib=${PREFIX}/lib/skalibs
 CONFIGURE_ARGS+=       --with-include=${PREFIX}/include
+CFLAGS+=               -Wno-implicit-function-declaration
 
 .include "../../devel/skalibs/buildlink3.mk"
 .include "../../mk/bsd.pkg.mk"