nedit: Update nedit to 5.7, fixes abort on amd64
authorAndrew Randrianasulu <randrianasulu@gmail.com>
Wed, 20 Nov 2024 03:42:09 +0000 (06:42 +0300)
committerAndrew Randrianasulu <randrianasulu@gmail.com>
Wed, 20 Nov 2024 03:43:15 +0000 (06:43 +0300)
nedit/DESCR [new file with mode: 0644]
nedit/Makefile [new file with mode: 0644]
nedit/PLIST [new file with mode: 0644]
nedit/distinfo [new file with mode: 0644]
nedit/patches/patch-aa [new file with mode: 0644]

diff --git a/nedit/DESCR b/nedit/DESCR
new file mode 100644 (file)
index 0000000..99db4af
--- /dev/null
@@ -0,0 +1,7 @@
+NEdit is a standard GUI (Graphical User Interface) style text editor for
+programs and plain-text files.  Users of Macintosh and MS Windows based text
+editors should find NEdit a familiar and comfortable environment.  NEdit
+provides all of the standard menu, dialog, editing, and mouse support, as
+well as all of the standard shortcuts to which the users of modern GUI based
+environments are accustomed.  For users of older style Unix editors, welcome
+to the world of mouse-based editing!
diff --git a/nedit/Makefile b/nedit/Makefile
new file mode 100644 (file)
index 0000000..3ac1700
--- /dev/null
@@ -0,0 +1,46 @@
+# $NetBSD: Makefile,v 1.60 2019/06/08 10:40:56 rillig Exp $
+
+DISTNAME=      nedit-${VERS}-src
+PKGNAME=       nedit-${VERS}
+PKGREVISION=   
+CATEGORIES=    editors
+MASTER_SITES=  ${MASTER_SITE_NEDIT:=v${VERS:S/./_/g}/}
+MASTER_SITES+= ${MASTER_SITE_SOURCEFORGE:=nedit/}
+EXTRACT_SUFX=  .tar.gz
+
+MAINTAINER=    pkgsrc-users@NetBSD.org
+HOMEPAGE=      http://www.nedit.org/
+# Upstream "info@nedit.org" did not reply to a message send on 22 March 2014
+# asking about patches for modern compilers.
+COMMENT=       Motif based standard GUI style text editor
+LICENSE=       gnu-gpl-v2
+
+VERS=          5.7
+MASTER_SITE_NEDIT= \
+               https://sourceforge.net/projects/nedit/files/nedit-source/
+
+WRKSRC=                        ${WRKDIR}/${PKGNAME_NOREV}
+BUILD_TARGET=          netbsd docs
+INSTALLATION_DIRS=     bin ${PKGMANDIR}/man1 ${PREFIX}/share/doc/nedit
+
+USE_TOOLS+=perl
+
+do-install:
+       ${INSTALL_PROGRAM} ${WRKSRC}/source/nedit ${DESTDIR}${PREFIX}/bin
+       ${INSTALL_PROGRAM} ${WRKSRC}/source/nc ${DESTDIR}${PREFIX}/bin
+       ${INSTALL_MAN} ${WRKSRC}/doc/nedit.man \
+               ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/nedit.1
+       ${INSTALL_MAN} ${WRKSRC}/doc/nc.man \
+               ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/nedit-nc.1
+.for f in README ReleaseNotes
+       ${INSTALL_DATA} ${WRKSRC}/${f} ${DESTDIR}${PREFIX}/share/doc/nedit
+.endfor
+.for f in faq.txt NEdit.ad
+       ${INSTALL_DATA} ${WRKSRC}/doc/${f} ${DESTDIR}${PREFIX}/share/doc/nedit
+.endfor
+
+.include "../../x11/libX11/buildlink3.mk"
+.include "../../x11/libXt/buildlink3.mk"
+.include "../../x11/libXpm/buildlink3.mk"
+.include "../../mk/motif.buildlink3.mk"
+.include "../../mk/bsd.pkg.mk"
diff --git a/nedit/PLIST b/nedit/PLIST
new file mode 100644 (file)
index 0000000..656b880
--- /dev/null
@@ -0,0 +1,9 @@
+@comment $NetBSD: PLIST,v 1.5 2013/04/28 20:35:22 dholland Exp $
+bin/nc
+bin/nedit
+man/man1/nedit-nc.1
+man/man1/nedit.1
+share/doc/nedit/NEdit.ad
+share/doc/nedit/README
+share/doc/nedit/ReleaseNotes
+share/doc/nedit/faq.txt
diff --git a/nedit/distinfo b/nedit/distinfo
new file mode 100644 (file)
index 0000000..cfd0f4d
--- /dev/null
@@ -0,0 +1,6 @@
+$NetBSD: distinfo,v 1.21 2021/10/26 10:21:34 nia Exp $
+
+BLAKE2s (nedit-5.7-src.tar.gz) = 39c70225a47446ecd8d655d830f1175af624a65e9a471b44d64cd0589751e244
+SHA512 (nedit-5.7-src.tar.gz) = cf242d2f8eea4c78649dbeb741f545a3dc8ffaf5bb36239794a4b2635420e5445fa1c77472add79c05ec081d71a0b9df4431f48db365a71692e43869fd4e7932
+Size (nedit-5.7-src.tar.gz) = 1344754 bytes
+SHA1 (patch-aa) = aee848d3c2ddf0f0919f89d5e6994b3b2bb84d58
diff --git a/nedit/patches/patch-aa b/nedit/patches/patch-aa
new file mode 100644 (file)
index 0000000..7df03df
--- /dev/null
@@ -0,0 +1,14 @@
+--- makefiles/Makefile.netbsd.orig     2024-11-19 17:46:24.345240965 +0300
++++ makefiles/Makefile.netbsd  2024-11-19 17:46:51.342881630 +0300
+@@ -10,9 +10,9 @@
+ # To test if the Motif library exports the runtime version
+ # add -DHAVE__XMVERSIONSTRING to CFLAGS
+ #
+-CFLAGS=-O -I/usr/X11R6/include -DUSE_DIRENT -DUSE_LPR_PRINT_CMD
++CFLAGS=-O -I/usr/X11R7/include -DUSE_DIRENT -DUSE_LPR_PRINT_CMD
+ ARFLAGS=-ur
+-LIBS= -L/usr/X11R6/lib -lm -lXm -lXpm -lXext -lXt -lSM -lICE -lX11
++LIBS= -L/usr/pkg/lib -L/usr/X11R7/lib -rpath=/usr/pkg/lib -rpath=/usr/X11R7/lib -lm -lXm -lXpm -lXext -lXt -lSM -lICE -lX11 -L/usr/pkg/lib -L/usr/X11R7/lib
+ include Makefile.common