cheat: Import version 1.0.4
authorMichael Baeuerle <micha@NetBSD.org>
Mon, 10 Feb 2025 12:13:37 +0000 (13:13 +0100)
committerMichael Baeuerle <micha@NetBSD.org>
Mon, 10 Feb 2025 12:13:37 +0000 (13:13 +0100)
CHEAT stands for C Header Embedded Automated Testing or something like that.
It is a convenient unit testing framework for the C programming language.

It has no dependencies and requires no installation or configuration.
Only a header file and a test case is needed.

Makefile
cheat/COMMIT_MSG [new file with mode: 0644]
cheat/DESCR [new file with mode: 0644]
cheat/Makefile [new file with mode: 0644]
cheat/PLIST [new file with mode: 0644]
cheat/distinfo [new file with mode: 0644]

index 7e61d59785724cf69200922a04f67d9d54051255..24b37d588fbbc5a212b961689f37b07e76962a1f 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -454,6 +454,7 @@ SUBDIR+=    chapel
 SUBDIR+=       chartsrv
 SUBDIR+=       charybdis
 SUBDIR+=       chbg
+SUBDIR+=       cheat
 SUBDIR+=       check-update
 SUBDIR+=       checkstyle
 SUBDIR+=       chemeq
diff --git a/cheat/COMMIT_MSG b/cheat/COMMIT_MSG
new file mode 100644 (file)
index 0000000..c160a82
--- /dev/null
@@ -0,0 +1,7 @@
+devel/cheat: Import version 1.0.4
+
+CHEAT stands for C Header Embedded Automated Testing or something like that.
+It is a convenient unit testing framework for the C programming language.
+
+It has no dependencies and requires no installation or configuration.
+Only a header file and a test case is needed.
diff --git a/cheat/DESCR b/cheat/DESCR
new file mode 100644 (file)
index 0000000..ae3cb1a
--- /dev/null
@@ -0,0 +1,5 @@
+CHEAT stands for C Header Embedded Automated Testing or something like that.
+It is a convenient unit testing framework for the C programming language.
+
+It has no dependencies and requires no installation or configuration.
+Only a header file and a test case is needed.
diff --git a/cheat/Makefile b/cheat/Makefile
new file mode 100644 (file)
index 0000000..146d2d2
--- /dev/null
@@ -0,0 +1,25 @@
+# $NetBSD$
+
+DISTNAME=      cheat-1.0.4
+CATEGORIES=    devel
+MASTER_SITES=  ${MASTER_SITE_GITHUB:=Tuplanolla/}
+GITHUB_PROJECT=        cheat
+GITHUB_TAG=    ${PKGVERSION_NOREV}
+
+OWNER=         micha@NetBSD.org
+HOMEPAGE=      https://github.com/Tuplanolla/cheat/
+COMMENT=       Convenient unit testing framework for the C programming language
+LICENSE=       2-clause-bsd
+
+USE_LANGUAGES= #
+NO_CONFIGURE=  yes
+NO_BUILD=      yes
+
+INSTALLATION_DIRS=     include man/man7
+
+do-install:
+       cd ${WRKSRC} && ${INSTALL_DATA} cheat.h ${DESTDIR}${PREFIX}/include
+       cd ${WRKSRC} && ${INSTALL_MAN} cheat.7 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man7
+
+
+.include "../../mk/bsd.pkg.mk"
diff --git a/cheat/PLIST b/cheat/PLIST
new file mode 100644 (file)
index 0000000..97b7a86
--- /dev/null
@@ -0,0 +1,3 @@
+@comment $NetBSD$
+include/cheat.h
+man/man7/cheat.7
diff --git a/cheat/distinfo b/cheat/distinfo
new file mode 100644 (file)
index 0000000..02d4d38
--- /dev/null
@@ -0,0 +1,5 @@
+$NetBSD$
+
+BLAKE2s (cheat-1.0.4.tar.gz) = f0b8c740b476f8b43b4ca57737aaf45428d51fe41c0ea40535c4db217a8b20f2
+SHA512 (cheat-1.0.4.tar.gz) = 9a30355edc08d9eeba3fe30e00f91632b32fa189bd5cf999bfc6248370e81dc7bee83d65633f6ce36143b0a5e4ab126bbe33bd489888fde9e8e8f79f5caa9bf8
+Size (cheat-1.0.4.tar.gz) = 84126 bytes