p5-IPC-Open3-Simple: Simple alternative to IPC::Open3
authorJason Bacon <bacon4000@gmail.com>
Fri, 3 Nov 2017 16:18:37 +0000 (11:18 -0500)
committerJason Bacon <bacon4000@gmail.com>
Fri, 3 Nov 2017 16:18:37 +0000 (11:18 -0500)
Makefile
p5-IPC-Open3-Simple/DESCR [new file with mode: 0644]
p5-IPC-Open3-Simple/Makefile [new file with mode: 0644]
p5-IPC-Open3-Simple/PLIST [new file with mode: 0644]
p5-IPC-Open3-Simple/distinfo [new file with mode: 0644]

index 933f7a1bf8370f9ec47d314f8d7331ecb9f2aada..b016fcbe8c8958873ee095d3487d2cc2e6e650db 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -2403,6 +2403,7 @@ SUBDIR+=  p5-HTTP-Request-StreamingUpload
 SUBDIR+=       p5-Hash-AsObject
 SUBDIR+=       p5-IO-Lambda
 SUBDIR+=       p5-IO-Socket-Socks
+SUBDIR+=       p5-IPC-Open3-Simple
 SUBDIR+=       p5-Image-EXIF
 SUBDIR+=       p5-Imager
 SUBDIR+=       p5-Iterator
diff --git a/p5-IPC-Open3-Simple/DESCR b/p5-IPC-Open3-Simple/DESCR
new file mode 100644 (file)
index 0000000..6b01a19
--- /dev/null
@@ -0,0 +1,11 @@
+IPC::Open3::Simple aims at making it very easy to start a shell command,
+eventually feed its stdin with some data, then retrieve its stdout and stderr
+separately.
+When you want to run a shell command and parse its stdout/stderr or feed its
+stdin, you often end up using IPC::Run, IPC::Cmd or IPC::Open3 with your own
+parsing code, and end up writing more code than you intended. IPC::Open3::Simple
+is about removing this overhead and making IPC::Open3 easier to use.
+IPC::Open3::Simple calls IPC::Open3 and redirects stdin, stdout and stderr to
+some function references passed in argument to the constructor. It does a select
+on the input/output filehandles returned by IPC::Open3 and dispatches their
+content to and from those functions.
diff --git a/p5-IPC-Open3-Simple/Makefile b/p5-IPC-Open3-Simple/Makefile
new file mode 100644 (file)
index 0000000..14404d3
--- /dev/null
@@ -0,0 +1,29 @@
+# $NetBSD$
+#
+###########################################################
+#                  Generated by fbsd2pkg                  #
+#              Fri Nov  3 11:12:06 CDT 2017               #
+###########################################################
+
+###########################################################
+# Unconverted and partially converted FreeBSD port syntax:
+
+#LICENSE_COMB= dual
+
+DISTNAME=      IPC-Open3-Simple-${PORTVERSION}
+PKGNAME=       p5-IPC-Open3-Simple-${PORTVERSION}
+CATEGORIES=    devel
+MASTER_SITES=  ${MASTER_SITE_PERL_CPAN:=IPC/}
+
+MAINTAINER=    bacon4000@gmail.com
+HOMEPAGE=      http://search.cpan.org/dist/IPC-Open3-Simple/
+COMMENT=       Simple alternative to IPC::Open3
+# Check this
+LICENSE=       artistic
+
+USE_TOOLS+=    perl:pkgsrc
+
+PORTVERSION=   0.04
+
+.include "../../lang/perl5/module.mk"
+.include "../../mk/bsd.pkg.mk"
diff --git a/p5-IPC-Open3-Simple/PLIST b/p5-IPC-Open3-Simple/PLIST
new file mode 100644 (file)
index 0000000..63b128e
--- /dev/null
@@ -0,0 +1,4 @@
+@comment $NetBSD$
+${PERL5_SUB_INSTALLVENDORLIB}/IPC/Open3/Simple.pm
+${PERL5_SUB_INSTALLVENDORARCH}/auto/IPC/Open3/Simple/.packlist
+${PERL5_SUB_INSTALLVENDORMAN3DIR}/IPC::Open3::Simple.3
diff --git a/p5-IPC-Open3-Simple/distinfo b/p5-IPC-Open3-Simple/distinfo
new file mode 100644 (file)
index 0000000..852cc4b
--- /dev/null
@@ -0,0 +1,6 @@
+$NetBSD$
+
+SHA1 (IPC-Open3-Simple-0.04.tar.gz) = 0063c2a7c696e6d33721ed3150d2c2ba5ebd4355
+RMD160 (IPC-Open3-Simple-0.04.tar.gz) = cd1a16dce341a3ffe4ad13e9545d0c2b1cd2455e
+SHA512 (IPC-Open3-Simple-0.04.tar.gz) = 04929a087e3e938a6ae02526312db7f6980af30963ead268d45819df5a521d6ce7f5a38260d026476edde1451d623c4111ecf481afdc9544ad9daf8d3027ea4a
+Size (IPC-Open3-Simple-0.04.tar.gz) = 5037 bytes