R-conditionz: Import R package conditionz-0.1.0 as wip/R-conditionz
authorBrook Milligan <brook@nmsu.edu>
Wed, 8 Sep 2021 17:46:09 +0000 (11:46 -0600)
committerBrook Milligan <brook@nmsu.edu>
Wed, 8 Sep 2021 17:46:09 +0000 (11:46 -0600)
Control how many times conditions are thrown

Package API:

 - `handle_messages`
 - `handle_conditions`
 - `ConditionKeeper`
 - `handle_warnings`
 - `capture_message`
 - `capture_warning`

Use cases for `conditionz` functions:

- `ConditionKeeper` is what you want to use if you want to keep track
  of conditions inside a function being applied many times, either in
  a for loop or lapply style fashion.

- `handle_conditions`/`handle_messages`/`handle_warnings` is what you
  want to use if the multiple conditions are happening within a single
  function or code block

- `capture_message`/`capture_warning` are meant for capturing
  messages/warnings into a useable list

Makefile
R-conditionz/DESCR [new file with mode: 0644]
R-conditionz/Makefile [new file with mode: 0644]
R-conditionz/distinfo [new file with mode: 0644]

index 28a472b7912fac8827ce2058ad50fcaab65a255b..f7f55d2ea0d47a9af6a80dd9c6edb4952d80aeee 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -46,6 +46,7 @@ SUBDIR+=      R-bigmemory
 SUBDIR+=       R-bigmemory.sri
 SUBDIR+=       R-bigtabulate
 SUBDIR+=       R-bnlearn
+SUBDIR+=       R-conditionz
 SUBDIR+=       R-cubature
 SUBDIR+=       R-doParallel
 SUBDIR+=       R-easySVG
diff --git a/R-conditionz/DESCR b/R-conditionz/DESCR
new file mode 100644 (file)
index 0000000..d02898a
--- /dev/null
@@ -0,0 +1,3 @@
+Provides ability to control how many times in function calls
+conditions are thrown (shown to the user). Includes control of
+warnings and messages.
diff --git a/R-conditionz/Makefile b/R-conditionz/Makefile
new file mode 100644 (file)
index 0000000..38f4c8f
--- /dev/null
@@ -0,0 +1,16 @@
+# $NetBSD$
+
+R_PKGNAME=     conditionz
+R_PKGVER=      0.1.0
+CATEGORIES=    devel
+
+MAINTAINER=    pkgsrc-users@NetBSD.org
+COMMENT=       Control how many times conditions are thrown
+LICENSE=       mit
+
+DEPENDS+=      R-uuid>=0.1.2:../../devel/R-uuid
+
+USE_LANGUAGES= # none
+
+.include "../../math/R/Makefile.extension"
+.include "../../mk/bsd.pkg.mk"
diff --git a/R-conditionz/distinfo b/R-conditionz/distinfo
new file mode 100644 (file)
index 0000000..5328f4a
--- /dev/null
@@ -0,0 +1,6 @@
+$NetBSD$
+
+SHA1 (R/conditionz_0.1.0.tar.gz) = e56fecd4f0025b170e0b54f099713bef42d1c53e
+RMD160 (R/conditionz_0.1.0.tar.gz) = b834a3dbd30b3781c065a3f3e8bf8ee2b886962b
+SHA512 (R/conditionz_0.1.0.tar.gz) = b1b9b8181d20c9681c31520d17544b9551c44411763d0019ac68181b305f3b4d34a1c92fc26915e10f43fbd3546f7c1061a661b87c5c2dd3b2f3a358afb91904
+Size (R/conditionz_0.1.0.tar.gz) = 7372 bytes