corefx-git: Feature detect two pal_errno symbols
authorjasonwilliams200ok <necmon@yahoo.com>
Sun, 7 Feb 2016 18:56:11 +0000 (18:56 +0000)
committerjasonwilliams200ok <necmon@yahoo.com>
Sun, 7 Feb 2016 18:56:42 +0000 (18:56 +0000)
corefx-git/distinfo
corefx-git/patches/patch-src_Native_configure.cmake

index e1a9053e52a25e66f558de7cc68d179578c37164..29204d886f23a5d538c1f0614a021be811e4d652 100644 (file)
@@ -1,3 +1,5 @@
 $NetBSD$
+SHA1 (patch-src_Native_Common_pal__config.h.in) = df846d4283b3faa55c6b629ed9772afd40ff5d3c
+SHA1 (patch-src_Native_System.Native_pal__errno.cpp) = 80c19049b465824ebd518c367e228231f12b5022
 SHA1 (patch-src_Native_System.Native_pal__interfaceaddresses.cpp) = 4f82e6f028fe2b9826ba6afb62869e42a0b6ee3d
-SHA1 (patch-src_Native_configure.cmake) = 147acf1936ae3e66b8afb591ea2f114434a1f06b
+SHA1 (patch-src_Native_configure.cmake) = 383369775e46d22780ae7448cfb62b9dace09215
index 2a23fa97c08902e7e10ae9dff7f0b4d605a82af1..4bbe3e8661d0daee9fce61a079e00f6e67d9647b 100644 (file)
@@ -10,3 +10,20 @@ $NetBSD$
  
  # in_pktinfo: Find whether this struct exists
  check_include_files(
+@@ -75,6 +76,16 @@ check_symbol_exists(
+     "sys/ioctl.h"
+     HAVE_TIOCGWINSZ)
++check_symbol_exists(
++    ENOTRECOVERABLE
++    "sys/errno.h"
++    HAVE_ENOTRECOVERABLE)
++
++check_symbol_exists(
++    EOWNERDEAD
++    "sys/errno.h"
++    HAVE_EOWNERDEAD)
++
+ check_function_exists(
+     tcgetattr
+     HAVE_TCGETATTR)