webkit-gtk: Limit patch-Source_JavaScriptCore_jit_ExecutableAllocator.cpp to OpenBSD
authorLeonardo Taccari <leot@NetBSD.org>
Mon, 1 Oct 2018 17:05:29 +0000 (19:05 +0200)
committerLeonardo Taccari <leot@NetBSD.org>
Mon, 1 Oct 2018 17:05:29 +0000 (19:05 +0200)
It is no longer present on FreeBSD ports (so update the comment) and it is not
problematic on NetBSD... just limit it to OpenBSD.

webkit-gtk/TODO
webkit-gtk/distinfo
webkit-gtk/patches/patch-Source_JavaScriptCore_jit_ExecutableAllocator.cpp

index cfb002d3f0b50062a85647922ac6c56f71fe57a9..ee5f03c5b72fff2ce1d8ec8afa291d17b10f7d0a 100644 (file)
@@ -1,6 +1,3 @@
-- Is patches/patch-Source_JavaScriptCore_jit_ExecutableAllocator.cpp relevant
-  for NetBSD? (probably not, `&& !defined(__FreeBSD__) && !defined(__NetBSD__)'
-  can be probably removed after testing it)
 - Review JIT support for NetBSD:
    * patches/patch-Source_JavaScriptCore_runtime_MachineContext.h
    * patches/patch-Source_WTF_wtf_Platform.h
index 6df8e1d9478e1fe1b92f8d3ff98aa0288f980b6b..d93309a4510393312f13443d815b45e44ecc8d14 100644 (file)
@@ -8,7 +8,7 @@ SHA1 (patch-CMakeLists.txt) = dacc4c2694c517ea34a3512ffd48731b21afa5b1
 SHA1 (patch-Source_JavaScriptCore_assembler_ARMAssembler.h) = 99e46f9d9b26a8d9ba6b29c66d7ce5326c4ffeb6
 SHA1 (patch-Source_JavaScriptCore_assembler_MacroAssemblerARM.cpp) = f78e6150ed8901b3fe046b2ef182f50f1c7500a4
 SHA1 (patch-Source_JavaScriptCore_heap_MarkedSpace.cpp) = e6a23d5ef22bddd0a9606fb0e472960e4cf5673e
-SHA1 (patch-Source_JavaScriptCore_jit_ExecutableAllocator.cpp) = 2f20d6aa8f1ec4122bee9f2f95b736ee4496812f
+SHA1 (patch-Source_JavaScriptCore_jit_ExecutableAllocator.cpp) = 81d9c3a9f5d850d85aaa24d00cc72b5d0261f33a
 SHA1 (patch-Source_JavaScriptCore_runtime_MachineContext.h) = 928050c743dc889cb42fa4e74bec5664b8e1318c
 SHA1 (patch-Source_ThirdParty_gtest_include_gtest_internal_gtest-port.h) = f1eee7f9d3012edee1915234c837cff820f97092
 SHA1 (patch-Source_WTF_wtf_Platform.h) = 6ab636e109494d555d3ee63d49b1a11482309ab0
index 11e8d713c5e6441abbcd2d860023a2e1657700ee..64c6783ebbb901c8937d0f8a313c168b1da2720b 100644 (file)
@@ -1,10 +1,10 @@
 $NetBSD: patch-Source_JavaScriptCore_jit_ExecutableAllocator.cpp,v 1.1 2018/04/09 08:33:48 wiz Exp $
 
-Avoid to (pre)allocate 1GB of memory:
+Avoid to (pre)allocate 1GB of memory on OpenBSD:
 
  <https://bugs.webkit.org/show_bug.cgi?id=61137>
 
-From FreeBSD and OpenBSD ports.
+From OpenBSD ports.
 
 --- Source/JavaScriptCore/jit/ExecutableAllocator.cpp.orig     2017-08-09 09:13:42.000000000 +0000
 +++ Source/JavaScriptCore/jit/ExecutableAllocator.cpp
@@ -13,7 +13,7 @@ From FreeBSD and OpenBSD ports.
  #elif CPU(ARM64)
  static const size_t fixedExecutableMemoryPoolSize = 64 * 1024 * 1024;
 -#elif CPU(X86_64)
-+#elif CPU(X86_64) && !defined(__OpenBSD__) && !defined(__FreeBSD__) && !defined(__NetBSD__)
++#elif CPU(X86_64) && !defined(__OpenBSD__)
  static const size_t fixedExecutableMemoryPoolSize = 1024 * 1024 * 1024;
  #else
  static const size_t fixedExecutableMemoryPoolSize = 32 * 1024 * 1024;