Import go-freetype-20170609 to wip
authorK.I.A.Derouiche <kamelderouiche@yahoo.com>
Sun, 10 Jan 2021 00:18:49 +0000 (01:18 +0100)
committerK.I.A.Derouiche <kamelderouiche@yahoo.com>
Sun, 10 Jan 2021 00:18:49 +0000 (01:18 +0100)
Makefile
go-freetype/DESCR [new file with mode: 0644]
go-freetype/Makefile [new file with mode: 0644]
go-freetype/PLIST [new file with mode: 0644]
go-freetype/buildlink3.mk [new file with mode: 0644]
go-freetype/distinfo [new file with mode: 0644]

index 55b004c7feb27bef18fb5559480ec61e3e2615b5..281ad06215b188e8df26089c034f6d2994f27723 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1192,6 +1192,7 @@ SUBDIR+=  go-err113
 SUBDIR+=       go-errorx
 SUBDIR+=       go-flac-eaburns
 SUBDIR+=       go-flags
+SUBDIR+=       go-freetype
 SUBDIR+=       go-fsnotify
 SUBDIR+=       go-ghodss-yaml
 SUBDIR+=       go-godot
diff --git a/go-freetype/DESCR b/go-freetype/DESCR
new file mode 100644 (file)
index 0000000..fe2a9af
--- /dev/null
@@ -0,0 +1 @@
+The Freetype font rasterizer in the Go programming language.
diff --git a/go-freetype/Makefile b/go-freetype/Makefile
new file mode 100644 (file)
index 0000000..0a581cc
--- /dev/null
@@ -0,0 +1,24 @@
+# $NetBSD$
+
+DISTNAME=      freetype-20170609
+PKGNAME=       go-${DISTNAME}
+GITHUB_PROJECT=        freetype
+GITHUB_TAG=    e2365dfdc4a05e4b8299a783240d4a7d5a65d4e4
+CATEGORIES=    graphics
+MASTER_SITES=  ${MASTER_SITE_GITHUB:=golang/}
+
+MAINTAINER=    kamelderouiche@yahoo.com
+HOMEPAGE=      https://github.com/golang/freetype/
+COMMENT=       The Freetype font rasterizer in the Go programming language
+LICENSE=       gnu-gpl-v2
+
+GO_DIST_BASE=   ${GITHUB_PROJECT}-${GITHUB_TAG}
+GO_SRCPATH=     github.com/golang/${GITHUB_PROJECT}
+
+USE_TOOLS+= bash
+
+REPLACE_BASH+= testdata/make-other-hinting-txts.sh
+
+.include "../../graphics/go-image/buildlink3.mk"
+.include "../../lang/go/go-package.mk"
+.include "../../mk/bsd.pkg.mk"
diff --git a/go-freetype/PLIST b/go-freetype/PLIST
new file mode 100644 (file)
index 0000000..ae239a1
--- /dev/null
@@ -0,0 +1,44 @@
+@comment $NetBSD$
+gopkg/pkg/${GO_PLATFORM}/github.com/golang/freetype.a
+gopkg/pkg/${GO_PLATFORM}/github.com/golang/freetype/raster.a
+gopkg/pkg/${GO_PLATFORM}/github.com/golang/freetype/truetype.a
+gopkg/src/github.com/golang/freetype/AUTHORS
+gopkg/src/github.com/golang/freetype/CONTRIBUTORS
+gopkg/src/github.com/golang/freetype/LICENSE
+gopkg/src/github.com/golang/freetype/README
+gopkg/src/github.com/golang/freetype/cmd/print-glyph-points/main.c
+gopkg/src/github.com/golang/freetype/example/capjoin/main.go
+gopkg/src/github.com/golang/freetype/example/drawer/main.go
+gopkg/src/github.com/golang/freetype/example/freetype/main.go
+gopkg/src/github.com/golang/freetype/example/gamma/main.go
+gopkg/src/github.com/golang/freetype/example/genbasicfont/main.go
+gopkg/src/github.com/golang/freetype/example/raster/main.go
+gopkg/src/github.com/golang/freetype/example/round/main.go
+gopkg/src/github.com/golang/freetype/example/truetype/main.go
+gopkg/src/github.com/golang/freetype/freetype.go
+gopkg/src/github.com/golang/freetype/freetype_test.go
+gopkg/src/github.com/golang/freetype/licenses/ftl.txt
+gopkg/src/github.com/golang/freetype/licenses/gpl.txt
+gopkg/src/github.com/golang/freetype/raster/geom.go
+gopkg/src/github.com/golang/freetype/raster/paint.go
+gopkg/src/github.com/golang/freetype/raster/raster.go
+gopkg/src/github.com/golang/freetype/raster/stroke.go
+gopkg/src/github.com/golang/freetype/testdata/COPYING
+gopkg/src/github.com/golang/freetype/testdata/README
+gopkg/src/github.com/golang/freetype/testdata/luximr.ttf
+gopkg/src/github.com/golang/freetype/testdata/luximr.ttx
+gopkg/src/github.com/golang/freetype/testdata/luxirr.ttf
+gopkg/src/github.com/golang/freetype/testdata/luxirr.ttx
+gopkg/src/github.com/golang/freetype/testdata/luxisr-12pt-sans-hinting.txt
+gopkg/src/github.com/golang/freetype/testdata/luxisr-12pt-with-hinting.txt
+gopkg/src/github.com/golang/freetype/testdata/luxisr.ttf
+gopkg/src/github.com/golang/freetype/testdata/luxisr.ttx
+gopkg/src/github.com/golang/freetype/testdata/make-other-hinting-txts.sh
+gopkg/src/github.com/golang/freetype/truetype/face.go
+gopkg/src/github.com/golang/freetype/truetype/face_test.go
+gopkg/src/github.com/golang/freetype/truetype/glyph.go
+gopkg/src/github.com/golang/freetype/truetype/hint.go
+gopkg/src/github.com/golang/freetype/truetype/hint_test.go
+gopkg/src/github.com/golang/freetype/truetype/opcodes.go
+gopkg/src/github.com/golang/freetype/truetype/truetype.go
+gopkg/src/github.com/golang/freetype/truetype/truetype_test.go
diff --git a/go-freetype/buildlink3.mk b/go-freetype/buildlink3.mk
new file mode 100644 (file)
index 0000000..dce5bc2
--- /dev/null
@@ -0,0 +1,18 @@
+# $NetBSD$
+
+BUILDLINK_TREE+=       go-freetype
+
+.if !defined(GO_FREETYPE_BUILDLINK3_MK)
+GO_FREETYPE_BUILDLINK3_MK:=
+
+BUILDLINK_CONTENTS_FILTER.go-freetype= ${EGREP} gopkg/
+BUILDLINK_DEPMETHOD.go-freetype?=              build
+
+BUILDLINK_API_DEPENDS.go-freetype+=    go-freetype>=20170609
+BUILDLINK_PKGSRCDIR.go-freetype?=      ../../category/go-freetype
+
+
+.include "../../graphics/go-image/buildlink3.mk"
+.endif # GO_FREETYPE_BUILDLINK3_MK
+
+BUILDLINK_TREE+=       -go-freetype
diff --git a/go-freetype/distinfo b/go-freetype/distinfo
new file mode 100644 (file)
index 0000000..185d13f
--- /dev/null
@@ -0,0 +1,6 @@
+$NetBSD$
+
+SHA1 (freetype-20170609-e2365dfdc4a05e4b8299a783240d4a7d5a65d4e4.tar.gz) = f2e0dfb71583532732c1a0dcf260fa4cd094b5ca
+RMD160 (freetype-20170609-e2365dfdc4a05e4b8299a783240d4a7d5a65d4e4.tar.gz) = cb129bea38dea064fc9ebaa013484e34ef272724
+SHA512 (freetype-20170609-e2365dfdc4a05e4b8299a783240d4a7d5a65d4e4.tar.gz) = 47f437a4d076cc6e72b295c3cc13bae66abc026b5f5961b17cae427acd285a006316adc44a48a2af5f8bdf1a787a0bc15a8c953664a5f65732868efbeabd8de9
+Size (freetype-20170609-e2365dfdc4a05e4b8299a783240d4a7d5a65d4e4.tar.gz) = 466612 bytes