varnish: remove, updated in pkgsrc
authorTobias Nygren <tnn@NetBSD.org>
Fri, 25 Jun 2021 12:24:33 +0000 (14:24 +0200)
committerTobias Nygren <tnn@NetBSD.org>
Fri, 25 Jun 2021 12:24:33 +0000 (14:24 +0200)
14 files changed:
Makefile
varnish-modules/Makefile
varnish/DESCR [deleted file]
varnish/Makefile [deleted file]
varnish/PLIST [deleted file]
varnish/buildlink3.mk [deleted file]
varnish/distinfo [deleted file]
varnish/files/smf/manifest.xml [deleted file]
varnish/files/varnishd.sh [deleted file]
varnish/files/varnishlog.sh [deleted file]
varnish/files/varnishncsa.sh [deleted file]
varnish/patches/patch-bin_varnishd_cache_cache__panic.c [deleted file]
varnish/patches/patch-etc_Makefile.in [deleted file]
varnish/patches/patch-include_tbl_params.h [deleted file]

index 1799ff747a5b55ecaf204dd52dab9d6898e4dedf..990af5fc3630f5062ba03da1dbcda729ce1e8a9c 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -5683,7 +5683,6 @@ SUBDIR+=  valgrind-netbsd
 SUBDIR+=       vamp
 SUBDIR+=       vamps
 SUBDIR+=       vanitygen
-SUBDIR+=       varnish
 SUBDIR+=       varnish-modules
 SUBDIR+=       vault
 SUBDIR+=       vba-m
index 5cd23e0767036241d7daeca201aede82213a2c2b..55f572151320172de298998a9f1a2cc13f06fa2a 100644 (file)
@@ -23,6 +23,6 @@ BUILDLINK_TRANSFORM+= rm:-Werror
 pre-configure:
        cd ${WRKSRC} && ./bootstrap
 
-.include "../../wip/varnish/buildlink3.mk"
+.include "../../www/varnish/buildlink3.mk"
 .include "../../lang/python/application.mk"
 .include "../../mk/bsd.pkg.mk"
diff --git a/varnish/DESCR b/varnish/DESCR
deleted file mode 100644 (file)
index ba07daa..0000000
+++ /dev/null
@@ -1,9 +0,0 @@
-Varnish is
-
-* a high-performace HTTP accelerator designed for content-heavy
-  dynamic web sites.
-* designed for maximum performance on modern hardware and modern
-  operating systems. Varnish takes full advantage of modern virtual
-  memory systems and of advanced operating system features such as
-  kqueue, accept filters, sendfile etc. where available.
-* open source, published under a two-clause BSD license.
diff --git a/varnish/Makefile b/varnish/Makefile
deleted file mode 100644 (file)
index 057689c..0000000
+++ /dev/null
@@ -1,89 +0,0 @@
-# $NetBSD$
-
-DISTNAME=      varnish-6.6.0
-CATEGORIES=    www
-MASTER_SITES=  https://varnish-cache.org/_downloads/
-EXTRACT_SUFX=  .tgz
-
-MAINTAINER=    pkgsrc-users@NetBSD.org
-HOMEPAGE=      https://varnish-cache.org/
-COMMENT=       High-performace HTTP accelerator
-LICENSE=       modified-bsd
-
-BUILD_DEPENDS+=                ${PYPKGPREFIX}-docutils>=0.12:../../textproc/py-docutils
-
-PYTHON_VERSIONED_DEPENDENCIES= sphinx:tool
-
-GNU_CONFIGURE= yes
-USE_LIBTOOL=   yes
-USE_TOOLS+=    pkg-config gmake
-
-BUILD_DEFS+=   VARBASE
-BUILD_DEFS+=   PKG_SYSCONFBASE
-
-CONF_FILES=            share/examples/varnish/builtin.vcl \
-                       ${PKG_SYSCONFDIR}/builtin.vcl
-CONF_FILES+=           share/examples/varnish/example.vcl \
-                       ${PKG_SYSCONFDIR}/example.vcl
-
-.include "../../mk/bsd.prefs.mk"
-
-VRNUSER?=              varnish
-VRNGROUP?=             ${VRNUSER}
-STATEDIR=              ${VARBASE}/db
-VRNDIR=                        ${STATEDIR}/${PKGBASE}
-
-OWN_DIRS+=             ${VRNDIR}
-OWN_DIRS_PERMS+=       ${VRNDIR} ${VRNUSER} ${VRNGROUP} 0770
-
-PKG_GROUPS+=           ${VRNGROUP}
-PKG_USERS+=            ${VRNUSER}:${VRNGROUP}
-PKG_HOME.${VRNUSER}=   ${VRNDIR}
-PKG_SHELL.${VRNUSER}=  ${SH}
-PKG_GECOS.${VRNUSER}=  Varnish daemon user
-
-PKG_SYSCONFSUBDIR=     varnish
-
-FILES_SUBST+=          VRNUSER=${VRNUSER}
-FILES_SUBST+=          VRNGROUP=${VRNGROUP}
-
-REPLACE_PYTHON+=       lib/libvcc/vmodtool.py
-REPLACE_PYTHON+=       lib/libvcc/vsctool.py
-
-CONFIGURE_ARGS+=       --localstatedir=${STATEDIR}
-CONFIGURE_ARGS+=       --sysconfdir=${PKG_SYSCONFBASE}
-CONFIGURE_ARGS+=       --with-rst2html=${PREFIX}/bin/rst2html-${PYVERSSUFFIX}
-CONFIGURE_ARGS+=       --with-rst2man=${PREFIX}/bin/rst2man-${PYVERSSUFFIX}
-CONFIGURE_ARGS+=       --with-sphinx-build=${PREFIX}/bin/sphinx-build-${PYVERSSUFFIX}
-
-# Explicitly disable epoll on illumos, provided for Linux compat only.
-CONFIGURE_ARGS.SunOS+= --disable-epoll
-
-.include "../../mk/compiler.mk"
-
-# Fixes build on at least SunOS/i386
-# See https://github.com/varnishcache/varnish-cache/issues/1875
-.if !empty(CC_VERSION:Mgcc*) && ${MACHINE_ARCH} == "i386"
-CFLAGS+=               -fexcess-precision=standard
-.endif
-LDFLAGS+=              -lm # for ldexp
-
-INSTALL_MAKE_FLAGS+=   sysconfdir=${PREFIX}/share/examples/varnish
-
-# not signed/unsigned char safe
-BUILDLINK_TRANSFORM+=  rm:-Werror
-
-PKGCONFIG_OVERRIDE+=   varnishapi.pc.in
-
-RCD_SCRIPTS=           varnishd varnishlog varnishncsa
-
-TEST_TARGET=           check
-
-.include "../../devel/pcre/buildlink3.mk"
-.include "../../devel/libexecinfo/buildlink3.mk"
-.include "../../lang/python/application.mk"
-.include "../../lang/python/versioned_dependencies.mk"
-.include "../../mk/curses.buildlink3.mk"
-.include "../../mk/pthread.buildlink3.mk"
-.include "../../mk/readline.buildlink3.mk"
-.include "../../mk/bsd.pkg.mk"
diff --git a/varnish/PLIST b/varnish/PLIST
deleted file mode 100644 (file)
index 273a018..0000000
+++ /dev/null
@@ -1,132 +0,0 @@
-@comment $NetBSD$
-bin/varnishadm
-bin/varnishhist
-bin/varnishlog
-bin/varnishncsa
-bin/varnishstat
-bin/varnishstat_help_gen
-bin/varnishtest
-bin/varnishtop
-include/varnish/cache/cache.h
-include/varnish/cache/cache_backend.h
-include/varnish/cache/cache_director.h
-include/varnish/cache/cache_filter.h
-include/varnish/cache/cache_varnishd.h
-include/varnish/common/common_param.h
-include/varnish/miniobj.h
-include/varnish/tbl/acct_fields_bereq.h
-include/varnish/tbl/acct_fields_req.h
-include/varnish/tbl/backend_poll.h
-include/varnish/tbl/ban_arg_oper.h
-include/varnish/tbl/ban_oper.h
-include/varnish/tbl/ban_vars.h
-include/varnish/tbl/bo_flags.h
-include/varnish/tbl/boc_state.h
-include/varnish/tbl/body_status.h
-include/varnish/tbl/cli_cmds.h
-include/varnish/tbl/debug_bits.h
-include/varnish/tbl/feature_bits.h
-include/varnish/tbl/h2_error.h
-include/varnish/tbl/h2_frames.h
-include/varnish/tbl/h2_settings.h
-include/varnish/tbl/h2_stream.h
-include/varnish/tbl/htc.h
-include/varnish/tbl/http_headers.h
-include/varnish/tbl/http_response.h
-include/varnish/tbl/locks.h
-include/varnish/tbl/mgt_vcc.h
-include/varnish/tbl/obj_attr.h
-include/varnish/tbl/oc_exp_flags.h
-include/varnish/tbl/oc_flags.h
-include/varnish/tbl/params.h
-include/varnish/tbl/req_flags.h
-include/varnish/tbl/sess_attr.h
-include/varnish/tbl/sess_close.h
-include/varnish/tbl/symbol_kind.h
-include/varnish/tbl/vcl_returns.h
-include/varnish/tbl/vcl_states.h
-include/varnish/tbl/vhd_fsm.h
-include/varnish/tbl/vhd_fsm_funcs.h
-include/varnish/tbl/vhd_return.h
-include/varnish/tbl/vhp_huffman.h
-include/varnish/tbl/vhp_static.h
-include/varnish/tbl/vrt_stv_var.h
-include/varnish/tbl/vsc_levels.h
-include/varnish/tbl/vsig_list.h
-include/varnish/tbl/vsl_tags.h
-include/varnish/tbl/vsl_tags_http.h
-include/varnish/tbl/waiters.h
-include/varnish/vapi/vapi_options.h
-include/varnish/vapi/voptget.h
-include/varnish/vapi/vsc.h
-include/varnish/vapi/vsig.h
-include/varnish/vapi/vsl.h
-include/varnish/vapi/vsl_int.h
-include/varnish/vapi/vsm.h
-include/varnish/vas.h
-include/varnish/vav.h
-include/varnish/vbh.h
-include/varnish/vbm.h
-include/varnish/vcl.h
-include/varnish/vcli.h
-include/varnish/vcs.h
-include/varnish/vdef.h
-include/varnish/vmod_abi.h
-include/varnish/vqueue.h
-include/varnish/vre.h
-include/varnish/vrnd.h
-include/varnish/vrt.h
-include/varnish/vrt_obj.h
-include/varnish/vsa.h
-include/varnish/vsb.h
-include/varnish/vsha256.h
-include/varnish/vtcp.h
-include/varnish/vtim.h
-include/varnish/vtree.h
-include/varnish/vut.h
-include/varnish/vut_options.h
-include/varnish/waiter/waiter.h
-lib/libvarnishapi.la
-lib/pkgconfig/varnishapi.pc
-lib/varnish/vmods/libvmod_blob.la
-lib/varnish/vmods/libvmod_cookie.la
-lib/varnish/vmods/libvmod_debug.la
-lib/varnish/vmods/libvmod_directors.la
-lib/varnish/vmods/libvmod_proxy.la
-lib/varnish/vmods/libvmod_purge.la
-lib/varnish/vmods/libvmod_std.la
-lib/varnish/vmods/libvmod_unix.la
-lib/varnish/vmods/libvmod_vtc.la
-man/man1/varnishadm.1
-man/man1/varnishd.1
-man/man1/varnishhist.1
-man/man1/varnishlog.1
-man/man1/varnishncsa.1
-man/man1/varnishstat.1
-man/man1/varnishtest.1
-man/man1/varnishtop.1
-man/man3/vmod_blob.3
-man/man3/vmod_cookie.3
-man/man3/vmod_directors.3
-man/man3/vmod_proxy.3
-man/man3/vmod_purge.3
-man/man3/vmod_std.3
-man/man3/vmod_unix.3
-man/man3/vmod_vtc.3
-man/man7/varnish-cli.7
-man/man7/varnish-counters.7
-man/man7/vcl-backend.7
-man/man7/vcl-probe.7
-man/man7/vcl-var.7
-man/man7/vcl.7
-man/man7/vsl-query.7
-man/man7/vsl.7
-man/man7/vtc.7
-sbin/varnishd
-share/aclocal/varnish-legacy.m4
-share/aclocal/varnish.m4
-share/examples/varnish/builtin.vcl
-share/examples/varnish/example.vcl
-share/varnish/vcl/devicedetect.vcl
-share/varnish/vmodtool.py
-share/varnish/vsctool.py
diff --git a/varnish/buildlink3.mk b/varnish/buildlink3.mk
deleted file mode 100644 (file)
index 805a4c7..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-# $NetBSD$
-
-BUILDLINK_TREE+=       varnish
-
-.if !defined(VARNISH_BUILDLINK3_MK)
-VARNISH_BUILDLINK3_MK:=
-
-BUILDLINK_API_DEPENDS.varnish+=        varnish>=6.6.0
-BUILDLINK_PKGSRCDIR.varnish?=  ../../wip/varnish
-
-.include "../../devel/libexecinfo/buildlink3.mk"
-.include "../../devel/pcre/buildlink3.mk"
-
-.endif # VARNISH_BUILDLINK3_MK
-
-BUILDLINK_TREE+=       -varnish
diff --git a/varnish/distinfo b/varnish/distinfo
deleted file mode 100644 (file)
index effb797..0000000
+++ /dev/null
@@ -1,9 +0,0 @@
-$NetBSD: distinfo,v 1.13 2015/03/09 00:47:05 mspo Exp $
-
-SHA1 (varnish-6.6.0.tgz) = c330a3cbdbb13586338d1419ef8913efbd3816ae
-RMD160 (varnish-6.6.0.tgz) = 550dfcf68597dc2937c7eafa7dd03ff805c3cdfa
-SHA512 (varnish-6.6.0.tgz) = 0f52e94dd866a7cf141f9333a9169b396627f169907acb2d64f18dcac3188f9d9f1e72ea9eb9f2c0c19a5f53df0c90446041eb2b1e52f4756ea257efb329d0d1
-Size (varnish-6.6.0.tgz) = 3519048 bytes
-SHA1 (patch-bin_varnishd_cache_cache__panic.c) = cf2b9c1f2c3ba15c7e20baca3c9af607a3e1fa82
-SHA1 (patch-etc_Makefile.in) = f4407cad5f9f6c6402ab3b7fce0e1577d70b36be
-SHA1 (patch-include_tbl_params.h) = 649355bb5a43bf2db6a40076be55fe165dd97edf
diff --git a/varnish/files/smf/manifest.xml b/varnish/files/smf/manifest.xml
deleted file mode 100644 (file)
index 84a0a47..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-<?xml version="1.0"?>
-<!DOCTYPE service_bundle SYSTEM "/usr/share/lib/xml/dtd/service_bundle.dtd.1">
-<service_bundle type="manifest" name="varnish">
-  <service name="@SMF_PREFIX@/@SMF_NAME@" type="service" version="1">
-    <create_default_instance enabled="false" />
-    <single_instance />
-    <dependency name="network" grouping="require_all" restart_on="error" type="service">
-      <service_fmri value="svc:/milestone/network:default" />
-    </dependency>
-    <dependency name="filesystem" grouping="require_all" restart_on="error" type="service">
-      <service_fmri value="svc:/system/filesystem/local" />
-    </dependency>
-    <method_context>
-      <method_credential user='@VRNUSER@' group='@VRNGROUP@' privileges='basic,net_privaddr' />
-      <method_environment>
-        <envvar name='PATH' value='@PREFIX@/sbin:@PREFIX@/bin:/sbin:/usr/sbin:/usr/bin' />
-      </method_environment>
-    </method_context>
-    <exec_method type="method" name="start" exec="@PREFIX@/sbin/varnishd -j solaris -a %{listen} -l %{size} -f %{config_file}" timeout_seconds="60" />
-    <exec_method type="method" name="stop" exec=":kill" timeout_seconds="60" />
-    <property_group name="startd" type="framework">
-      <propval name="duration" type="astring" value="contract" />
-      <propval name="ignore_error" type="astring" value="core,signal" />
-    </property_group>
-    <property_group name="application" type="application">
-      <propval name="config_file" type="astring" value="@PKG_SYSCONFDIR@/example.vcl" />
-      <propval name="listen" type="astring" value="0.0.0.0:8080" />
-      <propval name="size" type="astring" value="64M" />
-    </property_group>
-    <stability value="Evolving" />
-    <template>
-      <common_name>
-        <loctext xml:lang="C">Varnish daemon</loctext>
-      </common_name>
-    </template>
-  </service>
-</service_bundle>
diff --git a/varnish/files/varnishd.sh b/varnish/files/varnishd.sh
deleted file mode 100644 (file)
index 01ffc50..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-#!@RCD_SCRIPTS_SHELL@
-#
-# PROVIDE: varnishd
-# REQUIRE: DAEMON
-
-. /etc/rc.subr
-
-name="varnishd"
-rcvar=$name
-command="@PREFIX@/sbin/varnishd"
-
-load_rc_config $name
-run_rc_command "$1"
diff --git a/varnish/files/varnishlog.sh b/varnish/files/varnishlog.sh
deleted file mode 100644 (file)
index 7e1536e..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-#!@RCD_SCRIPTS_SHELL@
-#
-# PROVIDE: varnishlog
-# REQUIRE: varnishd
-
-. /etc/rc.subr
-
-name="varnishlog"
-rcvar=$name
-command="@PREFIX@/bin/varnishlog"
-command_args="-D"
-
-load_rc_config $name
-run_rc_command "$1"
diff --git a/varnish/files/varnishncsa.sh b/varnish/files/varnishncsa.sh
deleted file mode 100644 (file)
index 98122d6..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-#!@RCD_SCRIPTS_SHELL@
-#
-# PROVIDE: varnishncsa
-# REQUIRE: varnishd
-
-. /etc/rc.subr
-
-name="varnishncsa"
-rcvar=$name
-command="@PREFIX@/bin/varnishncsa"
-command_args="-D"
-
-load_rc_config $name
-run_rc_command "$1"
diff --git a/varnish/patches/patch-bin_varnishd_cache_cache__panic.c b/varnish/patches/patch-bin_varnishd_cache_cache__panic.c
deleted file mode 100644 (file)
index 3298566..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-$NetBSD$
-
-Need sys/cdefs.h for __BEGIN_DECLS/__END_DECLS.
-
---- bin/varnishd/cache/cache_panic.c.orig      2021-03-12 15:02:41.000000000 +0000
-+++ bin/varnishd/cache/cache_panic.c
-@@ -31,6 +31,10 @@
- #include "config.h"
-+#ifdef __NetBSD__
-+#include <sys/cdefs.h>
-+#endif
-+
- #ifdef WITH_UNWIND
- #  include <libunwind.h>
- #else
diff --git a/varnish/patches/patch-etc_Makefile.in b/varnish/patches/patch-etc_Makefile.in
deleted file mode 100644 (file)
index 0ab081c..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-$NetBSD$
-
-Use standard sysconfdir for vcl files.
-
---- etc/Makefile.in.orig       2021-03-15 11:36:30.000000000 +0000
-+++ etc/Makefile.in
-@@ -157,7 +157,7 @@ am__uninstall_files_from_dir = { \
-     || { echo " ( cd '$$dir' && rm -f" $$files ")"; \
-          $(am__cd) "$$dir" && rm -f $$files; }; \
-   }
--am__installdirs = "$(DESTDIR)$(docdir)" "$(DESTDIR)$(vcldir)"
-+am__installdirs = "$(DESTDIR)$(sysconfdir)" "$(DESTDIR)$(vcldir)"
- DATA = $(dist_doc_DATA) $(dist_vcl_DATA)
- am__extra_recursive_targets = recheck-recursive
- am__tagged_files = $(HEADERS) $(SOURCES) $(TAGS_FILES) $(LISP)
-@@ -380,18 +380,18 @@ clean-libtool:
-       -rm -rf .libs _libs
- install-dist_docDATA: $(dist_doc_DATA)
-       @$(NORMAL_INSTALL)
--      @list='$(dist_doc_DATA)'; test -n "$(docdir)" || list=; \
-+      @list='$(dist_doc_DATA)'; test -n "$(sysconfdir)" || list=; \
-       if test -n "$$list"; then \
--        echo " $(MKDIR_P) '$(DESTDIR)$(docdir)'"; \
--        $(MKDIR_P) "$(DESTDIR)$(docdir)" || exit 1; \
-+        echo " $(MKDIR_P) '$(DESTDIR)$(sysconfdir)'"; \
-+        $(MKDIR_P) "$(DESTDIR)$(sysconfdir)" || exit 1; \
-       fi; \
-       for p in $$list; do \
-         if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
-         echo "$$d$$p"; \
-       done | $(am__base_list) | \
-       while read files; do \
--        echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(docdir)'"; \
--        $(INSTALL_DATA) $$files "$(DESTDIR)$(docdir)" || exit $$?; \
-+        echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(sysconfdir)'"; \
-+        $(INSTALL_DATA) $$files "$(DESTDIR)$(sysconfdir)" || exit $$?; \
-       done
- uninstall-dist_docDATA:
-@@ -465,7 +465,7 @@ check-am: all-am
- check: check-am
- all-am: Makefile $(DATA)
- installdirs:
--      for dir in "$(DESTDIR)$(docdir)" "$(DESTDIR)$(vcldir)"; do \
-+      for dir in "$(DESTDIR)$(sysconfdir)" "$(DESTDIR)$(vcldir)"; do \
-         test -z "$$dir" || $(MKDIR_P) "$$dir"; \
-       done
- install: install-am
diff --git a/varnish/patches/patch-include_tbl_params.h b/varnish/patches/patch-include_tbl_params.h
deleted file mode 100644 (file)
index 3b21cfd..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-$NetBSD$
-
-Change some defaults limits to cover NetBSD defaults.
-
---- include/tbl/params.h.orig  2021-03-12 15:02:41.000000000 +0000
-+++ include/tbl/params.h
-@@ -856,7 +856,7 @@ PARAM_SIMPLE(
-       /* name */      tcp_keepalive_intvl,
-       /* type */      timeout,
-       /* min */       "1",
--      /* max */       "100",
-+      /* max */       "150",
-       /* def */       NULL,
-       /* units */     "seconds",
-       /* descr */
-@@ -889,7 +889,7 @@ PARAM_SIMPLE(
-       /* name */      tcp_keepalive_time,
-       /* type */      timeout,
-       /* min */       "1",
--      /* max */       "7200",
-+      /* max */       "14400",
-       /* def */       NULL,
-       /* units */     "seconds",
-       /* descr */