go-bindata: add version 3.6.0
authorFrédéric Fauberteau <triaxx@NetBSD.org>
Tue, 4 Aug 2020 21:10:44 +0000 (21:10 +0000)
committerFrédéric Fauberteau <triaxx@NetBSD.org>
Tue, 4 Aug 2020 21:10:44 +0000 (21:10 +0000)
A small utility which generates Go code from any file. Useful for
embedding binary data in a Go program.

Makefile
go-bindata/DESCR [new file with mode: 0644]
go-bindata/Makefile [new file with mode: 0644]
go-bindata/PLIST [new file with mode: 0644]
go-bindata/distinfo [new file with mode: 0644]

index 8f6766a5f15deaab36ae5c6007a2beb9c657e6b3..f1238cfdeb84003c3b6a499eb3711591ade4a467 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1193,6 +1193,7 @@ SUBDIR+=  gnuradio-zeromq
 SUBDIR+=       gnutls-guile
 SUBDIR+=       go115
 SUBDIR+=       go-backoff
+SUBDIR+=       go-bindata
 SUBDIR+=       go-collectd
 SUBDIR+=       go-dotenv
 SUBDIR+=       go-flags
diff --git a/go-bindata/DESCR b/go-bindata/DESCR
new file mode 100644 (file)
index 0000000..0190621
--- /dev/null
@@ -0,0 +1,7 @@
+This package converts any file into managable Go source code. Useful for
+embedding binary data into a go program. The file data is optionally gzip
+compressed before being converted to a raw byte slice.
+
+It comes with a command line tool in the go-bindata sub directory. This tool
+offers a set of command line options, used to customize the output being
+generated.
diff --git a/go-bindata/Makefile b/go-bindata/Makefile
new file mode 100644 (file)
index 0000000..88fe981
--- /dev/null
@@ -0,0 +1,17 @@
+# $NetBSD: $
+
+DISTNAME=      go-bindata-3.6.0
+CATEGORIES=    devel
+MASTER_SITES=  ${MASTER_SITE_GITHUB:=shuLhan/}
+GITHUB_TAG=    v${PKGVERSION_NOREV}
+
+MAINTAINER=    triaxx@NetBSD.org
+HOMEPAGE=      https://github.com/shuLhan/go-bindata
+COMMENT=       Small utility to generate Go code from any file
+LICENSE=       cc0-1.0-universal
+
+GO_SRCPATH=    github.com/shuLhan/go-bindata
+GO_DIST_BASE=  ${DISTNAME}
+
+.include "../../lang/go/go-package.mk"
+.include "../../mk/bsd.pkg.mk"
diff --git a/go-bindata/PLIST b/go-bindata/PLIST
new file mode 100644 (file)
index 0000000..aaec8eb
--- /dev/null
@@ -0,0 +1,111 @@
+@comment $NetBSD$
+bin/go-bindata
+gopkg/pkg/${GO_PLATFORM}/github.com/shuLhan/go-bindata.a
+gopkg/src/github.com/shuLhan/go-bindata/AUTHORS
+gopkg/src/github.com/shuLhan/go-bindata/CHANGELOG
+gopkg/src/github.com/shuLhan/go-bindata/CONTRIBUTING.md
+gopkg/src/github.com/shuLhan/go-bindata/LICENSE
+gopkg/src/github.com/shuLhan/go-bindata/Makefile
+gopkg/src/github.com/shuLhan/go-bindata/README.md
+gopkg/src/github.com/shuLhan/go-bindata/assert_test.go
+gopkg/src/github.com/shuLhan/go-bindata/asset.go
+gopkg/src/github.com/shuLhan/go-bindata/bindata.go
+gopkg/src/github.com/shuLhan/go-bindata/cmd/go-bindata/AppendSliceValue.go
+gopkg/src/github.com/shuLhan/go-bindata/cmd/go-bindata/main.go
+gopkg/src/github.com/shuLhan/go-bindata/cmd/go-bindata/main_test.go
+gopkg/src/github.com/shuLhan/go-bindata/config.go
+gopkg/src/github.com/shuLhan/go-bindata/config_test.go
+gopkg/src/github.com/shuLhan/go-bindata/debug.go
+gopkg/src/github.com/shuLhan/go-bindata/doc.go
+gopkg/src/github.com/shuLhan/go-bindata/fsscanner.go
+gopkg/src/github.com/shuLhan/go-bindata/fsscanner_test.go
+gopkg/src/github.com/shuLhan/go-bindata/go.mod
+gopkg/src/github.com/shuLhan/go-bindata/input_config.go
+gopkg/src/github.com/shuLhan/go-bindata/input_config_test.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/_bindata_test.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/inputDir/assert_test.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/inputDir/bindata.exp
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/inputDir/bindata_test.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/inputDir/main.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/inputDirRecursive/assert_test.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/inputDirRecursive/bindata.exp
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/inputDirRecursive/bindata_test.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/inputDirRecursive/main.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/inputDuplicateDir/assert_test.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/inputDuplicateDir/bindata.exp
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/inputDuplicateDir/bindata_test.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/inputDuplicateDir/main.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/inputDuplicateFile/assert_test.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/inputDuplicateFile/bindata.exp
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/inputDuplicateFile/bindata_test.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/inputDuplicateFile/main.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/inputFile/assert_test.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/inputFile/bindata.exp
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/inputFile/bindata_test.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/inputFile/main.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/inputSymlinkRecursive/assert_test.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/inputSymlinkRecursive/bindata.exp
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/inputSymlinkRecursive/bindata_test.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/inputSymlinkRecursive/main.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/inputSymlinkToDir/assert_test.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/inputSymlinkToDir/bindata.exp
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/inputSymlinkToDir/bindata_test.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/inputSymlinkToDir/main.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/inputSymlinkToFile/assert_test.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/inputSymlinkToFile/bindata.exp
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/inputSymlinkToFile/bindata_test.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/inputSymlinkToFile/main.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/withDebug/assert_test.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/withDebug/bindata.exp
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/withDebug/bindata_test.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/withDebug/main.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/withNoCompress/assert_test.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/withNoCompress/bindata.exp
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/withNoCompress/bindata_test.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/withNoCompress/main.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/withNoCompressNoMemCopy/assert_test.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/withNoCompressNoMemCopy/bindata.exp
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/withNoCompressNoMemCopy/bindata_test.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/withNoCompressNoMemCopy/main.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/withNoMemCopy/assert_test.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/withNoMemCopy/bindata.exp
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/withNoMemCopy/bindata_test.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/withNoMemCopy/main.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/withSplit/assert_test.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/withSplit/bindata.exp
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/withSplit/bindataInSplitTest1.exp
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/withSplit/bindataInSplitTest2.exp
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/withSplit/bindata_test.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/withSplit/main.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/withoutOutputFlag/assert_test.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/withoutOutputFlag/bindata.exp
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/withoutOutputFlag/bindata_test.go
+gopkg/src/github.com/shuLhan/go-bindata/internal/tests/withoutOutputFlag/main.go
+gopkg/src/github.com/shuLhan/go-bindata/release.go
+gopkg/src/github.com/shuLhan/go-bindata/release_template.go
+gopkg/src/github.com/shuLhan/go-bindata/release_test.go
+gopkg/src/github.com/shuLhan/go-bindata/restore.go
+gopkg/src/github.com/shuLhan/go-bindata/stringwriter.go
+gopkg/src/github.com/shuLhan/go-bindata/template.go
+gopkg/src/github.com/shuLhan/go-bindata/testdata/dupname/foo/bar
+gopkg/src/github.com/shuLhan/go-bindata/testdata/dupname/foo_bar
+gopkg/src/github.com/shuLhan/go-bindata/testdata/in/a/test.asset
+gopkg/src/github.com/shuLhan/go-bindata/testdata/in/b/test.asset
+gopkg/src/github.com/shuLhan/go-bindata/testdata/in/c/test.asset
+gopkg/src/github.com/shuLhan/go-bindata/testdata/in/file name
+gopkg/src/github.com/shuLhan/go-bindata/testdata/in/split/test.1
+gopkg/src/github.com/shuLhan/go-bindata/testdata/in/split/test.2
+gopkg/src/github.com/shuLhan/go-bindata/testdata/in/test.asset
+gopkg/src/github.com/shuLhan/go-bindata/testdata/symlinkFile/file1
+gopkg/src/github.com/shuLhan/go-bindata/testdata/symlinkParent/symlinkTarget
+gopkg/src/github.com/shuLhan/go-bindata/testdata/symlinkRecursiveParent/file1
+gopkg/src/github.com/shuLhan/go-bindata/testdata/symlinkRecursiveParent/symlinkTarget
+gopkg/src/github.com/shuLhan/go-bindata/testdata/symlinkSrc/file1
+gopkg/src/github.com/shuLhan/go-bindata/testdata/symlinkSrc/file2
+gopkg/src/github.com/shuLhan/go-bindata/testdata/symlinkSrc/file3
+gopkg/src/github.com/shuLhan/go-bindata/testdata/symlinkSrc/file4
+gopkg/src/github.com/shuLhan/go-bindata/toc.go
+gopkg/src/github.com/shuLhan/go-bindata/translate.go
+gopkg/src/github.com/shuLhan/go-bindata/translateToDir.go
+gopkg/src/github.com/shuLhan/go-bindata/translateToFile.go
+gopkg/src/github.com/shuLhan/go-bindata/translate_common.go
diff --git a/go-bindata/distinfo b/go-bindata/distinfo
new file mode 100644 (file)
index 0000000..d68bda4
--- /dev/null
@@ -0,0 +1,6 @@
+$NetBSD$
+
+SHA1 (go-bindata-3.6.0.tar.gz) = 926506401f3b75bf8bd1f91a188ddd668bf2410e
+RMD160 (go-bindata-3.6.0.tar.gz) = 83752855416a1b7f9122aa76a14996fe38a9f69c
+SHA512 (go-bindata-3.6.0.tar.gz) = ee0b887d96cdabd61626bcb9159c58fa9609eecabd6317e6d6aaf87af43cd4b5386f4ed48018de3a8e66302768baacdda2a9e68440fd3381cbc00cfd317bff6b
+Size (go-bindata-3.6.0.tar.gz) = 37373 bytes