(cross/retro68) rename Retro68 to retro68 per @ryoon, tks
authorMakoto Fujiwara <makoto@if.t.u-tokyo.ac.jp>
Tue, 30 Jan 2024 14:18:41 +0000 (23:18 +0900)
committerMakoto Fujiwara <makoto@if.t.u-tokyo.ac.jp>
Tue, 30 Jan 2024 14:18:41 +0000 (23:18 +0900)
retro68/DESCR [new file with mode: 0644]
retro68/Makefile [new file with mode: 0644]
retro68/PLIST [new file with mode: 0644]
retro68/TODO [new file with mode: 0644]
retro68/distinfo [new file with mode: 0644]
retro68/patches/patch-LaunchAPPL_Client_MiniVMac.cc [new file with mode: 0644]
retro68/patches/patch-PEFTools_MakePEF.cc [new file with mode: 0644]
retro68/patches/patch-ResourceFiles_ResourceFile.cc [new file with mode: 0644]
retro68/patches/patch-gcc_newlib_libc_include___ansi.h [new file with mode: 0644]
retro68/patches/patch-gcc_newlib_libc_include_sys_config.h [new file with mode: 0644]
retro68/patches/patch-libelf_src_config.h [new file with mode: 0644]

diff --git a/retro68/DESCR b/retro68/DESCR
new file mode 100644 (file)
index 0000000..1db115e
--- /dev/null
@@ -0,0 +1,23 @@
+todo:  Adjust the following lines from README.md
+
+Retro68
+=======
+
+A GCC-based cross-compilation environment for 68K and PowerPC Macs.
+Why? Because there is no decent C++17 Compiler targeting Apple's System 6.
+If that's not a sufficient reason for you, I'm sure you will find
+something more useful elsewhere.
+
+If you are crazy enough to try it out, please say hello at
+wolfgang.thaller@gmx.net.
+
+Installing/Building
+-------------------
+
+### Prerequisites
+
+- Linux, Mac OS X or Windows (via Cygwin)
+- boost
+- CMake 3.9 or later
+- GCC dependencies: GMP 4.2+, MPFR 2.3.1+ and MPC 0.8.0+
+...
diff --git a/retro68/Makefile b/retro68/Makefile
new file mode 100644 (file)
index 0000000..ec4d6b6
--- /dev/null
@@ -0,0 +1,105 @@
+# $NetBSD$
+
+VERSION=       2019.8.2
+DISTNAME=      Retro68-${VERSION}
+CATEGORIES=    cross
+MASTER_SITES=  ${MASTER_SITE_GITHUB:=autc04/}
+GITHUB_TAG=    v${VERSION}
+
+MAINTAINER=    pkgsrc-users@NetBSD.org
+HOMEPAGE=      https://github.com/autc04/Retro68/
+COMMENT=       M68k cross compiler environment
+LICENSE=       gnu-gpl-v3
+
+USE_TOOLS+=            pkg-config gmake
+USE_PKGLOCALEDIR=      yes
+USE_LANGUAGES=         c c++ fortran
+
+#RKSRC=                ${WRKDIR}/${DISTNAME}
+CPPFLAGS+=     -Iinclude/libhfs
+CFLAGS+=       -Ihfsutils/libhfs
+
+# check-portability
+SUBST_CLASSES=         equal-test
+SUBST_STAGE.equal-test=        pre-configure
+SUBST_SED.equal-test=  '-e s," == "," = " ,'
+SUBST_FILES.equal-test=        \
+       binutils/binutils/testsuite/binutils-all/dlltool.exp \
+       binutils/binutils/testsuite/binutils-all/objcopy.exp \
+       binutils/gas/testsuite/lib/gas-defs.exp \
+       binutils/ld/pe-dll.c \
+       binutils/ld/scripttempl/elfarc.sc \
+       binutils/ld/scripttempl/elfarcv2.sc \
+       binutils/ld/testsuite/ChangeLog-2012 \
+       binutils/ld/testsuite/ld-bootstrap/bootstrap.exp \
+       binutils/ld/testsuite/ld-elf/binutils.exp \
+       binutils/ld/testsuite/ld-x86-64/x86-64.exp \
+       binutils/ld/testsuite/lib/ld-lib.exp \
+       binutils/opcodes/bfin-dis.c \
+       gcc/contrib/ChangeLog \
+       gcc/contrib/dg-extract-results.sh \
+       gcc/contrib/download_prerequisites \
+       gcc/contrib/reghunt/bin/reg-hunt \
+       gcc/contrib/repro_fail \
+       gcc/gcc/ada/repinfo.adb \
+       gcc/gcc/ada/xeinfo.adb \
+       gcc/gcc/d/dmd/hdrgen.c \
+       gcc/gcc/genattrtab.c \
+       gcc/gcc/go/gofrontend/expressions.cc \
+       gcc/gcc/testsuite/gcc.dg/pr28685-1.c \
+       gcc/gcc/testsuite/gcc.dg/tree-ssa/forwprop-15.c \
+       gcc/gcc/testsuite/gcc.target/s390/s390.exp \
+       gcc/gcc/testsuite/gcc.test-framework/gen_directive_tests \
+       gcc/gcc/testsuite/gdc.test/compilable/fix17335.d \
+       gcc/gcc/testsuite/gdc.test/compilable/interpret3.d \
+       gcc/gcc/testsuite/gdc.test/runnable/constfold.d \
+       gcc/gcc/testsuite/gdc.test/runnable/template4.d \
+       gcc/gcc/testsuite/gdc.test/runnable/test12.d \
+       gcc/gcc/testsuite/go.test/go-test.exp \
+       gcc/gcc/testsuite/go.test/test/fixedbugs/bug425.go \
+       gcc/gcc/testsuite/jit.dg/jit.exp \
+       gcc/gcc/testsuite/lib/asan-dg.exp \
+       gcc/gcc/testsuite/lib/gcc-defs.exp \
+       gcc/gcc/testsuite/lib/gcc-dg.exp \
+       gcc/gcc/testsuite/lib/objc.exp \
+       gcc/gcc/testsuite/lib/target-supports.exp \
+       gcc/libatomic/testsuite/lib/libatomic.exp \
+       gcc/libffi/testsuite/lib/libffi.exp \
+       gcc/libgo/go/go/constant/value_test.go \
+       gcc/libgo/go/go/types/eval_test.go \
+       gcc/libgo/go/html/template/js.go \
+       gcc/libgo/go/html/template/js_test.go \
+       gcc/libgo/go/net/http/h2_bundle.go \
+       gcc/libgo/go/runtime/runtime_test.go \
+       gcc/libgo/mksysinfo.sh \
+       gcc/libgomp/testsuite/lib/libgomp.exp \
+       gcc/libitm/testsuite/lib/libitm.exp \
+       gcc/libphobos/libdruntime/core/time.d \
+       gcc/libphobos/src/std/conv.d \
+       gcc/libphobos/src/std/regex/internal/kickstart.d \
+       gcc/libphobos/src/std/variant.d \
+       gcc/libstdc++-v3/doc/html/manual/appendix_porting.html \
+       gcc/libstdc++-v3/doc/xml/manual/build_hacking.xml \
+       gcc/libstdc++-v3/include/bits/locale_facets.tcc \
+       gcc/libstdc++-v3/testsuite/22_locale/collate/compare/char/2.cc \
+       gcc/libstdc++-v3/testsuite/22_locale/collate/compare/wchar_t/2.cc \
+       gcc/libstdc++-v3/testsuite/22_locale/collate/hash/char/2.cc \
+       gcc/libstdc++-v3/testsuite/22_locale/collate/hash/wchar_t/2.cc \
+       gcc/libstdc++-v3/testsuite/22_locale/collate/transform/char/2.cc \
+       gcc/libstdc++-v3/testsuite/22_locale/collate/transform/wchar_t/2.cc \
+       gcc/libstdc++-v3/testsuite/22_locale/collate_byname/named_equivalence.cc \
+       gcc/libstdc++-v3/testsuite/lib/libstdc++.exp \
+       gcc/libvtv/testsuite/lib/libvtv.exp
+
+
+
+PKGCONFIG_OVERRIDE+=   binutils/zlib/contrib/minizip/minizip.pc.in
+PKGCONFIG_OVERRIDE+=   binutils/zlib/zlib.pc.in
+PKGCONFIG_OVERRIDE+=   gcc/libffi/libffi.pc.in
+PKGCONFIG_OVERRIDE+=   gcc/zlib/contrib/minizip/minizip.pc.in
+PKGCONFIG_OVERRIDE+=   gcc/zlib/zlib.pc.in
+
+.include "../../devel/cmake/build.mk"
+.include "../../devel/boost-libs/buildlink3.mk"
+.include "../../devel/libhfs/buildlink3.mk"
+.include "../../mk/bsd.pkg.mk"
diff --git a/retro68/PLIST b/retro68/PLIST
new file mode 100644 (file)
index 0000000..92ba51a
--- /dev/null
@@ -0,0 +1,4 @@
+@comment $NetBSD$
+@comment TODO: to fill this file with the file listing:
+@comment TODO: 1. run "/usr/bin/make package"
+@comment TODO: 2. run "/usr/bin/make print-PLIST"
diff --git a/retro68/TODO b/retro68/TODO
new file mode 100644 (file)
index 0000000..76a00e6
--- /dev/null
@@ -0,0 +1,55 @@
+SX2@makoto 23:06:42/240130(..wip/Retro68)%  make |& tee /tmp/log                                                               
+=> Bootstrap dependency digest>=20211023: found digest-20220214
+===> Skipping vulnerability checks.
+WARNING: No /usr/pkg/pkgdb/pkg-vulnerabilities file found.
+WARNING: To fix run: `/usr/pkg/sbin/pkg_admin -K /usr/pkg/pkgdb fetch-pkg-vulnerabilities'.
+===> Building for Retro68-2019.8.2
+[  2%] Built target LaunchAPPLCommon
+[  3%] Building CXX object PEFTools/CMakeFiles/MakePEF.dir/MakePEF.cc.o
+[  6%] Built target ResourceFiles
+[  7%] Building CXX object LaunchAPPL/Common/CMakeFiles/TestLaunchAPPLCommon.dir/Test.cc.o
+[  8%] Building CXX object PEFTools/CMakeFiles/MakeImport.dir/MakeImport.cc.o
+[  8%] Building CXX object ConvertObj/CMakeFiles/ConvertObj.dir/ConvertObj.cc.o
+[  8%] Building CXX object ResourceFiles/CMakeFiles/ResInfo.dir/ResInfo.cc.o
+[  9%] Building CXX object LaunchAPPL/Client/CMakeFiles/LaunchAPPL.dir/LaunchAPPL.cc.o
+[ 83%] Built target ELF
+[ 83%] Building CXX object LaunchAPPL/Client/CMakeFiles/LaunchAPPL.dir/MakeExecutable.cc.o
+[ 84%] Building CXX object LaunchAPPL/Client/CMakeFiles/LaunchAPPL.dir/LaunchMethod.cc.o
+In file included from /tmp/wip/Retro68/work/Retro68-2019.8.2/PEFTools/../gcc/newlib/libc/include/sys/config.h:5,
+                 from /tmp/wip/Retro68/work/Retro68-2019.8.2/PEFTools/../gcc/newlib/libc/include/_ansi.h:11,
+                 from /tmp/wip/Retro68/work/Retro68-2019.8.2/PEFTools/../gcc/newlib/libc/include/alloca.h:10,
+                 from /tmp/wip/Retro68/work/Retro68-2019.8.2/PEFTools/MakePEF.cc:9:
+/tmp/wip/Retro68/work/Retro68-2019.8.2/PEFTools/../gcc/newlib/libc/include/sys/features.h:28:10: fatal error: _newlib_version.h: No such file or directory
+   28 | #include <_newlib_version.h>
+      |          ^~~~~~~~~~~~~~~~~~~
+compilation terminated.
+gmake[2]: *** [PEFTools/CMakeFiles/MakePEF.dir/build.make:76: PEFTools/CMakeFiles/MakePEF.dir/MakePEF.cc.o] Error 1
+gmake[1]: *** [CMakeFiles/Makefile2:349: PEFTools/CMakeFiles/MakePEF.dir/all] Error 2
+gmake[1]: *** Waiting for unfinished jobs....
+[ 85%] Building CXX object LaunchAPPL/Client/CMakeFiles/LaunchAPPL.dir/Launcher.cc.o
+In file included from /tmp/wip/Retro68/work/Retro68-2019.8.2/PEFTools/MakeImport.cc:19:
+/tmp/wip/Retro68/work/Retro68-2019.8.2/PEFTools/PEF.h:44:10: fatal error: PEFBinaryFormat.h: No such file or directory
+   44 | #include "PEFBinaryFormat.h"
+      |          ^~~~~~~~~~~~~~~~~~~
+compilation terminated.
+gmake[2]: *** [PEFTools/CMakeFiles/MakeImport.dir/build.make:76: PEFTools/CMakeFiles/MakeImport.dir/MakeImport.cc.o] Error 1
+gmake[1]: *** [CMakeFiles/Makefile2:375: PEFTools/CMakeFiles/MakeImport.dir/all] Error 2
+[ 85%] Building CXX object LaunchAPPL/Client/CMakeFiles/LaunchAPPL.dir/Utilities.cc.o
+[ 86%] Linking CXX executable TestLaunchAPPLCommon
+[ 86%] Built target TestLaunchAPPLCommon
+[ 87%] Building CXX object LaunchAPPL/Client/CMakeFiles/LaunchAPPL.dir/Executor.cc.o
+[ 87%] Building CXX object LaunchAPPL/Client/CMakeFiles/LaunchAPPL.dir/MiniVMac.cc.o
+[ 88%] Building CXX object LaunchAPPL/Client/CMakeFiles/LaunchAPPL.dir/SSH.cc.o
+[ 89%] Building CXX object LaunchAPPL/Client/CMakeFiles/LaunchAPPL.dir/StreamBasedLauncher.cc.o
+[ 90%] Linking CXX executable ConvertObj
+[ 90%] Built target ConvertObj
+[ 90%] Building CXX object LaunchAPPL/Client/CMakeFiles/LaunchAPPL.dir/Serial.cc.o
+[ 91%] Building CXX object LaunchAPPL/Client/CMakeFiles/LaunchAPPL.dir/TCP.cc.o
+[ 92%] Building CXX object LaunchAPPL/Client/CMakeFiles/LaunchAPPL.dir/SharedFile.cc.o
+[ 93%] Linking CXX executable ResInfo
+[ 93%] Built target ResInfo
+/tmp/wip/Retro68/work/Retro68-2019.8.2/LaunchAPPL/Client/SharedFile.cc: In member function 'virtual void SharedFileStream::write(const void*, size_t)':
+/tmp/wip/Retro68/work/Retro68-2019.8.2/LaunchAPPL/Client/SharedFile.cc:51:13: error: 'ofstream' is not a member of 'fs'; did you mean 'std::ofstream'?
+   51 |         fs::ofstream out(shared_directory / "in_channel_1", std::ios::binary);
+      |             ^~~~~~~~
+.... more lines
diff --git a/retro68/distinfo b/retro68/distinfo
new file mode 100644 (file)
index 0000000..82959f5
--- /dev/null
@@ -0,0 +1,11 @@
+$NetBSD$
+
+BLAKE2s (Retro68-2019.8.2.tar.gz) = 1d81caea9babe5882b9bf1549cc84c0c9ada3b2bccf2b47a218df22b23397da8
+SHA512 (Retro68-2019.8.2.tar.gz) = 1d70e6248f915d6947ea95ea7f47d903b94115f582612ecfe4392692f26c855c77b0980088388f4ea2d3d2f11e943b4a568037611aa489b9556ae04751e71ccf
+Size (Retro68-2019.8.2.tar.gz) = 175241148 bytes
+SHA1 (patch-LaunchAPPL_Client_MiniVMac.cc) = 47d8b9dc6706069d5581143ba878814c1462d61d
+SHA1 (patch-PEFTools_MakePEF.cc) = f3f4e71db8d73f98c5e32e6ed1abd09b9535b56f
+SHA1 (patch-ResourceFiles_ResourceFile.cc) = ea73eedfddb408169eb82beef7af132ee99096ef
+SHA1 (patch-gcc_newlib_libc_include___ansi.h) = 8943735eb0a8a9f5143c29b58b45d4bf4a523b21
+SHA1 (patch-gcc_newlib_libc_include_sys_config.h) = b3cee661db099935895c97768477d17d1ca4fdce
+SHA1 (patch-libelf_src_config.h) = 1a5d86716b8aaf16daaa1e17612b691c0afa32cb
diff --git a/retro68/patches/patch-LaunchAPPL_Client_MiniVMac.cc b/retro68/patches/patch-LaunchAPPL_Client_MiniVMac.cc
new file mode 100644 (file)
index 0000000..0b8c26c
--- /dev/null
@@ -0,0 +1,20 @@
+$NetBSD$
+:
+[ 89%] Building CXX object LaunchAPPL/Client/CMakeFiles/LaunchAPPL.dir/SSH.cc.o
+/tmp/wip/Retro68/work/Retro68-2019.8.2/LaunchAPPL/Client/MiniVMac.cc:8:10: fatal error: hfs.h: No such file or directory
+    8 | #include "hfs.h"
+      |          ^~~~~~~
+compilation terminated.
+
+--- LaunchAPPL/Client/MiniVMac.cc.orig 2019-08-24 19:56:10.000000000 +0900
++++ LaunchAPPL/Client/MiniVMac.cc      2024-01-30 22:46:31.665649819 +0900
+@@ -5,7 +5,8 @@
+ #include "ResourceFile.h"
+ extern "C" {
+-#include "hfs.h"
++/* #include "hfs.h" */
++#include "../../hfsutils/libhfs/hfs.h"
+ }
+ #include <iostream>
diff --git a/retro68/patches/patch-PEFTools_MakePEF.cc b/retro68/patches/patch-PEFTools_MakePEF.cc
new file mode 100644 (file)
index 0000000..918d65d
--- /dev/null
@@ -0,0 +1,20 @@
+$NetBSD$
+
+[ 83%] Building CXX object LaunchAPPL/Client/CMakeFiles/LaunchAPPL.dir/LaunchMethod.cc.o
+/tmp/wip/Retro68/work/Retro68-2019.8.2/PEFTools/MakePEF.cc:8:10: fatal error: alloca.h: No such file or directory
+    8 | #include <alloca.h>
+      |          ^~~~~~~~~~
+compilation terminated.
+
+--- PEFTools/MakePEF.cc.orig   2019-08-24 19:56:10.000000000 +0900
++++ PEFTools/MakePEF.cc        2024-01-30 22:19:27.932859420 +0900
+@@ -5,7 +5,8 @@
+ #include <fstream>
+ #include <set>
+ #include <string.h>
+-#include <alloca.h>
++/* #include <alloca.h> */
++#include "../gcc/newlib/libc/include/alloca.h"
+ #include <assert.h>
+ #include <stdint.h>
diff --git a/retro68/patches/patch-ResourceFiles_ResourceFile.cc b/retro68/patches/patch-ResourceFiles_ResourceFile.cc
new file mode 100644 (file)
index 0000000..c1eb309
--- /dev/null
@@ -0,0 +1,18 @@
+$NetBSD$
+
+/tmp/wip/Retro68/work/Retro68-2019.8.2/ResourceFiles/ResourceFile.cc:13:10: fatal error: hfs.h: No such file or directory
+   13 | #include "hfs.h"
+      |          ^~~~~~~
+compilation terminated.
+
+--- ResourceFiles/ResourceFile.cc.orig 2019-08-24 19:56:10.000000000 +0900
++++ ResourceFiles/ResourceFile.cc      2024-01-30 22:13:51.335496105 +0900
+@@ -10,7 +10,7 @@
+ #include <sys/xattr.h>
+ #endif
+ extern "C" {
+-#include "hfs.h"
++#include "libhfs/hfs.h"
+ }
+ namespace fs = boost::filesystem;
diff --git a/retro68/patches/patch-gcc_newlib_libc_include___ansi.h b/retro68/patches/patch-gcc_newlib_libc_include___ansi.h
new file mode 100644 (file)
index 0000000..1134bcc
--- /dev/null
@@ -0,0 +1,22 @@
+$NetBSD$
+
+[ 84%] Building CXX object LaunchAPPL/Client/CMakeFiles/LaunchAPPL.dir/LaunchMethod.cc.o
+In file included from /tmp/wip/Retro68/work/Retro68-2019.8.2/PEFTools/../gcc/newlib/libc/include/alloca.h:10,
+                 from /tmp/wip/Retro68/work/Retro68-2019.8.2/PEFTools/MakePEF.cc:9:
+/tmp/wip/Retro68/work/Retro68-2019.8.2/PEFTools/../gcc/newlib/libc/include/_ansi.h:10:10: fatal error: newlib.h: No such file or directory
+   10 | #include <newlib.h>
+      |          ^~~~~~~~~~
+
+--- PEFTools/../gcc/newlib/libc/include/_ansi.h.orig   2019-08-24 19:56:10.000000000 +0900
++++ PEFTools/../gcc/newlib/libc/include/_ansi.h        2024-01-30 22:41:53.763229405 +0900
+@@ -7,8 +7,8 @@
+ #ifndef       _ANSIDECL_H_
+ #define       _ANSIDECL_H_
+-#include <newlib.h>
+-#include <sys/config.h>
++#include "newlib.h"
++#include "sys/config.h"
+ /*  ISO C++.  */
diff --git a/retro68/patches/patch-gcc_newlib_libc_include_sys_config.h b/retro68/patches/patch-gcc_newlib_libc_include_sys_config.h
new file mode 100644 (file)
index 0000000..bd21d3d
--- /dev/null
@@ -0,0 +1,22 @@
+$NetBSD$
+
+[ 83%] Building CXX object LaunchAPPL/Client/CMakeFiles/LaunchAPPL.dir/LaunchMethod.cc.o
+In file included from /tmp/wip/Retro68/work/Retro68-2019.8.2/PEFTools/../gcc/newlib/libc/include/_ansi.h:11,
+                 from /tmp/wip/Retro68/work/Retro68-2019.8.2/PEFTools/../gcc/newlib/libc/include/alloca.h:10,
+                 from /tmp/wip/Retro68/work/Retro68-2019.8.2/PEFTools/MakePEF.cc:9:
+/tmp/wip/Retro68/work/Retro68-2019.8.2/PEFTools/../gcc/newlib/libc/include/sys/config.h:5:10: fatal error: sys/features.h: No such file or directory
+    5 | #include <sys/features.h> /* POSIX defs */
+      |          ^~~~~~~~~~~~~~~~
+compilation terminated.
+
+--- PEFTools/../gcc/newlib/libc/include/sys/config.h.orig      2024-01-30 22:57:05.167249422 +0900
++++ PEFTools/../gcc/newlib/libc/include/sys/config.h   2024-01-30 22:58:26.400601194 +0900
+@@ -2,7 +2,7 @@
+ #define __SYS_CONFIG_H__
+ #include <machine/ieeefp.h>  /* floating point macros */
+-#include <sys/features.h>     /* POSIX defs */
++#include "features.h" /* POSIX defs */
+ #ifdef __aarch64__
+ #define MALLOC_ALIGNMENT 16
diff --git a/retro68/patches/patch-libelf_src_config.h b/retro68/patches/patch-libelf_src_config.h
new file mode 100644 (file)
index 0000000..bda719a
--- /dev/null
@@ -0,0 +1,19 @@
+$NetBSD$
+
+Endianness
+
+--- libelf/src/config.h.orig   2019-08-24 19:56:10.000000000 +0900
++++ libelf/src/config.h        2024-01-28 08:22:01.334880989 +0900
+@@ -29,6 +29,12 @@
+ #ifndef EU_CONFIG_H
+ #define EU_CONFIG_H   1
++#if defined(__NetBSD__)
++#define __BYTE_ORDER    BYTE_ORDER
++#define __LITTLE_ENDIAN LITTLE_ENDIAN
++#define __BIG_ENDIAN    BIG_ENDIAN
++#endif
++
+ #ifdef USE_LOCKS
+ # include <pthread.h>
+ # include <assert.h>